Windows Defender Antivirus Service zieht 99-100% CPU auf allen Kernen

Deine Frage passt nicht in die anderen Bereiche, dann stelle sie hier.
Javora
Poweruser
Poweruser
Beiträge: 523
Registriert: 24.04.2016, 20:33

Re: Windows Defender Antivirus Service zieht 99-100% CPU auf allen Kernen

Beitrag von Javora » 09.09.2019, 17:34

Hab einmal ein Nicht - Defender - Gerät mit Intel Core i5-6200U umgestellt auf Defender.
CPU - Unterschied also nicht wie Tag und Nacht.
Normale akt. Win 10 Version/ Build und normale akt derzeitige Defenderversion
(System mit Dism…/ sfc… Korrekturen i.Z. Defender).
Priorität MsMpEng.exe war auf normal eingestellt.
Keine Änderung bei Gruppenrichtlinien/ Registry vorgenommen.

Die Auslastung war sehr volatil, zwischen 9 % und 87 % beobachtet (ganz anders als im beispielhaft geposteteten Bild), Abweichungen von 50 % je abnehmend nach unten/ oben; im Mittel vlt. max. 60 % Auslastung. Geprüfte Systemplatte hatte nur ca. 40 GB.

Anschließend einmal in Gruppenrichtlinien
„Angeben des max. Prozentsatzes der CPU-Auslastung während eines Scanvorganges“
auf 50 % gesetzt. Eine Änderung konnte allein damit nicht wahrgenommen werden, m. E. lief dies analog ab. Näher hab ich nicht geschaut. Beim Defender sieht man ja auch nicht, was gerade gescannt wird (es sei denn, es ließe sich irgendwo einstellen).
Schauen könnte man bei Bedarf noch, welche Prozesse außerdem bei höheren Ausschlägen involviert sind.

Abgesehen von etwaigen Alternativen/ Workarounds und überhaupt i.Z.m. Defender , wenn Überbelastung droht, reduziere ich zumindest die max. Prozessorleistung über Energieeinstellungen Win.

Tante Google

Re: Windows Defender Antivirus Service zieht 99-100% CPU auf allen Kernen

Beitrag von Tante Google » 09.09.2019, 17:34




GwenDragon
★ Team Forum ★
Beiträge: 8361
Registriert: 20.07.2014, 12:25
Geschlecht:

Re: Windows Defender Antivirus Service zieht 99-100% CPU auf allen Kernen

Beitrag von GwenDragon » 20.09.2019, 12:10

:dankeschoen: an @ecerer für den Hinweis.

GwenDragon
★ Team Forum ★
Beiträge: 8361
Registriert: 20.07.2014, 12:25
Geschlecht:

Re: Windows Defender Antivirus Service zieht 99-100% CPU auf allen Kernen

Beitrag von GwenDragon » 08.11.2020, 19:38

Leider hat sich Windows 10s Defender auch in 20H2 nicht gebessert. Alle Intel-Kerne auf Volllast.

Wer mal im Büro o.ä Arbeitsplatz ein Laufwerk scannen will, sollte mindestens 2 Stunden ode mehr frei nehmen. Denn trotz des Hinweises von windows Sicherheit, dass man weiter arbeiten kann wenn Defender läuft, geht da oft nichts mehr, weil alle CPU-Kerne auf 99-100% dauerhaft laufen.
Ich sehe mich zu Emsi, AVG und Kaspersky zurück. Die bremsten nicht so ungeheuer. :heulen:

GwenDragon
★ Team Forum ★
Beiträge: 8361
Registriert: 20.07.2014, 12:25
Geschlecht:

Re: Windows Defender Antivirus Service zieht 99-100% CPU auf allen Kernen

Beitrag von GwenDragon » 02.07.2021, 20:05

:heulen: Und wieder das grüßende Murmeltier. 98–100% auf alle 4 Cores. Kein Wunder, dass da der CPU-Lüfter heult. Ist zum Glück kein Laptop.
Ab und an ist der Defender Defender Antivirus/Malware wirklich wenig performant. Ich werde mal weitere Updates morgen abwarten.

GwenDragon
★ Team Forum ★
Beiträge: 8361
Registriert: 20.07.2014, 12:25
Geschlecht:

Re: Windows Defender Antivirus Service zieht 99-100% CPU auf allen Kernen

Beitrag von GwenDragon » 03.07.2021, 19:33

Mensch was ist das für ein Murks, jedes Programm jedesmal braucht in Windows Pro 10.0.19043.1081 so 3-6 Sekunden zum Start nach Klick auf das Icon. Und das sind keine mehrere 100 MB große Dinger.
Ich befürchte Microsoft hat mir wieder mal eine lahme Defenerr-version eingespült :sauer:

Ich hab da:
Antimalware-Clientversion: 4.18.2106.6
Modulversion: 1.1.18300.4
Antiviren-Version: 1.343.322.0
Antispyware-Version: 1.343.322.0

Kann das Bremsen daran liegen dass ich für die i5-7500 fTPM im BIOS aktiviert habe?

Benutzeravatar
DK2000
Legende
Legende
Beiträge: 6045
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: Windows Defender Antivirus Service zieht 99-100% CPU auf allen Kernen

Beitrag von DK2000 » 03.07.2021, 19:56

Liegt bestimmt an der 4.18.2106.6. Die hab ich jetzt ach im Dev bekommen. Gar nicht mitbekommen. Erklärt dann aber wohl, warum alles etwas langsamer startet. In den Restlichen Installationen ist da noch die 4.18.2105.5.

Vermutlich weil ich mit der "4" gespielt hab. Das hat wohl was verändert:

viewtopic.php?f=334&t=25580&p=368314&hi ... ng#p368314

Bin jetzt im Dev wohl wieder drin im Defender Test. Interessanter Weise steht bei mir jetzt das in der Registry:

Code: Alles auswählen

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender\MpEngine]
"MpCampRing"=dword:00000002
"MpEngineRing"=dword:00000002
Alos nichts mehr mit "3" oder "4", sondern "2". Das ist alles sehr seltsam. Mal was testen.

---

Mh? jetzt war ich im Dev kurt auf der 4.18.2105.5, aber das hat wohl nicht gefallen. Jetzt bin ich wieder auf der 4.18.2106.6. Liegt das jetzt am Dev Channel oder passiert das automatisch, weil ich da in der Registry rumgespielt habe?

Benutzeravatar
DK2000
Legende
Legende
Beiträge: 6045
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: Windows Defender Antivirus Service zieht 99-100% CPU auf allen Kernen

Beitrag von DK2000 » 03.07.2021, 21:22

OK, bin jetzt im Retail Channel auch mit der 4.18.2106.6 unterwegs. Das hat auch hier funktioniert:

Code: Alles auswählen

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender\MpEngine]
"MpCampRing"=dword:00000004
"MpEngineRing"=dword:00000004
Das war ja einfach.

Raus bin ich jetzt wieder so gekommen (vorher aber Backup anlegen):

Verbindung zum Internet trennen.

Konsole (cmd.exe; nicht Powershell) mit Adminrechten starten:

Code: Alles auswählen

"%programfiles%\Windows Defender\MpCmdRun.exe" -resetplatform
Neustart. Defender sollte jetzt die Version 4.18.1909.6 haben (19041 InBox). Der Rest sollte Version 0.0.0.0 sein.

Die beiden Einträge in der Registry entfernen, falls noch vorhanden: "MpCampRing" und "MpEngineRing"

Und jetzt kommt der Teil, wo man eine Konsole mit den Rechten des TrustedInstaller (NSudo), um eine Kleinigkeiten zu löschen:

Code: Alles auswählen

rmdir /q /S "C:\ProgramData\Microsoft\Windows Defender\Platform\"
NSudo: https://www.deskmodder.de/blog/2021/06/ ... stuetzung/

Wenn man den Ordner samt Inhalt losgeworden ist, Verbindung zum Internet wieder herstellen und das Windows Update ausführen. Jetzt sollten die beiden Sachen ohne Fehler installiert werden:

Code: Alles auswählen

Update für Microsoft Defender Antivirus-Antischadsoftwareplattform – KB4052623 (Version 4.18.2105.5)
Update für Windows Defender Antivirus-Antischadsoftwareplattform – KB4052623 (Version 4.18.2001.10)
Hier scheint er die 4.18.2105.5 zu halten und nicht wieder auf die 4.18.2106.6 zu aktualisieren.

GwenDragon
★ Team Forum ★
Beiträge: 8361
Registriert: 20.07.2014, 12:25
Geschlecht:

Re: Windows Defender Antivirus Service zieht 99-100% CPU auf allen Kernen

Beitrag von GwenDragon » 04.07.2021, 14:16

Defender zurück gesetzt, Verzeichnis unter Linux geleert. Neu gestartet.
Wieso ums Verrecken steht da beiden Ring 4 drin? Jetzt hat der wieder die 4.18.2106.6 drin. Und die braucht 5–6 Sekunden zum Start jedes Programs.

Macht MS mache zu heimlichen Betatastern!?

Benutzeravatar
DK2000
Legende
Legende
Beiträge: 6045
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: Windows Defender Antivirus Service zieht 99-100% CPU auf allen Kernen

Beitrag von DK2000 » 04.07.2021, 14:30

Defender zurücksetzen, Neustart und jetzt erst Verzeichnis und Einträge in der Registry löschen. Und dabei keine Verbindung zum Internet. Es muss jetzt Version 4.18.1909.6 angezeigt werden. Die Reihenfolge bis hier hin scheint da wichtig zu sein. Nur so hat das bei mir in der Retail geklappt (19043.1081).

Das ist die Frage, was das soll. Im Dev scheine ich da auch wieder in Defender Test zu sein. Da hat er nur kurz mal die 4.18.2105.5 installiert, aber gleich anschließend wieder die 4.18.2106.6. Bei der 21H1 ist es bei 4.18.2105.5 geblieben.

Das war jetzt nur ein Test meinerseits. Keine Ahnung, ob das generell so funktioniert oder nur Zufall war, dass es zweimal geklappt hat. Der Mist ist ja, dass das nirgends offiziell dokumentiert ist und man mit den Einträgen in der Registry experimentieren muss. Auf "4" wäre ich da so nicht gekommen. Aber damit konnte ich im Retail in den Defender Test. Das hatte vorher nicht geklappt. Und im Dev stehen beide Werte jetzt auf "2", davor war es immer "3". Und keine Ahnung, was das zu bedeuten hat.

GwenDragon
★ Team Forum ★
Beiträge: 8361
Registriert: 20.07.2014, 12:25
Geschlecht:

Re: Windows Defender Antivirus Service zieht 99-100% CPU auf allen Kernen

Beitrag von GwenDragon » 04.07.2021, 16:57

@DK2000 War ja auch auf 4.18.1909.6 nachdem ich das gemacht hatte.
Aber beim nächsten Start hat das Windoofs wieder den Defender auf die kaputte Version hoch gestuft.

GwenDragon
★ Team Forum ★
Beiträge: 8361
Registriert: 20.07.2014, 12:25
Geschlecht:

Re: Windows Defender Antivirus Service zieht 99-100% CPU auf allen Kernen

Beitrag von GwenDragon » 04.07.2021, 17:26

Wie gesagt, zum zweiten Mal getestet. Dasselbe. Erst war die 1909.6 drauf, dann nach Windows Update die kaputte. Muss ich wohl mit leben.

GwenDragon
★ Team Forum ★
Beiträge: 8361
Registriert: 20.07.2014, 12:25
Geschlecht:

Re: Windows Defender Antivirus Service zieht 99-100% CPU auf allen Kernen

Beitrag von GwenDragon » 27.07.2021, 13:49

Es wird immer schlimmer mit dem Defender. Jetzt friert teilweise Windows 1--2 Minuten ein.
Win 10 x64 Pro 21H1 (10.0.19043.1110)
Antimalware-Clientversion: 4.18.2107.4
Modulversion: 1.1.18300.4
Antiviren-Version: 1.343.1753.0
Antispyware-Version: 1.343.1753.0

Benutzeravatar
DK2000
Legende
Legende
Beiträge: 6045
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: Windows Defender Antivirus Service zieht 99-100% CPU auf allen Kernen

Beitrag von DK2000 » 27.07.2021, 14:16

Ja, macht er bei mir mit Windows 11 auch. Nur da habe ich im Moment den 4.18.2107.4. Der behebt zwar da das Problem mit dem nicht startenden Dienst von Defender, aber irgendwie läuft der Scanner nicht so ganz rund.

Antworten