Hartnäckige Probleme mit Windows-Updates

Du hast Fragen zur Sicherung, Reparatur oder Fehlermeldungen in Windows 10?
jamacoe
Neuling
Neuling
Beiträge: 9
Registriert: 10.06.2021, 10:57
Geschlecht:

Hartnäckige Probleme mit Windows-Updates

Beitrag von jamacoe » 11.06.2021, 19:14

Hallo liebe Deskmodder,

ich habe (für mich) unlösbare Probleme mit meinem Windows 10 Pro - Notebook (Vers. 2004, 19041.388, Build 19041.vb_release.191206-1406) und probiere seit vielen Monaten, dem irgendwie auf den Grund zu gehen.

Folgende Probleme bestehen:

1.) Windows Update:
- 2021-03 Update für Windows 10 Vers. 2004 für x64 (KB4023057)
Das System hat mMn immer noch 19041.388 (Win 2004) und macht seither keine Updates mehr
- Funktionsupdate f Win 10, Vers. 20H2
Trotzdem wird versucht, ein Update für 20H2 zu installieren.

Beide Updates geben immer Error 0x80070057 (Fehlerhafter Parameter), wobei für KB4023057 "Downloadfehler" angezeigt wird, das Funktionsupdate hingegen 100% Installation anzeigt und erst dann auf 0x80070057 umspringt (Updateverlauf).

Es funktionieren aber regelmäßig alle anderen Updates, d.h. Treiber-, Definitions-, Sicherheits-, Office-, .NET Core, Kumulative .NET-Framework usw.

2.) Die Liste der Windows-Features ist leer.

3.) Der DISM-Befehl gibt bei vielen Befehlen (aber nicht allen) Error 87:
PS> Dism /online /Get-Features
Tool zur Imageverwaltung für die Bereitstellung
Version: 10.0.19041.329
Abbildversion: 10.0.19041.388
Fehler: 87
Fehler beim Verarbeiten des Befehls.
Stellen Sie sicher, dass die Befehlszeilenargumente gültig sind.
Weitere Informationen finden Sie in der Protokolldatei.
Die DISM-Protokolldatei befindet sich unter "C:\WINDOWS\Logs\DISM\dism.log".
---

PS> Get-WindowsOptionalFeature
Fehler: Der Parametersatz kann mit den angegebenen benannten Parametern nicht aufgelöst werden.
In Zeile:1 Zeichen:1
+ Get-WindowsOptionalFeature
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidArgument: (:) [Get-WindowsOptionalFeature], ParameterBindingException
+ FullyQualifiedErrorId : AmbiguousParameterSet,Microsoft.Dism.Commands.GetWindowsOptionalFeatureCommand
---

PS> Get-WindowsOptionalFeature -Online
Get-WindowsOptionalFeature : Falscher Parameter.
In Zeile:1 Zeichen:1
+ Get-WindowsOptionalFeature -Online
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [Get-WindowsOptionalFeature], PSArgumentException
+ FullyQualifiedErrorId : Microsoft.Dism.Commands.GetWindowsOptionalFeatureCommand

Ich habe so ziemlich alles 100-fach probiert, was im Internet so an Tipps kursiert:

- Safe Boot
- DISM /online /cleanup-image /restorehealth (keine Fehler)
- ISO für 19041 geladen, wim entpackt und den DISM-Befehl mit /source-Angabe verwendet: Keine Fehler
- sfc /scannow - keine Fehler
- sämtiche Optionen des "Reset Windows Update Tool"
- Windows Update Troubleshooter: Findet Probleme:
Nach Windows Update-Problemen suchen - Emittelt - [!]
Windows-Update-Probleme beheben: Abgeschlossen
Erkennungsdetails:
WaaSMedicService: Problem gefunden von:ServiceHealthPlugin
Service Status: Problem mit dem BITS-Dienst: Der angeforderte Dienst wurde bereits gestartet.
Wiederholte Ausführung des Troubleshooters läßt diese Probleme nicht verschwinden.
- IONOS-Tipp: Umstieg auf altes WinUpdateApplet mittels Registry-Einträgen:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsUpdate\UX] „IsConvergedUpdateStackEnabled“=dword:00000000
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsUpdate\UX\Settings] „UxOption“=dword:00000000 (Default scheint hier "2" zu sein, zumindest bei einer anderen Installation)
- HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate löschen
- manuelle Downloads und Installationsversuche der entsprechenden MSUs/CABs aus Windows Catalog (mittels wusa.exe)
- auch MSUs entpackt und CAB-Installation probiert mit pkgmgr.exe sowie mit DISM /Online /Add-Package /PackagePath:"<...>.cab" probiert.
- Und last-but-not-least: Inplace Repair mit ISO Setup: wird nach Reboot bei 0% abgebrochen und dann rückgänging gemacht: 0x8007001F - 0x20006 (Phase SAFE_OS, Vorgang REPLICATE_OC)
- probiert mit Firewall disabled
- probietr mit bcdedit hypervisor an/aus
- Windows Trusted Installer - Prozessstart auf Automatisch gesetzt: Prozess läuft

- es ist ausreichend Festplatte frei
- Keine Antiviren-Software außer Windows Defender
- Windows ist korrekt lizensiert und aktiviert (slmgr /dlv)
- sämtliche Peripherie entfernt
- neuestes BIOS-Update erfolgt

Logs: Da habe ich einiges an Fehlern gefunden, komme aber mit der Interpretation und benötigten Aktionen nicht weiter. Vielleicht kann mir hier bitte jemand helfen.

* DISM.Log (08:15:32 - 08:20:17) https://pastebin.com/cyamLf3K
* CBS.Log (08:15:33 - 08:19:40) https://pastebin.com/FTBm9wbZ
* WindowsUpdate.log (08:20:28.8474562 - 08:33:48.5930548) https://pastebin.com/Sc0pmCEr
* SetupDiagResults.log (nach dem gescheiterten Inplace-Update und Rollback) inkl. aller Maschinendaten:https://pastebin.com/1MDqDc15

Tante Google

Hartnäckige Probleme mit Windows-Updates

Beitrag von Tante Google » 11.06.2021, 19:14


Benutzeravatar
DK2000
Legende
Legende
Beiträge: 5372
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: Hartnäckige Probleme mit Windows-Updates

Beitrag von DK2000 » 11.06.2021, 20:30

Mich wundert da irgendwie, dass DISM /online /cleanup-image /restorehealth keine Fehler findet.

KB5000983 lasse erst einmal weg. KB4023057 ist auch erst einmal uninteressant.

Wenn Du erneut DISM /online /cleanup-image /restorehealth ausführst, zeigt dass wirklich an, das keine Fehler gefunden wurden?

Und lasse mal die Modifikatonen von IONOS weg. Das ist was ganz anderes.

Das scheint auch so ein Fall zu sein, wo das Inplace Upgrade scheitert. Das hängt hiermit zusammen: Dism /online /Get-Features -> Fehler: 87

Was mich gerade interessiert, das Paket "Foundation-Package" ist fehlerfrei? Gebe mal in der Powershell ein:

Code: Alles auswählen

Get-FileHash C:\WINDOWS\Servicing\Packages\Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~10.0.19041.1.mum
SHA256: 8A1A78B46709AFAB0E410BC44171F5B247FD8250F5E951F3A0798580021887C3

Vergleiche mal den Hash.

Alles sehr unübersichtlich in der CBS.log.

jamacoe
Neuling
Neuling
Beiträge: 9
Registriert: 10.06.2021, 10:57
Geschlecht:

Re: Hartnäckige Probleme mit Windows-Updates

Beitrag von jamacoe » 12.06.2021, 09:07

Danke Dir für Deine Antwort, @DK2000.

Die IONOS-Modifikation hatte ich schon zurückgenommen.

Der Hash für Foundation stimmt und ja, DISM liefert keine Fehler. Hier ein Screenshot.
Bild

Die zu diesem gerade durchgeführten 'DISM /online /cleanup-image /restorehealth' gehörigen DISM.log und CBS.log habe ich noch einmal aktuell gepostet:

DISM.log https://pastebin.com/3W4SPhHC
CBS.log https://pastebin.com/0urgbcww

Ich würde mir von MS auch wünschen, dass das CBS.log übersichtlicher wäre. Mein Halbwissen sagt mir, dass man dort wahrscheinlich den/die Fehler finden kann. Und es sind ja einige Fehler gelistet. Besagter 0x80070057 kommt öfters vor und auch die Suche nach 'Error' oder 'failed' liefert einiges.

Mir ist aufgefallen:

- Die Stage 'CheckCsi' findet vier Metadata-Store-Corruptions, die jedoch weder von DISM noch von sfc angezeigt werden. Weiter unten läuft 'RepairCsi' ohne Fehler. Im Ergebnis werden diese Corruptions aber nicht entfernt (Total Repaired Corruption: 0) und sind auch bei weiteren Durchläufen wieder vorhanden.

- Die Stage 'CheckStagedPackages' meldet mehrere [HRESULT = 0x80070057 - E_INVALIDARG], beginnend mit 'Identity missing language.' bis zu 'Repr: Unable to open package Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~10.0.19041.1'.

- Im Abschnitt 'Checking System Update Readiness' wird reportet: dreimal "CBS Package Index Package Missing 0x80070490" und einmal "CBS Watchlist Package Missing 0x80070490"

jamacoe
Neuling
Neuling
Beiträge: 9
Registriert: 10.06.2021, 10:57
Geschlecht:

Re: Hartnäckige Probleme mit Windows-Updates

Beitrag von jamacoe » 12.06.2021, 09:11

Der Screenshot-Link hat wohl nicht funktioniert, d.h. hier: https://imgur.com/a/hhkCLf9

Benutzeravatar
Tekkie Boy
Nachwuchs
Nachwuchs
Beiträge: 73
Registriert: 29.02.2020, 21:05
Geschlecht:

Re: Hartnäckige Probleme mit Windows-Updates

Beitrag von Tekkie Boy » 12.06.2021, 10:10

Hallo

Das Problem bei Dir wird wohl sein, das die Registry beschädigt ist.
Das In-place Upgrade scheitert weil Dism /online /get-features ja nicht funktioniert.
Kannst Du mal dieses Script: ExportCBSRegistry.cmd herunterladen und als Administrator ausführen:
https://we.tl/t-wVINpt6xyc

Das erstellt das Paket: SoftwareCBS.zip auf dem Desktop.
Lade es auf OneDrive, GoogleDrive oder auf wetransfer.com hoch und stelle hier den Link zur Verfügung.

P.s:
Der Quellcode für das Script kann dort eingesehen werden:
https://pastebin.com/xPiJQ7Ai

Nicht das hier die Vermutung aufkommt Dir böswilligen Code unter zuschieben.
Freundliche Grüße / Friendly greetings

Benutzeravatar
DK2000
Legende
Legende
Beiträge: 5372
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: Hartnäckige Probleme mit Windows-Updates

Beitrag von DK2000 » 12.06.2021, 11:46

Die CBS.Logs geben da leider nicht mehr her.

Das scheitert irgendwie alles am "Microsoft-Windows-Foundation-Package". Daran scheitert auch das Inplace Upgrade. Das kann auch nicht auf die "Foundation" zugreifen.

Daher hätte mich ja mal die CBS.log und DISM.log von "Dism /online /get-features", ob das noch etwas hergibt.

Ansonsten auch mal versuchen (Pfad zu dem Paketen anpassen):

Code: Alles auswählen

Dism.exe" /Online /Remove-Package /PackagePath:Windows10.0-KB5000983-x64.cab
Dism.exe" /Online /Remove-Package /PackagePath:Windows10.0-KB4562830-x64.cab
Wenn das klappt, dann sind die beiden erst einmal weg.

Aber was dann weiter? /RestoreHEalth scheint da nicht unbedingt das zu reparieren, was eventuell kaputt ist. Findet zwar wa, kann aber auch nicht auf das "Foundation-Package" zugreifen, ignoriert das aber irgendwie, gibt vier Warnungen aus und beendet sich mit S_OK.

Registry, kann möglich sein. Hier wären dann auch für mich die Einträge zum "Microsoft-Windows-Foundation-Package" interessant. Weil irgendwie scheint ja alles an dem Paket zu hängen. Die Hash passt, also ist das Pakte da und unbeschädigt, aber so richtig Zugreifen kann wohl weder der TI noch das Setup für das Upgrade.

Mich stört auch irgendwie das "Identity missing language."? Ist das jetzt allgemein so, weil das Paket nicht erreichbar ist oder fehlt d wirklich die Sprache? Das LEP ist soweit installiert?

Was sieht es denn aus, wenn Du mal das eingibst? Sieht es dann in etwa so aus?

Code: Alles auswählen

PS C:\> Get-WindowsPackage -online|Where-Object { $_.PackageName -like "*Language*" -or $_.PackageName -like "*Foundation*" }|select PackageName,PackageState

PackageName                                                                                                        PackageState
-----------                                                                                                        ------------
Microsoft-Windows-Client-LanguagePack-Package~31bf3856ad364e35~amd64~de-DE~10.0.19041.1023                           Superseded
Microsoft-Windows-Client-LanguagePack-Package~31bf3856ad364e35~amd64~de-DE~10.0.19041.1052                            Installed
Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~10.0.19041.1                                             Installed
Microsoft-Windows-LanguageFeatures-Basic-de-de-Package~31bf3856ad364e35~amd64~~10.0.19041.1                           Installed
Microsoft-Windows-LanguageFeatures-Fonts-PanEuropeanSupplementalFonts-Package~31bf3856ad364e35~amd64~~10.0.19041.1    Installed
Microsoft-Windows-LanguageFeatures-Handwriting-de-de-Package~31bf3856ad364e35~amd64~~10.0.19041.1                     Installed
Microsoft-Windows-LanguageFeatures-OCR-de-de-Package~31bf3856ad364e35~amd64~~10.0.19041.1                             Installed
Microsoft-Windows-LanguageFeatures-Speech-de-de-Package~31bf3856ad364e35~amd64~~10.0.19041.1                          Installed
Microsoft-Windows-LanguageFeatures-TextToSpeech-de-de-Package~31bf3856ad364e35~amd64~~10.0.19041.1                    Installed

jamacoe
Neuling
Neuling
Beiträge: 9
Registriert: 10.06.2021, 10:57
Geschlecht:

Re: Hartnäckige Probleme mit Windows-Updates

Beitrag von jamacoe » 12.06.2021, 12:28

Danke f das Script, @TekkiBoy. Hier ist der Link zur Zip mit der .hiv. Kann ich das hier public posten, oder steht dort auch Serials, Passwörter, Keys u.ä. drin? https://drive.google.com/file/d/1q0aLz1 ... sp=sharing

Benutzeravatar
DK2000
Legende
Legende
Beiträge: 5372
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: Hartnäckige Probleme mit Windows-Updates

Beitrag von DK2000 » 12.06.2021, 15:03

Habe mir da mal die *.hiv angeschaut. Ist eine Kopie dieses Zweiges:

Code: Alles auswählen

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing
Aber so offensichtlich finde ich da keine Fehler. Gibt zwar Unterschiede zu meiner Registry, aber das liegt meistens daran, dass ich die 19043.1052 installiert habe. Wenn da etwas defekt ist, gute Frage. Vielleicht findet ja Tekkie Boy etwas.

Die beiden hängenden KBs, hast Du die jetzt mal versucht zu deinstallieren?

jamacoe
Neuling
Neuling
Beiträge: 9
Registriert: 10.06.2021, 10:57
Geschlecht:

Re: Hartnäckige Probleme mit Windows-Updates

Beitrag von jamacoe » 12.06.2021, 17:58

Hi DK2000,

nochmals vielen Dank für Deine bisherige Mühe. Ich bin neu hier im Forum und immer wieder begeistert, dass Menschen ihre wertvolle Zeit für die Probleme anderer opfern.

Windows10.0-KB5000983-x64.cab ließ sich nicht deinstallieren. Fehler: 0x80070570 und Fehler: 1392. Die Datei oder das Verzeichnis ist beschädigt und nicht lesbar. Wird auch in Programme + Features gelistet, aber ohne Deinstallieren-Button.

Windows10.0-KB4562830-x64.cab - der gleiche Fehler, wobei es nicht gelistet ist.

LEP voll installiert , aber Foundation fehlt:

Microsoft-Windows-Client-LanguagePack-Package~31bf3856ad364e35~amd64~de-DE~10.0.19041.264 Superseded
Microsoft-Windows-Client-LanguagePack-Package~31bf3856ad364e35~amd64~de-DE~10.0.19041.388 Installed
Microsoft-Windows-Client-LanguagePack-Package~31bf3856ad364e35~amd64~en-US~10.0.19041.1 Superseded
Microsoft-Windows-Client-LanguagePack-Package~31bf3856ad364e35~amd64~en-US~10.0.19041.388 Installed
Microsoft-Windows-LanguageFeatures-Basic-de-de-Package~31bf3856ad364e35~amd64~~10.0.19041.1 Installed
Microsoft-Windows-LanguageFeatures-Handwriting-de-de-Package~31bf3856ad364e35~amd64~~10.0.19041.1 Installed
Microsoft-Windows-LanguageFeatures-OCR-de-de-Package~31bf3856ad364e35~amd64~~10.0.19041.1 Installed
Microsoft-Windows-LanguageFeatures-Speech-de-de-Package~31bf3856ad364e35~amd64~~10.0.19041.1 Installed
Microsoft-Windows-LanguageFeatures-TextToSpeech-de-de-Package~31bf3856ad364e35~amd64~~10.0.19041.1 Installed

Zusätzlich hatte ich englisches Sprachpaket und spanische Tastatur, habe jetzt aber beides deinstalliert. Nur noch Deutsch.

Zu CBS.log und DISM.log von Dism /online /get-features bin ich noch nicht gekommen, sitze gerade am Flughafen.

Habe aber schon mal in der HKLM-Registry nach Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~10.0.19041.1 gesucht und einige Einträge gefunden, darunter ein merkwürdiger mit einem Pfad, der nicht existiert:

Hier der ganze Key:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\Packages\Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~10.0.19041.1]
"InstallClient"="Cbss"
"InstallName"="Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~10.0.19041.1.mum"
"InstallLocation"="\\\\?\\D:\\wd\\in\\BuildChunkArtifact\\f9e033e8-a66e-de80-132f-8c8218cd941a\\amd64fre\\NEUTRAL_STAGED_CLIENT_CATALOGS\\"
"CurrentState"=dword:00000070
"SelfUpdate"=dword:00000000
"Visibility"=dword:00000001
"InstallTimeHigh"=dword:01d5acdf
"InstallTimeLow"=dword:43255dab
"InstallUser"="S-1-5-21-3933942852-973373972-2766786355-1032"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\Packages\Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~10.0.19041.1\Owners]
"Microsoft-Windows-ProfessionalEdition~31bf3856ad364e35~amd64~~10.0.19041.264"=dword:00020050
"Microsoft-Windows-ProfessionalEdition~31bf3856ad364e35~amd64~~10.0.19041.388"=dword:00020070

Benutzeravatar
DK2000
Legende
Legende
Beiträge: 5372
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: Hartnäckige Probleme mit Windows-Updates

Beitrag von DK2000 » 12.06.2021, 18:23

Diese komischen Pfade mit "\\\\?\\D:\\wd\\in\\BuildChunkArtifact\\" gibt es bei mir auch, aber das muss wohl so sein.

OK, dann mal etwas ganz ungewöhnliches versuchen:

Code: Alles auswählen

 dism /online /Add-Package:C:\WINDOWS\Servicing\Packages\Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~10.0.19041.1.mum
 
 dism /Online /Cleanup-Image /RestoreHealth 
Mal schauen, ob das Paket dann wieder in der Liste erscheint. Ungewöhnlich deswegen, weil man dieses Paket eigentlich nicht deinstallieren kann. Aber das es nicht in der Liste erscheint, erklärt die Fehler.

Allerdings der Fehler klingt auch nicht gut:

0x080070570: The file or directory is corrupted and unreadable.

Eventuell ist da noch mehr defekt.

Benutzeravatar
Tekkie Boy
Nachwuchs
Nachwuchs
Beiträge: 73
Registriert: 29.02.2020, 21:05
Geschlecht:

Re: Hartnäckige Probleme mit Windows-Updates

Beitrag von Tekkie Boy » 13.06.2021, 12:10

@jamacoe

Sorry für die späte Antwort.
Nein, in dem Bereich der Registry sind keine bedenkliche Daten hinterlegt.
Ich hätte Dich dann auch die Hive nicht einfach so posten lassen.
Ich hatte eigentlich einen größeren Schaden in der Hive erwartet.
Es gibt da aber Sachen die nicht in Ordnung sind.

Zum Beispiel:

Code: Alles auswählen

2021-06-12 07:42:10, Info                  CBS    (w)	CBS Package Index Package Missing	0x80070490	HyperV-VMMS-Package~31bf3856ad364e35~amd64~~0.0.0.0	HyperV-VMMS-Package~31bf3856ad364e35~amd64~~10.0.19041.264
In der Registry ist das Paket im Index vorhanden:
Bild

aber bei den Paketen selbst fehlt es:
Bild.

Und der Eintrag "Value" ist kein gültiger Eintrag in der Registry bei dem Windows-Foundation-Package:
Bild

Bitte überprüfe mal ob die Datei:
C:\WINDOWS\Servicing\Packages\Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~10.0.19041.1.mum
korrupt ist und ungültige Zeichen enthält.

Gab es mal einen Absturz oder wurde der PC durch irgendein Ereignis hart ausgeschaltet?
Wenn Du Dir die Fehler nicht erklären kannst, überprüfe den Arbeitsspeicher und Festplatte auf Fehler und führe chkdsk aus.
Freundliche Grüße / Friendly greetings

jamacoe
Neuling
Neuling
Beiträge: 9
Registriert: 10.06.2021, 10:57
Geschlecht:

Re: Hartnäckige Probleme mit Windows-Updates

Beitrag von jamacoe » 13.06.2021, 13:03

PS> dism /online /Add-Package:C:\WINDOWS\Servicing\Packages\Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~10.0.19041.1.mum
Tool zur Imageverwaltung für die Bereitstellung
Version: 10.0.19041.329
Abbildversion: 10.0.19041.388
Beim Öffnen von C:\WINDOWS\Servicing\Packages\Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~10.0.19041.1.mum ist ein Fehler aufgetreten. Fehler: 0x80070057
Fehler: 87
Fehler beim Verarbeiten des Befehls.
Stellen Sie sicher, dass die Befehlszeilenargumente gültig sind.

cbs.log https://pastebin.com/c2hd8RPC
Dism.log https://pastebin.com/9pVw6Aad

Wie schon erwähnt: die .mum-Datei ist vorhanden, der Hash stimmt. Sie läßt sich auch kopieren.

jamacoe
Neuling
Neuling
Beiträge: 9
Registriert: 10.06.2021, 10:57
Geschlecht:

Re: Hartnäckige Probleme mit Windows-Updates

Beitrag von jamacoe » 13.06.2021, 13:05

Der erste Fehler in der CBS.log ist immer 'Identity missing language'. Was ist damit gemeint? Welche Identity?

Benutzeravatar
DK2000
Legende
Legende
Beiträge: 5372
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: Hartnäckige Probleme mit Windows-Updates

Beitrag von DK2000 » 13.06.2021, 13:17

@Tekkie Boy:

Ah, siehst, Immer besser, wenn da mehrere sich an der Fehlersuche beteiligen. Die vier Warnungen habe ich da gar nicht so beachtet:

Code: Alles auswählen

2021-06-12 07:42:10, Info                  CBS    (w)	CBS Package Index Package Missing	0x80070490	HyperV-VMMS-Package~31bf3856ad364e35~amd64~~0.0.0.0	HyperV-VMMS-Package~31bf3856ad364e35~amd64~~10.0.19041.264	
2021-06-12 07:42:10, Info                  CBS    (w)	CBS Package Index Package Missing	0x80070490	Microsoft-OneCore-IsolatedUserMode-Package~31bf3856ad364e35~amd64~~0.0.0.0	Microsoft-OneCore-IsolatedUserMode-Package~31bf3856ad364e35~amd64~~10.0.19041.264	
2021-06-12 07:42:10, Info                  CBS    (w)	CBS Package Index Package Missing	0x80070490	Microsoft-Windows-Client-Features-Package0214~31bf3856ad364e35~amd64~~0.0.0.0	Microsoft-Windows-Client-Features-Package0214~31bf3856ad364e35~amd64~~10.0.19041.153	
2021-06-12 07:42:10, Info                  CBS    (w)	CBS Watchlist Package Missing	0x80070490	Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~0.0.0.0	Value
Dann müssten das die vier Probleme sein. Wundert mich dann aber. das /RestoreHealth das nicht weiter als kritisch ansieht.

Den Eintrag würde ich einfach mal lösen:

Code: Alles auswählen

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\PackageDetect\Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~0.0.0.0]
"Value"=dword:00000000
Also nur das "Value", nicht den ganzen Zweig. Der ist so ungültig und lässt sich so auch nicht ermitteln, was da eigentlich stehe sollte.

Was die anderen drei Pakete angeht, so sehe ich da bei mir keinen Unterschied, mal von den Revisionen und Sprache abgesehen.

Code: Alles auswählen

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\PackageDetect\HyperV-VMMS-Package~31bf3856ad364e35~amd64~~0.0.0.0]
"HyperV-VMMS-Package~31bf3856ad364e35~amd64~de-DE~10.0.19041.1"=dword:00000002

Code: Alles auswählen

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\PackageIndex\HyperV-VMMS-Package~31bf3856ad364e35~amd64~~0.0.0.0]
"HyperV-VMMS-Package~31bf3856ad364e35~amd64~~10.0.19041.1023"=dword:00000000
"HyperV-VMMS-Package~31bf3856ad364e35~amd64~~10.0.19041.1052"=dword:00000000
Und hier sollten jetzt nur die Pakete eingetragen sein, welche unter "PackageIndex" für das Paket eintragen sind, also bei mir:

Code: Alles auswählen

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\Packages\HyperV-VMMS-Package~31bf3856ad364e35~amd64~~10.0.19041.1023]

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\Packages\HyperV-VMMS-Package~31bf3856ad364e35~amd64~~10.0.19041.1052]
Bei ihm wäre das halt 10.0.19041.264 und 10.0.19041.329.

Sehe da jetzt keinen signifikanten Unterschied. Oder ich übersehe da etwas, was Du gesehen hast.

Kann sein, dass das Ganze wirklich nur durch das seltsame "Value" ausgelöst wird.
Zuletzt geändert von DK2000 am 13.06.2021, 14:06, insgesamt 1-mal geändert.

Benutzeravatar
DK2000
Legende
Legende
Beiträge: 5372
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: Hartnäckige Probleme mit Windows-Updates

Beitrag von DK2000 » 13.06.2021, 13:29

jamacoe hat geschrieben: 13.06.2021, 13:05 Der erste Fehler in der CBS.log ist immer 'Identity missing language'. Was ist damit gemeint? Welche Identity?
Ich vermute wirklich im Moment, dass esdaran liegt:

Code: Alles auswählen

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\PackageDetect\Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~0.0.0.0]
"Value"=dword:00000000
Statt "Value" sollte da eigentlich der Name eines Manifestes stehen, aus dem die Identität "language" ausgelesen werden soll. Da aber "Value" kein Manifest ist, gibt es da auch keine Identitäten zum Auslesen. Daher wohl auch das "Failed to shred identity: Value".

Das habe ich gestern gar nicht mehr so beachtet. Lösche mal das "Value" und dann teste das noch einmal. Kann sein, dass der falsche Eintrag da alles blockiert.

Musst aber vermutlich RegEdit über NSudo mit den Rechtens des TrustedInstallers starten.

https://www.deskmodder.de/blog/2021/06/ ... stuetzung/

----

Habe jetzt mal aus Spaß in der VM mit der 19043.1052 dieses "Value" genau an der Stelle erstellt und nun habe ich das auch, wenn ich versuche das Update auf die19043.1055 zu installieren:

Code: Alles auswählen

2021-06-13 14:59:11, Info                  CBS    Identity missing language. [HRESULT = 0x80070057 - E_INVALIDARG]
2021-06-13 14:59:11, Info                  CBS    Failed to shred identity. [HRESULT = 0x80070057 - E_INVALIDARG]
2021-06-13 14:59:11, Error                 CBS    Failed to shred identity: Value [HRESULT = 0x80070057 - E_INVALIDARG]
2021-06-13 14:59:11, Info                  CBS    Failed to create identity from string: Value. [HRESULT = 0x80070057 - E_INVALIDARG]
2021-06-13 14:59:11, Info                  CBS    Failed to get identity from key form: Value [HRESULT = 0x80070057 - E_INVALIDARG]
2021-06-13 14:59:11, Info                  CBS    Failed to populate children. [HRESULT = 0x80070057 - E_INVALIDARG]
2021-06-13 14:59:11, Info                  CBS    Failed to initialize package: Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~10.0.19041.1, from path: \\?\C:\WINDOWS\Servicing\Packages\Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~10.0.19041.1.mum, existing package: 1 [HRESULT = 0x80070057 - E_INVALIDARG]
Und die Installation des Updates brich mit dem Fehler 0x80070057 ab.

Antworten