upgrade auf Windows 10 19033

Deine Frage passt nicht in die anderen Bereiche, dann stelle sie hier.
Benutzeravatar
august_burg
Berater
Berater
Beiträge: 237
Registriert: 25.12.2017, 11:23
Geschlecht:

upgrade auf Windows 10 19033

Beitrag von august_burg » 03.12.2019, 15:02

Tach allerseits,

ich wollte mein 1909 mutig auf o.a. Version "anheben". Entsprechende ISO habe ich hier downgeloaded.
Das Vorhaben mißlingt mit angehängter Fehlermeldung.

Was läuft hier falsch ?
Windows 10 upgrade.jpg
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Gruß, Achim :)

Tante Google

upgrade auf Windows 10 19033

Beitrag von Tante Google » 03.12.2019, 15:02


Benutzeravatar
moinmoin
★ Team Admin ★
Beiträge: 46391
Registriert: 14.11.2003, 11:12
Geschlecht:

Re: upgrade auf Windows 10 19033

Beitrag von moinmoin » 03.12.2019, 15:16

Offtopic: Welche Fehlermeldung? :lol:

Würde ich mal ein Versuch ohne Internet probieren.
Wenn auch das fehlschlägt, müsste man die Log-Dateien auswerten.
Aber da ist DK2000 eher der Profi.
Bild
Deskmodder findet ihr bei: Mewe | Twitter | Facebook Windows 10 Tipps und Tricks: Tutorials Windows 10.

Benutzeravatar
august_burg
Berater
Berater
Beiträge: 237
Registriert: 25.12.2017, 11:23
Geschlecht:

Re: upgrade auf Windows 10 19033

Beitrag von august_burg » 03.12.2019, 15:49

Nachtrag:

An der ISO kann es nicht liegen. Installation unter VMWare kein Problem !
Gruß, Achim :)

Benutzeravatar
DK2000
Alleswisser
Alleswisser
Beiträge: 1925
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: upgrade auf Windows 10 19033

Beitrag von DK2000 » 03.12.2019, 15:51

Das liegt wohl irgendwie an der 1909. Aus irgendeinem Grund kann da Setup der 2004 nicht ermitteln, ob die 2004 auf dem Gerät lauffähig ist oder nicht.

Müsste man mal für den Anfang die C:\$Windows.~BT\Sources\panther\setupact.log betrachten, ob da etwas hervorgeht, was weiter helfen könnte.

Benutzeravatar
august_burg
Berater
Berater
Beiträge: 237
Registriert: 25.12.2017, 11:23
Geschlecht:

Re: upgrade auf Windows 10 19033

Beitrag von august_burg » 03.12.2019, 15:55

sh. Anlage !
setupact.log
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Gruß, Achim :)

Benutzeravatar
DK2000
Alleswisser
Alleswisser
Beiträge: 1925
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: upgrade auf Windows 10 19033

Beitrag von DK2000 » 03.12.2019, 16:18

Der Fehler ist dieser: 0x80070003 - 0x40008

Der Fehler 0x80070003 (ERROR_PATH_NOT_FOUND) stammt von hier:

Code: Alles auswählen

2019-12-03 15:46:18, Info                  CONX   CHostIsUEFICompliantChecker invoked.
2019-12-03 15:46:18, Info                  CONX   ConX::Compatibility::CSystemAbstraction::HostIsUEFIFirmware: Host is UEFI.
2019-12-03 15:46:18, Info                  CONX   Windows::Compat::Appraiser::SetupAppraiser::InitializeRunOptions (1365):   No driver install path available.
2019-12-03 15:46:18, Error                 CONX   Windows::Compat::Appraiser::IsMeteredConnection (207):   Failed to get NetworkCostType assuming metered network [0x80004005].[gle=0x80004005]
2019-12-03 15:46:18, Info                  CONX   Windows::Compat::Appraiser::AppraiserSettings::GetSettingsInternal (298):   DeviceTicket not included.
2019-12-03 15:46:18, Info                  CONX   Windows::Compat::Appraiser::SetupAppraiser::GetAlternateData (3854):   Setup alternate data in use [0], Url [], Result [0x1].
2019-12-03 15:46:18, Info                  CONX   Windows::Compat::Appraiser::SdbUtils::SendSdbInfoTelemetry (1089):   Using Sdb Id: [{11111111-1111-1111-1111-111111111111}] Size: [12858794] Modified: [2016-01-01T00:00:00], at path C:\$WINDOWS.~BT\Sources\appraiser.sdb
2019-12-03 15:46:18, Error                 CONX   ConX::Compatibility::CSystemAbstraction::HostIsUEFIDiskLayout: Failed to retrieve system partition NT path.
2019-12-03 15:46:18, Error                 CONX   CHostIsUEFICompliantChecker failed. [Failed to check whether host has UEFI disk layout.] HRESULT = 0x80070003
Das Setup hat da Probleme zu erkennen, ob das Disk Layout dem GPT Standard für UEFI entspricht, weil ja erkannt wurde, dass "Host is UEFI". Das scheint dem Setup da überhaupt nicht zu gefallen und bricht ohne weitere Aktionen ab. Das führt dann noch zu weiteren Fehlern, die aber auch die selbe Ursache haben:

Code: Alles auswählen

[Failed to retrieve system volume NT path.] HRESULT = 0x80070003
Ist jetzt natürlich die Frage, wie es um Dein Disk Layout aussieht und warum das Setup damit Probleme hat, die Startpartition (?) zu finden.

Eventuell steht hier noch etwas drin: C:\WINDOWS\logs\SetupDiag\SetupDiagResults.xml

Benutzeravatar
august_burg
Berater
Berater
Beiträge: 237
Registriert: 25.12.2017, 11:23
Geschlecht:

Re: upgrade auf Windows 10 19033

Beitrag von august_burg » 03.12.2019, 19:35

sh. Anlage !
setupdiagresults.xml
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Gruß, Achim :)

Benutzeravatar
DK2000
Alleswisser
Alleswisser
Beiträge: 1925
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: upgrade auf Windows 10 19033

Beitrag von DK2000 » 03.12.2019, 19:39

Steht leider auch nur das Selbe drin, ohne Grund:

[Failed to check whether host has UEFI disk layout.] HRESULT = 0x80070003

Das Setup hat da irgendein Problem, Deine Disk Layout zu ermitteln. Irgendetwas passt da nicht mit der 1909.

Benutzeravatar
august_burg
Berater
Berater
Beiträge: 237
Registriert: 25.12.2017, 11:23
Geschlecht:

Re: upgrade auf Windows 10 19033

Beitrag von august_burg » 03.12.2019, 19:48

Ich hatte an anderer Stelle berichtet, daß nach Einbau einer EVO 970 PCie als Sys-Partition u. deren "Beglückung" mit einem speziellen Samsung-Treiber Verschiebung der Partitionen insgesamt erfolgt ist. Aus vorherigem Datenträger "0" ist jetzt der Datenträger "2" geworden. Sh. auch sreenshot.
Vllt. gibt es da einen Zusammenhang. Den Treiber kann ich problemlos deinstallieren, da dann Windows selbst eingreift.
Datenträger.jpg
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Gruß, Achim :)

Benutzeravatar
Manny
Meisteranwärter
Meisteranwärter
Beiträge: 281
Registriert: 27.03.2018, 18:12
Geschlecht:

Re: upgrade auf Windows 10 19033

Beitrag von Manny » 03.12.2019, 20:08

wo ist denn bei deinem Datenträger die Wiederherstellungspartition ? :o
sieht man die im Bild nicht oder hast du gar keine ?

Benutzeravatar
august_burg
Berater
Berater
Beiträge: 237
Registriert: 25.12.2017, 11:23
Geschlecht:

Re: upgrade auf Windows 10 19033

Beitrag von august_burg » 03.12.2019, 20:14

gelöscht 😁
Gruß, Achim :)

Benutzeravatar
Manny
Meisteranwärter
Meisteranwärter
Beiträge: 281
Registriert: 27.03.2018, 18:12
Geschlecht:

Re: upgrade auf Windows 10 19033

Beitrag von Manny » 03.12.2019, 20:44

august_burg hat geschrieben:
03.12.2019, 20:14
gelöscht 😁
da könnte evtl. der Fehler liegen was das updaten betrifft. die 19033 ist die 20H1 und dort wurde innerhalb der Build die "Ablage" der Wiederherstellungspartition hinter den Systemdatenträger gelegt (damit sie dynamisch verwaltet werden kann) - bei der 1909 war die Wiederherstellungspartition noch vor dem Systemdatenträger. Auch wenn du gar keine WHP mehr hast liegt der Gedanke nahe, das die Setuprountine eine solche Partition sucht und wegen nicht finden dann die Fehler entstehen

ich vermute stark das ein Clean Install auf die 19033 einwandfrei funktionieren würde

EDIT

und was die verschiedenen Datenträger-Nummern betrifft

das liegt ausschließlich an dem verwendeten Treiber - gerade noch mal durchgetestet - nimmt man den NVME Treiber von Samsung wird ( bei mir) der aktuelle Systemdatenträger zu Laufwerk 5 , deinstalliere ich diesen und es wird der integrierte Treiber von MS genommen (Standardmäßiger NVM Express-Controller) dann wird (mein) Systemdatenträger zu Laufwerk 2
(aber niemals zu Datenträger 0 ) da ich auch noch weitere Controller verbaut habe und das Bios / UEFI eine gewisse "Reihenfolge" vorgibt

Benutzeravatar
DK2000
Alleswisser
Alleswisser
Beiträge: 1925
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: upgrade auf Windows 10 19033

Beitrag von DK2000 » 03.12.2019, 21:43

Fehler sehe ich da im Moment keine.

Mit der Wiederherstellungspartition hat sich das Setup noch gar nicht beschäftigt, da es im Moment noch nach dem "System Volumen" bzw. der Boot Disk an sich sucht.

Der Abschnitt sollte eigentlich so aussehen, wenn alles glatt läuft:

Code: Alles auswählen

2019-12-03 21:27:42, Info                  CONX   CHostIsUEFICompliantChecker invoked.
2019-12-03 21:27:42, Info                  CONX   ConX::Compatibility::CSystemAbstraction::HostIsUEFIFirmware: Host is UEFI.
2019-12-03 21:27:42, Info                  CONX   ConX::Compatibility::CSystemAbstraction::HostIsUEFIDiskLayout: Detected system partition NT path: [\Device\HarddiskVolume2]
2019-12-03 21:27:42, Info                  CONX   ConX::Compatibility::CSystemAbstraction::HostIsUEFIDiskLayout: Constructed system volume NT path: [\\?\GLOBALROOT\Device\HarddiskVolume2]
2019-12-03 21:27:42, Info                  CONX   ConX::Compatibility::CSystemAbstraction::HostIsUEFIDiskLayout: Detected boot disk number: [0]
2019-12-03 21:27:42, Info                  CONX   ConX::Compatibility::CSystemAbstraction::HostIsUEFIDiskLayout: Boot disk has ESP partition.
2019-12-03 21:27:42, Info                  CONX   ConX::Compatibility::CSystemAbstraction::HostIsUEFIDiskLayout: Boot disk has MSR partition.
2019-12-03 21:27:42, Info                  CONX   ConX::Compatibility::CSystemAbstraction::HostIsUEFIDiskLayout: Boot disk has UEFI disk layout.
2019-12-03 21:27:42, Info                  CONX   CHostIsUEFICompliantChecker: checked HostIsUEFICompliant, found NoIssue.
Es wird an der Stelle primär nur nach C: und der ESP gesucht. Erst wenn er das gefunden und identifiziert hat und damit die Disk Nummer kennt, kommt danach die Wiederherstellungspartition bzw. das Recovery Image dran:

Code: Alles auswählen

2019-12-03 21:27:42, Info                         [SetupHost.exe] Enter WinReGetConfig
2019-12-03 21:27:42, Info                         [SetupHost.exe] Parameters: configWinDir: C:\WINDOWS
2019-12-03 21:27:42, Info                         [SetupHost.exe] WinRE config file path: C:\WINDOWS\system32\Recovery\ReAgent.xml
2019-12-03 21:27:42, Info                         [SetupHost.exe] Update enhanced config info is enabled.
2019-12-03 21:27:42, Info                         [SetupHost.exe] WinRE is installed
2019-12-03 21:27:42, Info                         [SetupHost.exe] WinRE is installed at: \\?\GLOBALROOT\device\harddisk0\partition1\Recovery\WindowsRE
2019-12-03 21:27:42, Info                         [SetupHost.exe] System is WimBoot: FALSE
2019-12-03 21:27:42, Info                         [SetupHost.exe] WinRE image validated
2019-12-03 21:27:42, Info                         [SetupHost.exe] Exit WinReGetConfig return value: 1, last error: 0x0
Aber soweit kommt das Setup bei ihm nicht mehr. Das Setup versagt im Prinzip an der Stelle, wo Disk 2 und dessen Partitionen erkannt werden soll, weil dessen Pfad nicht gefunden wird. Genauso wie diese Zeile:

Code: Alles auswählen

Windows::Compat::Appraiser::SetupAppraiser::InitializeRunOptions (1365):   No driver install path available.
Wonach sucht er da. Bei mir erscheint das nicht. Daher kann ich das im Moment schlecht zuordnen.

Das ist natürlich ein seltsamer Fehler. Das System bootet ja soweit von Disk 2, also sollte das passen. Sehe da im Moment keine offensichtlichen Fehler, außer das halt der "CHostIsUEFICompliantChecker" versagt, weil der Pfad zu C: nicht gefunden wird.

Nur um das auszuschließen: Im UEFI ist der Windows Bootmanager eintragen mit Disk 2? Ich weiß jetzt nicht, wo die Funktion sich da ihre Infos herholt. Eventuell mal zur Sicherheit bcdboot C:\Windows /l de-DE ausführen (mit Adminrechten).

Oder kommt das Setup wirklich nicht mit dem Samsung Treiber klar? Wäre komisch, aber auch nicht auszuschließen. Habe da leider keine NVMe, so dass ich das selber testen kann.

Benutzeravatar
Manny
Meisteranwärter
Meisteranwärter
Beiträge: 281
Registriert: 27.03.2018, 18:12
Geschlecht:

Re: upgrade auf Windows 10 19033

Beitrag von Manny » 03.12.2019, 22:17

DK2000 hat geschrieben:
03.12.2019, 21:43
...
Oder kommt das Setup wirklich nicht mit dem Samsung Treiber klar? Wäre komisch, aber auch nicht auszuschließen. Habe da leider keine NVMe, so dass ich das selber testen kann.
...
also was da genau (intern) abläuft weiß ich nicht aber am Samsung NVME Treiber liegt es nicht, weil
(nachfolgende Aussage betrifft alleine mein System):
Updates sowohl clean ( mit modifizierter ISO incl.NVME-Treiber direkt eingebunden ) genau so ablaufen wie eine Clean Installation ohne NVME-Treiber

selbiges funktioniert übrigens dann auch bei Updates über WU und oder als Inplace


Nachtrag: habe sogar selbige SSD wie august_burg

Benutzeravatar
DK2000
Alleswisser
Alleswisser
Beiträge: 1925
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: upgrade auf Windows 10 19033

Beitrag von DK2000 » 04.12.2019, 06:26

Würde ich auch komisch finden, wenn es wirklich am Treiber liegen sollte.

Das kuriose ist ja, das Windows gestartet wird und logischer Weise auf C: läuft (Partition 3), anschließend das Setup von der ISO innerhalb dieses Systemes gestartet wird und das Setup jetzt C: bzw. dessen Pfad \Device\HarddiskVolumeX ohne Probleme finden würde. Stattdessen sucht es anscheinend nach einen anderen Pfad mit Treibern (No driver install path available).

Möchte mal wissen, an welcher Stelle das Setup den Pfad für das Volumen C: sucht.

Antworten