Win 10 0xC0000013 und Autoreparatur

Windows 10 startet nicht, oder du kannst dich nicht einloggen?
Delta123

Win 10 0xC0000013 und Autoreparatur

Beitrag von Delta123 » 07.11.2018, 12:01

Hallo,
als ich gestern abend meinen PC (Windows Home 64bit) eingeschaltet habe, kam nach den BIOS-Meldungen, kurz vor der Anmeldemaske, der blaue Bildschirm mit der Meldung "Mit Ihrem PC gab es ein Problem" mit dem Hinweis auf StopCode 0xC0000013. Es wurden Daten gesammelt und der PC wurde neu gestartet.
Dies passierte ca. 3-4 Mal, dann wurde mir die Auto-Reparatur angeboten. Dies habe ich ausgeführt und den PC neu gestartet. Seitdem bootet der PC immer wieder in die Autoreparatur. Alle Optionen welche ich ausprobierte, sind erfolglos (keine Wiederherstellungspunkte vorhanden, keine System-Images vorhanden, zurücksetzen geht nicht, etc.).
Ich komme in der Autoreparatur in die Kommandozeile und habe versucht die Autoreparatur auszuschalten (bcedit set recoveryenabled NO, fsutil repair set c: 0). dies wurde zwar jeweils als erfolgreich gemeldet, aber beim nächsten Start geht er wieder in die Autoreparatur. Laut Titel der Kommandozeile wurde diese als Administrator gestartet.
ich habe auch bereits mit einem Win10 USB-Stick gebootet, aber die Optionen der dortigen Reparaturmaßnahmen verlaufen ebenfalls im Sande.
Dies betrifft ebenfalls den dort verfügbaren Abgesicherten Modus - bei Neustart fällt Win10 wieder in die Autoreparatur.

Ich habe vor dem ersten Auftreten des Stopcode 0xC0000013 nichts an der Hardware geändert. Ob ein Update von Windows herunter geladen wurde kann ich nicht sagen, da ich ja nicht mehr so weit komme. Einzig der Anschluß einer defekten Festplatte zum Versuch sie evtl. doch noch auszulesen, könnte als Ursache in Frage kommen. Aber da diese ja nicht einmal erkannt wurde, sehe ich das als eher theoretische Möglichkeit.

Ich wäre sehr dankbar, wenn mir jemand helfen könnte
a. die Autoreparatur auszuschalten und
b. mein Win 10 wieder bootfähig zu bekommen

Mein System:
Prozessor AMD Ryzen 5 1600, 6x 3200 MHz
Mainboard MSI X370 Gaming Pro
Arbeitsspeicher 2 x 16 GB DDR4-RAM, Dual Channel (2x 8 GB), 2400 MHz, Ballistix Sport
1. Festplatte 256 GB SSD Micron 1100 (Lesen/Schreiben: 530 MB/s | 500 MB/s)
Laufwerke Blu-ray Brenner ASUS BW-16D1HT/B
Netzteil 500 Watt be quiet! Pure Power 10
Betriebssystem Windows 10 Home, 64 Bit

Tante Google

Win 10 0xC0000013 und Autoreparatur

Beitrag von Tante Google » 07.11.2018, 12:01


Benutzeravatar
moinmoin
★ Team Admin ★
Beiträge: 45287
Registriert: 14.11.2003, 11:12
Geschlecht:

Re: Win 10 0xC0000013 und Autoreparatur

Beitrag von moinmoin » 07.11.2018, 12:35

Hört sich sehr nach Festplattenfehler an.

Falls du einen zweiten PC hast, könntest du die SSD mal ausbauen, dort einbauen und schauen, ob sie überhaupt erkannt wird.

Ansonsten in die erweiterten Startoptionen und chkdsk durchführen.

https://www.deskmodder.de/wiki/index.ph ... nd starten

https://www.deskmodder.de/wiki/index.ph ... zu finden
Bild
Deskmodder findet ihr bei: Mewe | Twitter | Facebook Windows 10 Tipps und Tricks: Tutorials Windows 10.

Delta123

Re: Win 10 0xC0000013 und Autoreparatur

Beitrag von Delta123 » 07.11.2018, 12:45

Hallo moinmoin,

erstmal vielen Dank für die schnelle Antwort !

chkdisk kann ich erst heut abend ausprobieren, da ich noch auf Arbeit bin.
Aber ich muß das in der Kommandozeile der Autoreparatur machen, da ich in die erweiterten Startoptionen nicht rankomme.

Ich glaub ich muß ertsmal die Autoreparatur loswerden, damit ich weiter komme - alle Anleitungen dazu die ich fand, funktionieren nicht

Benutzeravatar
moinmoin
★ Team Admin ★
Beiträge: 45287
Registriert: 14.11.2003, 11:12
Geschlecht:

Re: Win 10 0xC0000013 und Autoreparatur

Beitrag von moinmoin » 07.11.2018, 12:53

Lade dir eine Windows 10 ISO über das MediaCreationTool auf einen USB-Stick herunter und starte dann davon in die Computerreparatur
(Siehe Tutorial).

https://www.microsoft.com/de-de/softwar ... /windows10
Bild
Deskmodder findet ihr bei: Mewe | Twitter | Facebook Windows 10 Tipps und Tricks: Tutorials Windows 10.

Delta123

Re: Win 10 0xC0000013 und Autoreparatur

Beitrag von Delta123 » 07.11.2018, 12:58

Hab ich schon gemacht - gleicher Effekt.
ich bekomme die verschiedenen Optionen der Reparaturoptionen, aber keine führt zum Erfolg.
was ich versuche (zurücksetzen, starthilfe, etc.) funktioniert nicht und die Eingabeaufforderung nimmt meine Kommandos entgegen und sagt "Erfolg", aber nach dem neustart fangt wieder die Autoreparatur an...

Benutzeravatar
moinmoin
★ Team Admin ★
Beiträge: 45287
Registriert: 14.11.2003, 11:12
Geschlecht:

Re: Win 10 0xC0000013 und Autoreparatur

Beitrag von moinmoin » 07.11.2018, 13:13

Dann nutze mal Diskpart und prüfe ob die SSD aufgelistet wird. Wenn nicht ist sie wohl hin.

https://www.deskmodder.de/wiki/index.ph ... Windows 10 (aber nicht löschen ;) )
Bild
Deskmodder findet ihr bei: Mewe | Twitter | Facebook Windows 10 Tipps und Tricks: Tutorials Windows 10.

Delta123

Re: Win 10 0xC0000013 und Autoreparatur

Beitrag von Delta123 » 07.11.2018, 13:44

Alles klar - mach ich heut' abend und geb' Bescheid.
Eine Frage noch:
Die SSD asl Bootpartition ist dann ja wohl C:, oder ?
Auf die Laufwerke inkl. C. kann ich nämlich aus der Eingabeaufforderung der Reparatur Optionen zugreifen.
Allerdings ist in einem Log der erstn Reparaturversuche das Verzeichnis EFI erwähnt, wo sich eine datei Bootres.dll befinden soll. Dieses Verzeichnis kann ich aber nirgends finden. Hat die SSD als Bootpartition ebenfalls einen Laufwerksbuchstaben ?

Benutzeravatar
moinmoin
★ Team Admin ★
Beiträge: 45287
Registriert: 14.11.2003, 11:12
Geschlecht:

Re: Win 10 0xC0000013 und Autoreparatur

Beitrag von moinmoin » 07.11.2018, 14:12

Wenn du vom USB-Stick startest, ändert sich der Buchstabe auf D, oder E.
Das musst du vorab mal herausfinden über
D: Enter
dir eingeben Enter
Wenn nicht, dann weiter....
Bild
Deskmodder findet ihr bei: Mewe | Twitter | Facebook Windows 10 Tipps und Tricks: Tutorials Windows 10.

Delta123

Re: Win 10 0xC0000013 und Autoreparatur

Beitrag von Delta123 » 07.11.2018, 20:45

chkdsk hat nix gefunden - die SSD ist ok.
Ich hab dann mal im BIOS die Bootreihenfolge von Windows-Bootmanager auf Harddisc (SSD) gestellt, da lief dann gar nichts mehr.
No boot filename received - missing operating system

Benutzeravatar
IT-Nerd
Spezialist
Spezialist
Beiträge: 153
Registriert: 17.04.2018, 21:44
Geschlecht:

Re: Win 10 0xC0000013 und Autoreparatur

Beitrag von IT-Nerd » 07.11.2018, 21:59

@Delta123

Hallo!

Mal kurz zusammengefasst: BCDEdit Änderungen werden vom System abgenickt, wie es scheint jedoch nicht von diesem übernommen, nö, ich hab vor dem ersten Auftreten [..] nichts an der Hardware geändert (sei ehrlich, haste doch, diese defekte Platte, was für eine Schnittstelle wurde dabei benutzt SATA oder USB?) , die SDD ist heil in Verbindung mit "missing operating system" -das eröffnet den Raum der Hoffnung..

Solange dein Windows nicht wieder flott ist, legen wir BSOD und StopCode erstmal beiseite, ebenso dieses fossile Fsutil -das An- bzw. Ausknipsen von "NTFS Self-Healing" hat mit deinem eigentlichen Problem nur wenig zu tun.

Die Bootreihenfolge vorerst Mal unverändert lassen (SSD First) und wie von moinmoin bereits vorgeschlagen über USB Stick booten um auf eine "saubere" Kommandozeilen-Ebene zu gelangen.
Anmelden mit deinem User-Account und Kennwort -ich hoffe mal, das dieser Admin-Privilegien aufweist.

Nun gibst du einfach nur bcdedit -ohne Parameter- ein. Der nun dargestellte Output enthält auf einem Single-Boot System lediglich 2 Kategorien:

1) Den Windows Start-Manager (Bootmanager)
2) Das Windows Startladeprogramm (Bootloader)

Die dargestellten Infos -zur Not einfach Abschreiben- bitte mal hier um Forum irgendwie verfügbar machen. :smile:

Gruß

IT-Nerd

Benutzeravatar
DK2000
Alleswisser
Alleswisser
Beiträge: 1511
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: Win 10 0xC0000013 und Autoreparatur

Beitrag von DK2000 » 07.11.2018, 22:15

Ist das wirklich ein BSOD? Weil einen BSOD mit dem Code 0xC0000013 finde ich da nicht, auch nicht im SDK/WDK (1809).

Kann aber sein, dass es sich um einen Custom Code handelt. Der erscheint natürlich nicht in den Microsoft Listen.

Steht ganz unten auf der Seite eventuell ein Fehlertext bzw. ein Dateiname?

Existiert eventuell etwas in C:\Windows\Minidump\*.dmp oder eine C:\Windows\Memory.dmp? Die könnte man mal im Debugger auswerten und mal schauen, ob das was bringt.

Benutzeravatar
IT-Nerd
Spezialist
Spezialist
Beiträge: 153
Registriert: 17.04.2018, 21:44
Geschlecht:

Re: Win 10 0xC0000013 und Autoreparatur

Beitrag von IT-Nerd » 07.11.2018, 22:42

Hallo!

Ich wünschte ich wäre schon so weit..

Falls es mir gelingen sollte den Rechner von Delta123 wieder flott zu kriegen -ich zumindest sehe dafür im Augenblick gute Chancen - trete ich die weitere Analyse des BSOD gerne an dich ab.

Dieser StopCode 0xC0000013 scheint -wie auch immer- schon älteren Datums zu sein -im Netz finden sich jede Menge Info dazu, viele davon aus XP/Vista Zeiten.

Hier mal zwei neuere Beiträge zu diesem Problem:

https://answers.microsoft.com/de-de/win ... 4af1a33c03

https://www.win-10-forum.de/windows-10- ... -bsod.html

Gruß

IT-Nerd

expat
Meister
Meister
Beiträge: 324
Registriert: 11.10.2015, 09:54
Geschlecht:

Re: Win 10 0xC0000013 und Autoreparatur

Beitrag von expat » 08.11.2018, 02:14

Gibt es jemanden, bei dem Autoreparatur angeboten und mit Erfolg durchgeführt wurde? Bei mir kam da nie etwas raus.
Freundliche Grüße und einen schönen Tag!
Meine Webseite

Delta123

Re: Win 10 0xC0000013 und Autoreparatur

Beitrag von Delta123 » 08.11.2018, 09:50

Hi IT-Nerd und DK2000,

vielen Dank für Eure Beiträge - das gibt mir wieder etwas Hoffnung.

Es ist ja nicht so, daß alle meine Daten weg sind. Alles was ich habe (Office-Dokumente, Fotos, Videos, etc.) befinden sich auf externen Festplatten.
Was auf der C-platte liegt und was ich gerne retten würde, sind die Thunderbird- und Firefox-Profile sowie den Desktop. Die habe ich zwar aus der Eingabeaufforderung der automatischen Reparatur via Robocopy ebenfalls auf eine externe Platte kopiert. Aber eine Neuinstallation (mit nachfolgender Rücksicherung der Profile etc.) kostet Zeit (alles wieder installieren) und da ich keine Win10-DVD mehr habe (irgendwo natürlich schon, aber wo ...) bin ich mir nicht sicher, ob der alte Key erkannt wird.

So jetzt noch mal ein paar detailliertere Infos:
Die defekte Platte war eine SATA-Platte welche via einen Adapter über USB angeschlossen wurde. Die Platte war ca. 1,5 Tage angeschlossen, aber ich bin mir nicht sicher, ob ich den PC während dieser Zeit neu gestartet habe. Die meiste Zeit wurde die Platte nicht erkannt. Sie lief zwar die ganze Zeit, aber 1-2 mal ertönte der typische PlingPlang Sound wenn ein USB-Gerät erkannt wird, aber sie tauchte weder im Explorer noch in der Datenträgerverwaltung auf. Meist war nach wenigen Minuten auch wieder der Disconnect-Sound zu hören. Ein einziges Mal tauchte sie mit einem Laufwerksbuchstaben für wenige Sekunden im Explorer auf, um dann mit einer Windows-Fehlermeldung (ich weiß ncht mehr welche, aber irgendwas wie "not readable" oder "bad sector" o.ä.) wieder zu verschwinden. Danach sah ich sie nie wieder, aber sie tat irgendwas, was ich an den Geräuschen der Leseköpfe festmache.
Nachdem ich meine Versuche, die Platte zu lesen aufgegeben habe habe ich sie abgestöpselt und den Rechner heruntergefahren. Am nächsten Tag beim Hochfahren kam der "Ich PC hat ein Problem" Bildschirm (also kein BSOD im eigentlichen Sinne), der StopCode 0xC0000013 wurde genannt, Informationen wurden gesammelt und der PC wieder gestartet. Dann fing die Orgie mit der automatischen Reparatur an.
Da der StopCode wohl irgendwas mit "STATUS_NO_MEDIA_IN_DEVICE" bedeutet, werde nochmal versuchen sie wieder anzutöpseln und sehen, ob die Auto-Reparatur dann funktioniert. Ich glaube zwar nicht, aber solange Du mir nicht sagst "Tu das auf keinen Fall" ist es einen Versuch wert, oder ?

Ich glaube auch, daß die auto-Reparatur ein separates Problem ist, aber im Moment komme ich deswegen aber nicht weiter ins System.

Die Bootreihenfolge wies zuerst auf Windows Boot Manager als erstes, dies habe ich auf die SSD geändert, mit dem genanten Effekt. Ich hab's dann wieder zurück geändert.
Wenn ich in der Eingabeaufforderung der Auto-Reparatur (oder eben des WinPE vom Boot-Stick) DISKPART LIST DISK bzw. DISKPART LSIT VOLUME eingebe, sehe ich alle Platten als fehlerfrei.
Die SSD hat den Laufwerksbuchstaben C: und ist NTFS formatiert. Dann gibt es aber noch ein Volume SYSTEM mit FAT32 und VERSTECKT und ein WinPE ebenfalls NTFS. Beide haben keinen Laufwerksbuchstaben, aber alle sind fehlerfrei.

Im Bildschirm nach der fehlgeschlagenen Auto-Reparatur wird auf ein Log hingewiesen. Ich glaube C:\Windows\system32\Logfiles\Srt\SrtTrail.txt, welches eine Fehlerhafte bootres.dll in einem Verzeichnis C:\EFI\... nennt. Ich dachte erst, hiermit wäre die EFI-Partition gemeint, aber die ist ja auf SYStem und nicht auf C: und auf C: finde ich kein verzeichnis EFI - auch nicht versteckt.

Du schreibst " über USB Stick booten um auf eine "saubere" Kommandozeilen-Ebene zu gelangen. Anmelden mit deinem User-Account und Kennwort - ich hoffe mal, das dieser Admin-Privilegien aufweist."
Ich habe einen Boot-Stick über das MediaCreationTool erstellt und damit kommt auch die Installationsmaske mit Reparatur-Optionen. Aber ich muß mich nirgendwo einloggen bzw. kann das gar nicht. Auf jeden Fall kann auf eine Eingabeaufforderung kommen, die wohl Administratorrechte hat (steht zumindest im Titel der CMD).

Ich kann heute abend mal, den Output von BCDEDIT posten, vorher komme ich nicht dazu.

Benutzeravatar
DK2000
Alleswisser
Alleswisser
Beiträge: 1511
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: Win 10 0xC0000013 und Autoreparatur

Beitrag von DK2000 » 08.11.2018, 10:12

Im Bildschirm nach der fehlgeschlagenen Auto-Reparatur wird auf ein Log hingewiesen. Ich glaube C:\Windows\system32\Logfiles\Srt\SrtTrail.txt, welches eine Fehlerhafte bootres.dll in einem Verzeichnis C:\EFI\... nennt. Ich dachte erst, hiermit wäre die EFI-Partition gemeint, aber die ist ja auf SYStem und nicht auf C: und auf C: finde ich kein verzeichnis EFI - auch nicht versteckt.
Nicht von den Laufwerksbuchstaben verwirren lassen. Die 'Automatische Reparatur' läuft in einer eigenen Windows PE Umgebung, die ihre eigenen Buchstaben bekommt. Meist ist C: die Startpartition, aber kann auch schonmal D: oder E: sein. Und die Systempartition kann dann schonmal C: sein. Diese Zuordnungen der Buchstaben gelten auch wirklich nur in dieser Sitzung. Nach dem nächsten Neustart gehen die wieder verloren und haben auch nichts mit den Zuordnungen der Buchstaben des installierten Windows zu tun.

Gut, dieser Fehler mit der bootres.dll ist da nicht so tragisch. Das lässt sich reparieren.

Kommt Du jetzt noch in die automatische Reparatur hinein?
Oder hast Du einen USB Stick mit passender Windows PE Umgebung (Installations Medium)?

Und denke daran, da Dein System im UEFI Modus auf einem Laufwerk mit GPT installiert wurde, keine Tools zur Reparatur verwenden, die für MBR Laufwerke gedacht sind oder versuchen, eine neuen MBR zu schreiben. Das ist bei GPT wirklich eine sehr schlechte Idee.

Da der StopCode wohl irgendwas mit "STATUS_NO_MEDIA_IN_DEVICE" bedeutet, werde nochmal versuchen sie wieder anzutöpseln und sehen, ob die Auto-Reparatur dann funktioniert.

Und das ist halt eben nicht der Fall. STATUS_NO_MEDIA_IN_DEVICE ist ein NT Status Code und eigentlich kein Code für einen BSOD. Daher verwirrt mich das etwas. Solange nicht fest steht, dass es bei Dir sich wirklich um einen BSOD handelt, kann dieser Fehler-Text in die fasche Richtung führen.

Bei den Windows 10 BSODs werden ja eigentlich auch gar keine Codes mehr angezeigt, sondern nur der Fehlertext, welcher für den der Code steht. Wenn bei Dir der Code 0xC0000013 angezeigt wird, gehe ich mal davon aus, dass es nicht der blaue Bild mit einem BSOD ist, sondern nur der einfache blaue Statusbild ist. Oder es ist was neues in Windows 10.

Kann natürlich auch wirklich sein, dass das in irgendeinem Zusammenhang mit der defekten externen USB Platte zu tun hat.
Dieser StopCode 0xC0000013 scheint -wie auch immer- schon älteren Datums zu sein -im Netz finden sich jede Menge Info dazu, viele davon aus XP/Vista Zeiten.
Das ist halt das verwirrende im Moment. Bei allen Threads mit dem Code, die ich da so finde, geht es eigentlich um den NT Status Code 0xC0000013, welcher allenfalls Auslöser für ein BSOD sein kann, aber selber kein BSOD Code ist. Außerdem hat Microsoft den BSOD Screen ja so verändert, das eigentlich gar keine Fehlercodes mehr ausgegeben werden, nur den dazu passenden Text. Jedenfalls war das bislang so. Kann natürlich sein, dass Microsoft hier etwas verändert hat, was allerdings das Ganze etwas unübersichtlich macht.

Wenn man bei der Theorie bleibt, das sein BSOD = NT Status ist, dann steht das für STATUS_NO_MEDIA_IN_DEVICE, was eigentlich nur bei Wechseldatenträgern (optische Laufwerke, SD Karten Leser etc.) auftritt. Dann wird da entweder die SSD irgendwann währen der Bootphase als Wechseldatenträger erkannt un der Datenträger verschwindet plötzlich oder ein echter Wechseldatenträger wird benötigt. Alles sehr seltsam. Würde auch nur passen, wenn BSOD = NT Status ist.

Deswegen hätte ich da gerne mal eine Dump Datei, sofern vorhanden, um mal zu sehen, was da wirklich los ist.
Gibt es jemanden, bei dem Autoreparatur angeboten und mit Erfolg durchgeführt wurde? Bei mir kam da nie etwas raus.
Solange es nur um die Systempartition geht, dann kann die auch etwas reparieren. Mehr macht die ja eigentlich auch nicht. Und selbst mit dieser simplen Aufgabe scheiterst ab und dann, vor Allem bei Multiboot Umgebungen. Aber auch so. Die eigentliche Windows Installation auf der STartpartition wird damit nicht repariert. Das müsste manuell angestoßen werden oder komplett manuell erledigt werden.

Antworten