Problemlösungen: Wenn Videos nicht angezeigt werden...

Vivaldi - Der neue Browser im Opera-Stil.
Benutzeravatar
GwenDragon
★ Team Forum ★
Beiträge: 6755
Registriert: 20.07.2014, 12:25
Geschlecht:

Re: Problemlösungen: Wenn Videos nicht angezeigt werden...

Beitrag von GwenDragon » 17.06.2016, 21:39

Ja, bei jedem Snapshot; wenn nämlich die Chromium-Version ein schnelleres Upgrade bekommt das das seltsame chromium-codecs-ffmpeg-extra, dann passt die alte libffmpeg eben nicht zum Vivaldi und du musst das Updateskript anwerfen.
Ich mache es sowieso so, weil Debian gar kein chromium-codecs-ffmpeg-extra kennt.

Tante Google

Re: Problemlösungen: Wenn Videos nicht angezeigt werden...

Beitrag von Tante Google » 17.06.2016, 21:39


Benutzeravatar
mikko
Berater
Berater
Beiträge: 207
Registriert: 06.09.2014, 12:20

Re: Problemlösungen: Wenn Videos nicht angezeigt werden...

Beitrag von mikko » 18.06.2016, 10:15

Was für ein Gebastel. Das chromium-codecs-ffmpeg-extra hat ja gegenüber dem chromium-codecs-ffmpeg nix mehr als zusätzliche Codecs (inkl. H.264). Deswegen wundert mich, dass trotz installierten chromium-codecs-ffmpeg-extra keine H.264-Videos laufen.

Wird das noch irgendwann geändert oder muss man mit dem ständigen Tausch der libffmpeg.so jetzt leben?

Benutzeravatar
GwenDragon
★ Team Forum ★
Beiträge: 6755
Registriert: 20.07.2014, 12:25
Geschlecht:

Re: Problemlösungen: Wenn Videos nicht angezeigt werden...

Beitrag von GwenDragon » 18.06.2016, 13:45

Klar ist das nervig, aber so ist das bei den Snapshots.
Manchmal ist der Vivaldi-Snapshot mit einer höheren Versionsnummer als der Chromium auf manchen Distries, dann passt das dazu kompilierte chromium-codecs-ffmpeg-extra nicht mehr.
Ansonsten merkst du doch, wenn MP4 nicht läuft. Dann solltest du das Skript anwerfen. So mach ich das dann.

Benutzeravatar
mikko
Berater
Berater
Beiträge: 207
Registriert: 06.09.2014, 12:20

Re: Problemlösungen: Wenn Videos nicht angezeigt werden...

Beitrag von mikko » 18.06.2016, 14:31

Das verstehe ich ja schon, bloß ich begreife nicht so ganz, was Chromium (Vivaldi, Opera...) da so macht. Heißt das, dass Chromium ein auf dem System installiertes ffmpeg/libav nicht direkt nutzt?

Benutzeravatar
GwenDragon
★ Team Forum ★
Beiträge: 6755
Registriert: 20.07.2014, 12:25
Geschlecht:

Re: Problemlösungen: Wenn Videos nicht angezeigt werden...

Beitrag von GwenDragon » 19.06.2016, 12:46

So tief steck ich bei Chromium auch nicht in der Entwicklung bei ffmpeg drin, dass ich das genau wüsste.

Benutzeravatar
mikko
Berater
Berater
Beiträge: 207
Registriert: 06.09.2014, 12:20

Re: Problemlösungen: Wenn Videos nicht angezeigt werden...

Beitrag von mikko » 19.06.2016, 14:29

Kann ja wohl nur so sein. Firefox macht das wohl anders und benutzt meines Wissens das auf dem System installierte ffmpeg/libav inkl. Codecs.

Benutzeravatar
GwenDragon
★ Team Forum ★
Beiträge: 6755
Registriert: 20.07.2014, 12:25
Geschlecht:

Re: Problemlösungen: Wenn Videos nicht angezeigt werden...

Beitrag von GwenDragon » 19.06.2016, 14:58

Ich dachte, bei Firefox sind die Codecs im Programm selbst? -- ohne externe Codecs zu benutzen.

achmennoo
Grünschnabel
Grünschnabel
Beiträge: 46
Registriert: 22.07.2014, 10:29

Re: Problemlösungen: Wenn Videos nicht angezeigt werden...

Beitrag von achmennoo » 13.08.2016, 18:56

Ich hänge mich hier noch mal an. Obwohl es in Win7 keine Probleme mit der Videowiedergabe gibt, ist es unter Linux, OpenSuse 13.2 teilweise nicht möglich, Videos anzuschauen. Beispiel: http://www.golem.de/news/vw-ein-hauch-v ... 18355.html

Leider bin ich nicht so ein Linuxfrickler um mir irgendeine Datei nachträglich irgendwohin zu installieren, insbesondere wenn die Anleitung für ein Debianderivat ist. viewtopic.php?f=343&t=15436&p=280726#p278622
Opera kann Videos wiedergeben. Warum Vivaldi (atuelles Snapshot) nicht?

Benutzeravatar
GwenDragon
★ Team Forum ★
Beiträge: 6755
Registriert: 20.07.2014, 12:25
Geschlecht:

Re: Problemlösungen: Wenn Videos nicht angezeigt werden...

Beitrag von GwenDragon » 13.08.2016, 19:18

Opera liefert die unfreien Codecs wie H264 etc. mit eingebaut. Und zahlt dafür.
Vivaldi will das nicht, aus Kostengründen, denn es gibt in den Chromiumpaketen diese Codecs auch, die extrahiert werden können.
Wenn OpenSuSE solche Pakete nicht machen will, können die Vivladianer nur nix dafür.

1. Log dich al root ein
2. Hol dir http://repo.herecura.eu/pool/vivaldi-ff ... pkg.tar.xz
3. Extrahiere die libffmpeg.so nach /opt/vivaldi/lib/

Dann klappt alles es sei denn OpenSuSE ist extrem nervig veranlagt.

Benutzeravatar
GwenDragon
★ Team Forum ★
Beiträge: 6755
Registriert: 20.07.2014, 12:25
Geschlecht:

Re: Problemlösungen: Wenn Videos nicht angezeigt werden...

Beitrag von GwenDragon » 15.10.2016, 19:55

dann fehlt unter Windows ...
Ihr braucht unbedingt den Windows Media Player und das Media Feature Pack!
http://www.microsoft.com/en-us/download ... x?id=53356
https://support.microsoft.com/en-us/sea ... =KB3133719

Benutzeravatar
GwenDragon
★ Team Forum ★
Beiträge: 6755
Registriert: 20.07.2014, 12:25
Geschlecht:

Re: Problemlösungen: Wenn Videos nicht angezeigt werden...

Beitrag von GwenDragon » 23.12.2016, 12:46

Linuxer
Das Kopieren der libffmpeg nach /opt/vialdi*/lib/ kann jetzt bei neueren Vivaldis zu Ärger führen.

Also leiber vorhandene Packages der Distries nehmen. Und folgendes lesen https://gist.github.com/ruario/bec42d156d30affef655 und das dortige anwenden.

Benutzeravatar
GwenDragon
★ Team Forum ★
Beiträge: 6755
Registriert: 20.07.2014, 12:25
Geschlecht:

Re: Problemlösungen: Wenn Videos nicht angezeigt werden...

Beitrag von GwenDragon » 29.06.2018, 19:06

Flackern bei Video oder Webseite
Es soll bei den derzeitigen 1.15 Stable und 1.16 Snapshots helfen Vivaldi so zu starten:
vivaldi --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

Setzt bei einigen Grafikkarten diverse Patches außer Kraft.
Kann vielleicht auch einigen Linux, Windows oder Mac helfen.

Diese Schalter sind ja langsam bei Chrome, Chromium o.ä. so unübersichtlich, wann was hilft ist wohl Geheimwissen :(

Antworten