Intel Management Engine Software 12.0 bzw, Firmware 10.0; installieren oder nicht?

Deine Frage passt nicht in die anderen Bereiche, dann stelle sie hier.
ecerer

Re: Intel Management Engine Software 12.0 bzw, Firmware 10.0; installieren oder nicht?

Beitrag von ecerer » 22.07.2020, 19:52

Das ME Update kann doch nicht heimlich vom Chipset-Treiber kommen?

Tante Google

Re: Intel Management Engine Software 12.0 bzw, Firmware 10.0; installieren oder nicht?

Beitrag von Tante Google » 22.07.2020, 19:52


Benutzeravatar
DK2000
Legende
Legende
Beiträge: 5836
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: Intel Management Engine Software 12.0 bzw, Firmware 10.0; installieren oder nicht?

Beitrag von DK2000 » 22.07.2020, 20:04

Nicht dass ich wüsste, außer der OEM hat sich da selber etwas zurechtgebastelt. Intel selber bietet keine Updates an. Die gibt es nur über die Geräte- bzw. Boardhersteller.

ecerer

Re: Intel Management Engine Software 12.0 bzw, Firmware 10.0; installieren oder nicht?

Beitrag von ecerer » 22.07.2020, 20:23

Welches Interface ist klar, da hat mein Interface ein ähnliches Problem gehabt :ohno:

ecerer

Re: Intel Management Engine Software 12.0 bzw, Firmware 10.0; installieren oder nicht?

Beitrag von ecerer » 23.07.2021, 14:13

ecerer hat geschrieben: 16.07.2020, 15:00 ich bekomme manchmal eine Fehlermeldung beim booten: "Error sending end of post message to ME : HECI disabled, proceeding with boot!"
Wollte mal noch sagen, dass die Meldung sehr laaange nicht mehr kam und überfällig ist, ohne BIOS/IME Update!

ecerer

Re: Intel Management Engine Software 12.0 bzw, Firmware 10.0; installieren oder nicht?

Beitrag von ecerer » 25.08.2021, 20:49

Nicht das es jemand interessieren sollte aber ich muss das leider widerrufen.
Wie ich das geschrieben hatte, habe ich eine Option im BIOS verstellt und dann aber auch gleich wieder rückgängig gemacht aber nun kommt wieder ständig diese Meldung: "Error sending end of post message to ME : HECI disabled, proceeding with boot!" :ohno:

Benutzeravatar
moinmoin
★ Team Admin ★
Beiträge: 53633
Registriert: 14.11.2003, 11:12
Geschlecht:

Re: Intel Management Engine Software 12.0 bzw, Firmware 10.0; installieren oder nicht?

Beitrag von moinmoin » 26.08.2021, 07:33

Googelt man, wird diese Fehlermeldung auch mit TPM in Verbindung gebracht. :kopfkratz:

ecerer

Re: Intel Management Engine Software 12.0 bzw, Firmware 10.0; installieren oder nicht?

Beitrag von ecerer » 26.08.2021, 11:54

Der Ansatz gefällt mir, das TPM ist ein bisschen eine Blackbox und ich habe das nie gelöscht, weil es funktionierte...
Mal sehn, in ein paar Tagen sollte die Meldung erscheinen oder nicht.

Danke. :thx:

Benutzeravatar
Purgatory
★ Team Forum ★
Beiträge: 269
Registriert: 27.09.2018, 18:52

Re: Intel Management Engine Software 12.0 bzw, Firmware 10.0; installieren oder nicht?

Beitrag von Purgatory » 26.08.2021, 12:09

Dazu muss man wissen, dass die ME zwingend erforderlich ist für einen Boot. Wirklich deaktivieren kann man sie nicht, sollte man auch nicht. Was gerade passiert ist die Tatsache, dass die ME irgendetwas gefunden hat was nicht übereinstimmt mit den gespeicherten Daten in der ME Firmware. Pauschal ist das erstmal überhaupt nicht weiter schlimm, nur nervig. Weiterhin sollte man wissen, dass ME an den SM-Bus angeschlossen ist und somit generell alles auslesen kann was mit dem SM-Bus kommuniziert. Auch ist ME mit dem TPM Chip verbunden.
Jetzt führen viele Wege nach Rom. Es kann der TPM Chip sein, schließe ich aber eher aus insofern nicht aktiviert (und auch nicht vorher gewesen). Manchmal kommen Windows Updates rein und überschreiben den SM-Bus Controller, also den Treiber. ME findet jetzt eine andere Treiberversion als vorher und meldet logischerweise einen Fehler. Hier würde es helfen via Gerätemanager auf den vorigen Treiber zurückzukehren (siehe Link). Auch kann es Secureboot sein. Einmal angeschaltet, und das war es vorher nicht, (oder umgekehrt) kann diesen Fehler generieren. Hier würde helfen Secureboot entweder an bzw. auszuschalten (wie es vorher war) und das System eine zeitlang in diesem Zustand zu belassen. Auch kann es sein (siehe SM-Bus), dass ein falscher Treiber für die ME selbst installiert ist der nicht zu der Firmwareversion passt (Windows Update oder selbst installiert).
Seitens Intel ist die ME schwer zu diagnostizieren wenn sie Fehler ausspuckt, Intel lässt halt viel zu wenig Informationen diesbezüglich raus.
Die radikalste Methode (aber auch die effektivste) wäre das BIOS einmal komplett zu resetten um zu schauen wo der Fehler liegt. Ist nach dem Reset alles ok, war es eine falsche Einstellung. Bleibt der Fehler ist er via Windows zu beheben. Bei mir damals war es tatsächlich dieses Problem: https://docs.microsoft.com/de-de/troubl ... ler-device
Wenn ich 64 Bit intus habe, kann ich auch alles :anstossen:

Hardware:
CPU: Ryzen 9 5900x GPU: Sapphire Nitro+ 6800XT OC/UV MB: GA-X570 Aorus Master RAM: GSkill Trident Z Neo 2x16GB SSD/HDD: Samsung 980 Pro 1TB & 2TB, Samsung 870 Evo 4TB, Seagate ST4000DX001 PSU: BeQuiet! Straight Power Platinum 1000W Sound: Soundblaster Z Kühlung: Corsair iCUE H150i RGB PRO XT Case: Lian-Li O11 Dynamic

Benutzeravatar
DK2000
Legende
Legende
Beiträge: 5836
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: Intel Management Engine Software 12.0 bzw, Firmware 10.0; installieren oder nicht?

Beitrag von DK2000 » 26.08.2021, 13:43

Das ist alles kompliziert. Erklärt alles nicht wirklich, warum die Schnittstelle abgeschaltet ist. Die Meldung kommt ja vom BIOS direkt.

Das BIOS möchte gerne die Nachricht vom Ende des POST dem ME mitteilen, kann es aber nicht, weil die Schnittstelle (HECI) abgeschaltet ist. In seinem Falle ist das unkritisch und das System bootet normal weiter. Lästig wird es erst, wenn dort anstelle von "proceeding with boot!" ein glückliches "System Halt!" steht. Dann hat man wirklich ein Problem.

Und hier ist halt die Frage, warum ist die Schnittstelle abgeschaltet. Dadurch ist die ME vom System eigentlich getrennt worden.

Was erscheint denn im Gerätemanager:

"SM-Bus Controller" oder "Intel(R) Management Engine Interface"

Oder nichts davon?


Einen "SM-Bus Controller" habe ich da gar nicht mehr. Das läuft bei mir alles über das "Management Engine Interface (HECI). SM-Bus wurde ja durch HECI ersetzt. Ist zwar prinzipiell das Selbe (die direkte Schnittelle zur ME), aber doch ein wenig anders.

Eventuell hilft auch, das Gerät mal zu 100% stromlos machen und 1h warten. Hat beim Tablet nach dem manuellen Firmwareupdate für die ME auch geholfen, nur dass ich hier 2 Wochen warten musste, biss der Akku leer war. Bei nächsten Booten kam dann etwas vom Management Engine Reset und noch ein paar andere Sachen, danach einen selbstständigen Neustart und seit dem läuft es wieder wie erwartet. Aber das war halt bei mir, weil ich die ME Firmware selber aktualisiert habe.

Benutzeravatar
Purgatory
★ Team Forum ★
Beiträge: 269
Registriert: 27.09.2018, 18:52

Re: Intel Management Engine Software 12.0 bzw, Firmware 10.0; installieren oder nicht?

Beitrag von Purgatory » 26.08.2021, 14:03

DK2000 hat geschrieben: 26.08.2021, 13:43 Das ist alles kompliziert. Erklärt alles nicht wirklich, warum die Schnittstelle abgeschaltet ist. Die Meldung kommt ja vom BIOS direkt.
Da hast Du natürlich recht, allerdings kam die Meldung bei mir auch und HECI war in Windows aktiviert. Sichtbar und keinerlei Fehler.
Daher kann es sein, dass HECI durchaus teilaktiv ist (muss es auch, komplett abgeschaltet kann es nicht sein). Die Fehlermeldung sagt im Prinzip nur aus, dass das BIOS im HECI Adressen anspricht die nicht vorhanden sind, sprich abgeschaltet sind. Ein Stoppfehler würde kommen wäre das HECI überhaupt nicht mehr erreichbar. HECI ist so undurchsichtig, dass man kaum Fehler finden kann. Ich vermute, dass Teilbereiche abgeschaltet werden insofern irgendwelche Dinge nicht übereinstimmen. Wäre das nicht so würde das System stoppen.
Und im Gegensatz zum BIOS kommuniziert das UEFI ja schon beim Hochfahren mit Windows. Daher mein Lösungsansatz auch mit dem Hinweis das komplette BIOS mal zu resetten.
Wenn ich 64 Bit intus habe, kann ich auch alles :anstossen:

Hardware:
CPU: Ryzen 9 5900x GPU: Sapphire Nitro+ 6800XT OC/UV MB: GA-X570 Aorus Master RAM: GSkill Trident Z Neo 2x16GB SSD/HDD: Samsung 980 Pro 1TB & 2TB, Samsung 870 Evo 4TB, Seagate ST4000DX001 PSU: BeQuiet! Straight Power Platinum 1000W Sound: Soundblaster Z Kühlung: Corsair iCUE H150i RGB PRO XT Case: Lian-Li O11 Dynamic

ecerer

Re: Intel Management Engine Software 12.0 bzw, Firmware 10.0; installieren oder nicht?

Beitrag von ecerer » 26.08.2021, 14:33

Also ich bin optimistisch, dass es am TPM liegt.🤞

Für den Fall, dass ich nicht alles verstehe, liefer ich ein paar Informationen.
- BIOS-Reset hab ich zu anfangs auch immer mal probiert, brachte aber nichts, jetzt weiß ich aber nicht mehr ob das TPM davon unberührt bleibt. Das TPM an und ausschalten sollte es löschen.
- SecureBoot immer an
- TPM aktiviert(Bitlocker)
- Geräte Manager->Chipset Family SMBus->Kein Treiber installiert(?), hab aber mal verschiedene Chipset-Treiber Versionen durch probiert.
- Geräte Manager->Intel Management Engine Interface-> Das Gerät funktioniert einwandfrei
- ME-Treiber nicht vollständig installiert(MEI only, also bloß den HECI Treiber) (das war auch immer meine Vermutung aber auch das installieren brachte nichts)
Wusste gar nicht, dass es den Full ME-Treiber(300MB) nur für Gen 6-8 gibt.
Purgatory hat geschrieben: 26.08.2021, 12:09 ME findet jetzt eine andere Treiberversion als vorher und meldet logischerweise einen Fehler. Hier würde es helfen via Gerätemanager auf den vorigen Treiber zurückzukehren (siehe Link).
So etwas könnte ich mir auch vorstellen. Aber lasst erstmal abwarten 🤞

Benutzeravatar
DK2000
Legende
Legende
Beiträge: 5836
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: Intel Management Engine Software 12.0 bzw, Firmware 10.0; installieren oder nicht?

Beitrag von DK2000 » 26.08.2021, 15:53

Habe da mal auf dem Tablet nachgeschaut und da gibt es ein Gerät mit dem Namen:

"Mobile 6th/7th Generation Intel(R) Processor Family I/O SMBUS - 9D23"

Hat aber keine Treiber geladen. Muss wohl so sein. Probleme am Gerät habe ich da keine. Das INF Update benennt das Gerät eigentlich nur um. Passende Treiber finde ich dafür keine.

Das Gerät "Intel(R) Management Engine Interface" verwendet die Treiber aus der heci.inf.

Die meisten Treiber dafür kamen über das Windows Update, da externe Treiber kaum zu finden sind oder ich muss sie mir von anderen Geräteherstellern zusammenstellen.

ecerer
Einsteiger
Einsteiger
Beiträge: 11
Registriert: 23.09.2021, 17:09

Re: Intel Management Engine Software 12.0 bzw, Firmware 10.0; installieren oder nicht?

Beitrag von ecerer » 23.09.2021, 18:33

Also am TPM liegt es auch nicht. Hab auch nochmal BIOS-Reset und ohne Strom gemacht.
Wollte mein nächstes Kommentar zwar besser überlegen aber Ich muss meinen 2. Kommentar schreiben...


Antworten