Nach InPlace-Upgrade auf Win10-1809 Probleme mit virtuellem Speicher

Deine Frage passt nicht in die anderen Bereiche, dann stelle sie hier.
Natz
Grünschnabel
Grünschnabel
Beiträge: 33
Registriert: 12.09.2015, 16:24
Geschlecht:

Nach InPlace-Upgrade auf Win10-1809 Probleme mit virtuellem Speicher

Beitrag von Natz » 13.12.2018, 12:36

Salve,
vor einigen Tagen habe ich mit der aktuellen Win10-1809 ISO (Stand: 4.12.2018) aus diesem Forum ein InPlace Upgrade von Version 1803 gemacht. Es hat bei der Installation soweit auch alles geklappt, bis auf eine zusätzliche 499 MB-Partion auf der System-SSD. :kopfkratz:

Nachteilig war allerdings, dass seit dem Upgrade meine Einstellungen für den virtuellen Speicher nicht mehr funktionieren. Ich hatte bislang auf C:\ keinen virtuellen Speicher aktiviert, dafür aber auf einer anderen HD. Bis Version 1803 war das auch überhaupt kein Problem.
Nach dem Upgrade kam bereits zum Zeitpunkt der Anmeldung am System ein Warnhinweis (siehe Anhang) wg. eines Problems mit dem virtuellen Speicher.

Nach gefühlten 100 verschiedenen Versuchen kann ich nur feststellen:
1. Seit 1809 muss (bei mir) der virtuelle Speicher auf C:\ liegen.
2. Trotzdem wird auch eine "Pagefile.sys" in der gewählten Größe auf anderen ausgewählten LW angelegt und angezeigt im Explorer.
3. Solange LW C:\ nicht beteiligt ist, kann ich die Größe der Auslagerungsdatei beliebig ändern; die Fehlermeldung bleibt bestehen.
4. Windows legt nach Bestätigung der Fehlermeldung eine Auslagerungsdatei von 16 MB automatisch auf C:\ an.
5. Bei Mehrfachauswahl (LW C:\ und anderes LW) berücksichtigt Win nur den auf C:\ liegenden Teil.

Ist das jetzt so unter Windows 10-1809, oder habe ich nur wieder mal ein Brett vorm Kopf? Ich hätte es lieber, wenn ich die Pagefile.sys wieder ausschließlich auf ein anderes LW packen könnte.
Auslag W10.jpg
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
---
ciao, Bernd

Tante Google

Nach InPlace-Upgrade auf Win10-1809 Probleme mit virtuellem Speicher

Beitrag von Tante Google » 13.12.2018, 12:36


Benutzeravatar
DK2000
Superhirn
Superhirn
Beiträge: 1058
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: Nach InPlace-Upgrade auf Win10-1809 Probleme mit virtuellem Speicher

Beitrag von DK2000 » 13.12.2018, 12:53

Bei mir liegt die Auslagerungsdatei auch auf D: und nicht auf C:. Allerdings hatte ich sie beim Upgrade auf die 1809 noch auf C:. Von daher weiß ich nicht, wie sich Das Upgrade verhält, wenn die Auslagerungsdatei zum Zeitpunkt des Upgrades außerhalb von C: ist.

Kann sein, dass sich bei Dir durch das Anlegen und zurücklassen einer überflüssigen Partition Windows durcheinander gekommen ist. Aber das mit der zusätlichen Partition hatte ich da auch. Eine konnte ich davon löschen, da ungenutzt.

Hast Du mal alle Auslagerungsdateien deaktiviert? Auch in der Registry mal nachgeschaut, ob da in der Liste noch eine Auslagerungsdatei an flachen Ort eingetragen ist:

Code: Alles auswählen

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]
ExistingPageFiles	REG_MULTI_SZ	\??\D:\pagefile.sys 
`
Das Problem mit der Fehlermeldung beruht darauf, dass die Gesamtgröße aller Auslagerungsdateien nicht mehr passt. Das lässt sich eigentlich dadurch beheben, wenn man alle Auslagerungsdateien deaktiviert, einmal Neustart ausführt und die Auslagerungsdateien neu anlegen lässt.

Benutzeravatar
moinmoin
★ Team Admin ★
Beiträge: 43726
Registriert: 14.11.2003, 11:12
Geschlecht:

Re: Nach InPlace-Upgrade auf Win10-1809 Probleme mit virtuellem Speicher

Beitrag von moinmoin » 13.12.2018, 12:57

Das mit der zusätzlichen Partition passiert immer wieder mal beim Inplace.
Lässt sich aber lösen
https://www.deskmodder.de/blog/2018/04/ ... angezeigt/

Wird bei dir denn im anderen Laufwerk auch eine Auslagerungsdatei angezeigt?

Datenträgerbereinigung Windows 10 Alte Daten richtig löschen
Abschnitt 12.

PS: Man sollte die Auslagerung schon auf C lassen und nicht unter 768 MB einstellen.
Bild
Deskmodder findet ihr bei: Google+ | Twitter | Facebook Windows 10 Tipps und Tricks: Tutorials Windows 10.

Natz
Grünschnabel
Grünschnabel
Beiträge: 33
Registriert: 12.09.2015, 16:24
Geschlecht:

Re: Nach InPlace-Upgrade auf Win10-1809 Probleme mit virtuellem Speicher

Beitrag von Natz » 14.12.2018, 10:31

Danke für die bisherigen Antworten. Ich bin derzeit gesundheitlich ziemlich eingeschränkt und werde mich erst ab Mitte nächster Woche damit befassen können. Selbstverständlich gebe ich dann eine Rückmeldung.
---
ciao, Bernd

Natz
Grünschnabel
Grünschnabel
Beiträge: 33
Registriert: 12.09.2015, 16:24
Geschlecht:

Re: Nach InPlace-Upgrade auf Win10-1809 Probleme mit virtuellem Speicher

Beitrag von Natz » 19.12.2018, 18:33

So, ich bin jetzt einigermaßen wieder auf dem Damm und habe mich heute mit der Problemlösung beschäftigt. Richtig weitergekommen bin ich bislang aber nicht. :kopfkratz:
moinmoin hat geschrieben:
13.12.2018, 12:57
Das mit der zusätzlichen Partition passiert immer wieder mal beim Inplace.
Lässt sich aber lösen
https://www.deskmodder.de/blog/2018/04/ ... angezeigt/
Dieses Problem ist jetzt aber keins mehr; die Partition bin ich wieder los. Danke.
moinmoin hat geschrieben:
13.12.2018, 12:57
Wird bei dir denn im anderen Laufwerk auch eine Auslagerungsdatei angezeigt?
Ja, wird es. Siehe hierzu auch meinen nächsten Beitrag (Antwort auf DK2000; wird jetzt gleich noch erstellt).
moinmoin hat geschrieben:
13.12.2018, 12:57
PS: Man sollte die Auslagerung schon auf C lassen und nicht unter 768 MB einstellen.
Irgendwie gehöre ich da noch zum alten Schlag. Ich glaube immer noch, dass die ständigen Lese-/Schreibzugriffe auf die Pagefile.sys die Lebensdauer der SSD negativ beeinflussen können ... :smile:
---
ciao, Bernd

Benutzeravatar
moinmoin
★ Team Admin ★
Beiträge: 43726
Registriert: 14.11.2003, 11:12
Geschlecht:

Re: Nach InPlace-Upgrade auf Win10-1809 Probleme mit virtuellem Speicher

Beitrag von moinmoin » 19.12.2018, 18:46

Die neuen SSDs halten viel mehr aus, als du denkst. 100 GB am Tag machen einer SSD gar nichts.
Bild
Deskmodder findet ihr bei: Google+ | Twitter | Facebook Windows 10 Tipps und Tricks: Tutorials Windows 10.

Natz
Grünschnabel
Grünschnabel
Beiträge: 33
Registriert: 12.09.2015, 16:24
Geschlecht:

Re: Nach InPlace-Upgrade auf Win10-1809 Probleme mit virtuellem Speicher

Beitrag von Natz » 19.12.2018, 18:59

DK2000 hat geschrieben:
13.12.2018, 12:53
Kann sein, dass sich bei Dir durch das Anlegen und zurücklassen einer überflüssigen Partition Windows durcheinander gekommen ist. Aber das mit der zusätlichen Partition hatte ich da auch. Eine konnte ich davon löschen, da ungenutzt.
Dieses Problem konnte ich als einziges lösen.
DK2000 hat geschrieben:
13.12.2018, 12:53
Hast Du mal alle Auslagerungsdateien deaktiviert? Auch in der Registry mal nachgeschaut, ob da in der Liste noch eine Auslagerungsdatei an flachen Ort eingetragen ist:

Code: Alles auswählen

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]
ExistingPageFiles	REG_MULTI_SZ	\??\D:\pagefile.sys 
`
Das Problem mit der Fehlermeldung beruht darauf, dass die Gesamtgröße aller Auslagerungsdateien nicht mehr passt. Das lässt sich eigentlich dadurch beheben, wenn man alle Auslagerungsdateien deaktiviert, einmal Neustart ausführt und die Auslagerungsdateien neu anlegen lässt.
Bevor ich heute weitere Lösungsversuche machte, habe ich mich zu dem Registry-Schlüssel vorgearbeitet. Mir wurde folgendes angezeigt:
181219 Existing Pagefiles.jpg
Dann habe ich sämtliche Laufwerke durchsucht, ob da noch irgendwo Auslagerungsdateien lagen: Fehlanzeige.
Dann in den Systemeinstellungen alle Auslagerungsdateien gelöscht. Dann Neustart.
PC startete ohne die Fehlermeldung im Eröffnungsbeitrag, und auf keiner Partition war ein Auslagerungsdatei eingetragen.
Ich habe auf LW I: eine neue Pagefile.sys angelegt mit 4096 MB Größe (bei 16 GB RAM; LW I: ist ein internes Laufwerk, kein ext. Sata oder USB).
Dann Neustart. Beim Anmeldebildschirm gab es wieder einen Hinweiston und die Fehlermeldung des Eröffnungsbeitrages.
Die Registry sagt:
19-12-_2018_18-03-28.jpg
Mein Explorer sagt:
19-12-_2018_18-00-55.jpg
Die Systemeinstellung sagt:
19-12-_2018_18-52-15.jpg
(dieses letzt Bild stammt von einem weiteren Versuch, bei dem ich lediglich statt einer festen eine variable Auslagerung angelegt hatte.)
Tja, und jetzt weiß ich erst mal nicht weiter ...
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
---
ciao, Bernd

Antworten