17763.194 X64 Build + Aktivierten Net3.5 kb4470502 Problem ( Gelöst )

Deine Frage passt nicht in die anderen Bereiche, dann stelle sie hier.
lalala
Grünschnabel
Grünschnabel
Beiträge: 45
Registriert: 12.12.2018, 08:24

Re: 17763.194 X64 Build + Aktivierten Net3.5 kb4470502 Problem ( Gelöst )

Beitrag von lalala » 14.12.2018, 14:05

ich habe mir jetzt mal aus dem download bereich
eine version geladen die nicht von mir ist, wo das net update
auch eingespielt worden ist, aber nicht aktiviert wurde.

ich habe mir jetzt die install.wim davon ausgebaut, und zusätzlich
noch das net aktiviert, und sie wieder ins image eingespielt.

testlauf in der vmware gemacht, bei der Windows update suche
wird wieder das Kumulative windows10.0-kb4471332-x64 gefunden.
gleiches spiel wie bei mir.

hab mal screenshot gemacht mit winver im hintergrund.

Bild
Zuletzt geändert von lalala am 14.12.2018, 14:17, insgesamt 1-mal geändert.

Tante Google

Re: 17763.194 X64 Build + Aktivierten Net3.5 kb4470502 Problem ( Gelöst )

Beitrag von Tante Google » 14.12.2018, 14:05


lalala
Grünschnabel
Grünschnabel
Beiträge: 45
Registriert: 12.12.2018, 08:24

Re: 17763.194 X64 Build + Aktivierten Net3.5 kb4470502 Problem ( Gelöst )

Beitrag von lalala » 14.12.2018, 14:15

Mich stört das jetzt eigentlich nicht mehr, da ich ja jetzt weis wie ich das umgehen kann.

Benutzeravatar
DK2000
Superhirn
Superhirn
Beiträge: 1060
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: 17763.194 X64 Build + Aktivierten Net3.5 kb4470502 Problem ( Gelöst )

Beitrag von DK2000 » 14.12.2018, 16:47

Ich befürchte da bloß, das beim nächsten CU das selbe Speil wieder beginnt.

Mangels genauer Protokollierung beim Offline-Servicing habe ich da im Moment noch keinen offensichtlichen Fehler entdecken können.

Habe da nur festgestielt, dass dism /Image:"%mount%" /Cleanup-Image /StartComponentCleanup /ResetBase nichts wesentliches entfernt, außer ein paar AMD Treiber. Der Rest wird komprimiert (Delta Compression) und verbleibt im Komponentenspeicher. Keine Ahnung, seit wann das so ist. Unterstützt wird das wohl schon seit 2014. Ist mir so aber nie aufgefallen.

Benutzeravatar
DK2000
Superhirn
Superhirn
Beiträge: 1060
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: 17763.194 X64 Build + Aktivierten Net3.5 kb4470502 Problem ( Gelöst )

Beitrag von DK2000 » 14.12.2018, 19:08

Ich gebe es auf. Finde da keinen Fehler. Selbst der CBS ist da dieser Ansicht. Ich weiß nicht, wieso das Windows Update das KB4471332 erneut anbietet und es dem CBS vorsetzt. Der muss dann natürlich seine Schleife durchlaufen mit dem bahnbrechenden Ergebnis, dass alles passt und nichts getan werden muss.

Alle Pakete im CU werden wie folgt bewertet:

Code: Alles auswählen

Exec: Package: Package_xxxx_for_KB4471332~31bf3856ad364e35~amd64~~10.0.1.5 is already in the correct state, current: Installed, targeted: Installed
Exec: Skipping Package: Package_xxxx_for_KB4471332~31bf3856ad364e35~amd64~~10.0.1.5, Update: 4471332-1142_neutral because it is already in the correct state.
Und am Ende kommt nur noch Exec: Skipping transaction commit since nothing was changed.

Also im Grunde genommen wird das KB4471332 einfach nur noch mal herunter geladen um zu schauen, ob es noch da ist.

Ob das jetzt ein gewolltes Verhalten ist oder ein Bug im WU Client, kann ich nicht beurteilen.

---

Und nebenbei, es ist vollkommen egal, ob man das NetFX3 bereits in die Install.wim integriert (u. ggf aktiviert), das KB4471332 bekommt man auch angeboten, wenn man das NetFX3 aus der Install.wim weglässt und erst nach der Installation im Online-Modus hinzufügt. Alle anderen Updates waren natürlich integriert worden.

lalala
Grünschnabel
Grünschnabel
Beiträge: 45
Registriert: 12.12.2018, 08:24

Re: 17763.194 X64 Build + Aktivierten Net3.5 kb4470502 Problem ( Gelöst )

Beitrag von lalala » 14.12.2018, 19:22

also ich bekomme es nicht wieder angeboten wenn ich es nur in der install.wim installiere.
nur wenn wenn ich es in der install.wim aktiviere, wird es wieder angeboten.

vielleicht ja doch nen Bug sollte man den jungs von MS mal mitteilen ;-)

Gruß lalala
Zuletzt geändert von lalala am 14.12.2018, 19:25, insgesamt 1-mal geändert.

Benutzeravatar
DK2000
Superhirn
Superhirn
Beiträge: 1060
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: 17763.194 X64 Build + Aktivierten Net3.5 kb4470502 Problem ( Gelöst )

Beitrag von DK2000 » 14.12.2018, 19:25

Ja, solange man es nicht aktiviert, ist es egal. Nur sobald man es aktiviert, egal Online oder Offline, kommt das KB4471332 erneut über das WU.

lalala
Grünschnabel
Grünschnabel
Beiträge: 45
Registriert: 12.12.2018, 08:24

Re: 17763.194 X64 Build + Aktivierten Net3.5 kb4470502 Problem ( Gelöst )

Beitrag von lalala » 14.12.2018, 19:27

das hatte ich jetzt gar nicht mehr getestet.. das ja hart.
sehr merkwürdig das ganze verhalten.
Also Online habe ich es nicht mehr getestet.

Benutzeravatar
Nemo_G
Spezialist
Spezialist
Beiträge: 159
Registriert: 10.05.2014, 10:09
Geschlecht:

Re: 17763.194 X64 Build + Aktivierten Net3.5 kb4470502 Problem ( Gelöst )

Beitrag von Nemo_G » 15.12.2018, 14:25

DK2000 hat geschrieben:
14.12.2018, 19:25
Ja, solange man es nicht aktiviert, ist es egal. Nur sobald man es aktiviert, egal Online oder Offline, kommt das KB4471332 erneut über das WU.
Ähnliche Effekte hatte ich auch bei Server 2016 und 2019:
Nachdem ich Features, wie z.B. Print- und Datei-Server, aktiviert hatte, wollte mich WU nochmals mit dem aktuellen kumulativen Update beglücken, obwohl ich das bereits in die ursprünglichen Install.WIMs integriert hatte.
Seitdem ich in den Install.WIMs der Basisversionen 14393 bzw. 17763 bereits die benötigten Features aktiviert und erst dann die nötigen Patches integriert hatte, ließ mich auch WU in Ruhe.

Gruß, Nemo
Lizenzfrage: Die deutsche Rechtschreibung ist Freeware; jeder darf sie nutzen.
Sie ist aber nicht OpenSource; das heißt, der Nutzer darf sie nicht verändern!

Benutzeravatar
DK2000
Superhirn
Superhirn
Beiträge: 1060
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: 17763.194 X64 Build + Aktivierten Net3.5 kb4470502 Problem ( Gelöst )

Beitrag von DK2000 » 15.12.2018, 14:52

OK, das habe ich jetzt nicht weiter getestet, ob das mit anderen OCs auf dem Client auch passiert.

Kann natürlich darauf hindeuten, dass das ein gewolltes Verhalten ist, da OCs anders behandelt werden. Die können mehr veralten.

Bei Server Rollen weiß ich es gar nicht. Da habe ich das überhaupt nicht getestet.

Benutzeravatar
Nemo_G
Spezialist
Spezialist
Beiträge: 159
Registriert: 10.05.2014, 10:09
Geschlecht:

Re: 17763.194 X64 Build + Aktivierten Net3.5 kb4470502 Problem ( Gelöst )

Beitrag von Nemo_G » 15.12.2018, 18:28

DK2000 hat geschrieben:
15.12.2018, 14:52
... anderen OCs ...
Was heißt OC?

Gruß, Nemo
Lizenzfrage: Die deutsche Rechtschreibung ist Freeware; jeder darf sie nutzen.
Sie ist aber nicht OpenSource; das heißt, der Nutzer darf sie nicht verändern!

Benutzeravatar
DK2000
Superhirn
Superhirn
Beiträge: 1060
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: 17763.194 X64 Build + Aktivierten Net3.5 kb4470502 Problem ( Gelöst )

Beitrag von DK2000 » 15.12.2018, 18:47

Optional Component, wobei der richtige Ausdruck dafür 'Features on Demand (FOD)' ist.

Und ab der 1809 haben sich da auch Dinge geändert. Das mit dem immer wiederkehrenden Update schein gewollt zu sein:

Add language packs, FODs, and apps, in that order, prior to installing an update. If you add an update prior to adding language packs, FODs, and apps you'll have to reinstall the update.

Das habe ich mittlerweile auch festgestellt. Wenn ich andere FOD aktiviere bzw. aktivierte deaktiviere und anschließend wieder aktiviere (z.B. Internet Explorer), dann kommt auch jedes Mal das aktuelle CU über das Windows Update:
Anmerkung 2018-12-15 184400.jpg
Hat er jetzt schon 4x neu heruntergeladen und installiert.

Das scheint tatsächlich so gewollt zu sein, warum auch immer.

Man soll zwar diese FODs jetzt generell mit /Add-Capability integrieren (neu ab 1809), aber macht letztendlich keinen Unterschied.

Und die Sache mit /Cleanup-Image /StartComponentCleanup [/ResetBase] und der Datenträgerbereinigung scheint sich auch geändert zu haben.
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

Benutzeravatar
Manny
Aufsteiger
Aufsteiger
Beiträge: 85
Registriert: 27.03.2018, 18:12
Geschlecht:

Re: 17763.194 X64 Build + Aktivierten Net3.5 kb4470502 Problem ( Gelöst )

Beitrag von Manny » 15.12.2018, 20:28

DK2000 hat geschrieben:
15.12.2018, 18:47
Optional Component, wobei der richtige Ausdruck dafür 'Features on Demand (FOD)' ist.
….
Wenn ich andere FOD aktiviere bzw. aktivierte deaktiviere und anschließend wieder aktiviere (z.B. Internet Explorer), dann kommt auch jedes Mal das aktuelle CU über das Windows Update:
...
Also würde das (meinerseits) erklären warum ich das besagte Update KB 4471332 bis jetzt wo dieses Thema hier läuft NICHT mehr bekommen habe - unter Systemsteuerung / Programme / Programme und Features / Installierte Updates steht als installiert der 12.12.18 drin (aber seit der Zeit 10 Defender Aktualisierungen )
weil ich als letzte (nachträglich bearbeitete) ISO diese NUR bestückt hatte mit besagter KB UND natürlich dem SSU und da dann auch im Abschluss /Cleanup-Image /StartComponentCleanup [/ResetBase] benutzt hatte und dann die ISO fertig gestellt habe - DANACH habe ich dann erst erneut die ISO erneut gemounted bzw. die betreffende Install.wim und die Sache mit dem Netframe hinzugefügt ( installiert und auch aktiviert). Mit dieser fertigen ISO hatte ich dann das Inplace gemacht und seitdem ist über WU "Ruhe" mit der KB 4471332

Benutzeravatar
DK2000
Superhirn
Superhirn
Beiträge: 1060
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: 17763.194 X64 Build + Aktivierten Net3.5 kb4470502 Problem ( Gelöst )

Beitrag von DK2000 » 15.12.2018, 20:47

Ja, so sieht es wohl aus. Solange man an den FODs nichts mehr verändert, dann hat man Ruhe vor dem KB4471332.

Sobald man aber nach der Installation wieder etwas ändert, z.B. Internet Explorer deaktiviert, dann kommt es wieder. Aktiviert man den Internet Explorer wieder, kommt das Update auch wieder. Passiert auch, wenn man das NetFX3 wieder deaktiviert.

Daher steht ja der Zähler bei mir für das Update auf 4 (ganz am Ende der Zeile hinter dem Namen des Updates). Jedesmal wenn es angeboten wird und erneut 'installiert' wird, wird hochgezählt. Mittlerweile bin ich bei 9.

Und es ist dabei vollkommen uninteressant, ob man das Offline macht, also die Updates in die install.wim integriert, oder ob man das Online macht, also die Updates über das Windows Update installiert. Sobald man nach dem KB4471332 an den FODs was verändert (aber nicht bei allen), kommt es wieder.

---

Habe mir da jetzt auch noch einmal ein Log zu /Cleanup-Image /StartComponentCleanup /ResetBase und es wird im Offline Image tatsächlich nichts mehr entfernt, sondern nur komprimiert (mal von ein paar AMD TReiber abgesehen).

Der Vorgang erstellt folgenden Plan:

Code: Alles auswählen

2018-12-15 19:35:49, Info                  CSI    0000000c Scavenge: Planning Complete.
The following actions will be performed:
    Regeneration Candidates: 0
    Removal Candidates: 0
    Superseded/LDR (Delta Compression) Candidates: 664
    Null-Delta Compression Candidates: 
        Mutable file Candidates: 0
        Boot-Recovery Candidates: 0
    Backup regeneration candidates: 0
    Deletion Candidates (Non Driver): 0
    Driver Deletion Candidates: 13
    WinSxS Orphaned Objects Candidates: 0
    Manifests Orphaned Objects Candidates: 0
Und der wird dann auch durchgeführt:

Code: Alles auswählen

2018-12-15 19:35:57, Info                  CSI    0000001a Beginning Delta compression of LDR / Superseded Components
2018-12-15 20:02:53, Info                  CSI    0000001b Delta compression complete. Total number of components compressed: 664, Total file compressed: 1340, Total files untouched: 429, Total file skipped due to backing: 0, Total file size compressed:1389944832, Total delta file size: 79777792, compression ratio: 94%
Die 664 Komponenten, die eigentlich als 'superseded' erkannt wurden, werden nicht entfernt, sondern nur komprimiert und verbleiben im Image. Das erklärt auch, warum der Vorgang so lange dauert.

Benutzeravatar
Manny
Aufsteiger
Aufsteiger
Beiträge: 85
Registriert: 27.03.2018, 18:12
Geschlecht:

Re: 17763.194 X64 Build + Aktivierten Net3.5 kb4470502 Problem ( Gelöst )

Beitrag von Manny » 15.12.2018, 20:58

DK2000 hat geschrieben:
15.12.2018, 20:47
Ja, so sieht es wohl aus. Solange man an den FODs nichts mehr verändert, dann hat man Ruhe vor dem KB4471332.
na dann bin ich ja gespannt wie das bei dem nächsten Update aussieht :D
- und was passiert wenn ich meine "persönliche" ISO nochmal bearbeite ( wegen SMB1 - trotz Update von Unitymedia meiner 6490 auf Version 7.01 ) muss ich das immer noch aktivieren wegen meinen Routerplatten

Benutzeravatar
Manny
Aufsteiger
Aufsteiger
Beiträge: 85
Registriert: 27.03.2018, 18:12
Geschlecht:

Re: 17763.194 X64 Build + Aktivierten Net3.5 kb4470502 Problem ( Gelöst )

Beitrag von Manny » 15.12.2018, 20:59

UPS, 2 mal denselben Eintrag gepostet ? :o - direkt mal ändern ;)

Antworten