Defender: schwerwiegender Bug?

Du brauchst Hilfe zu OneDrive, der Sicherheit oder dem Internet Explorer?
Antworten
TempMember

Defender: schwerwiegender Bug?

Beitrag von TempMember » 31.08.2018, 21:31

Ich habe ein Problem im Defender Security Center unter Win 10 1803 (17134.254).

Unter Gerätesicherheit stand seither lediglich "Sicherer Start" und darunter, dass er aktiviert sei. Ganz unten auf der Seite stand noch unter Hardwaresicherheit, dass mein Gerät die Anforderungen für standardmäßige Hardwaresicherheit erfüllt. Der Menüpunkt Kernisolierung fehlte jedoch. So weit, so gut.

Nun bin ich ins BIOS und habe folgende Funktionen aktiviert:

- Intel Virtualization Technology
- VT-d
- TxT

Danach hat mir dann Defender unter Gerätesicherheit jetzt auch die Kernisolierung angezeigt. Unter "Details zur Kernisolierung" stand die Speicherintegrität auf "Aus". Diese habe ich dann eingeschaltet und wurde umgehend zum Rechner-Neustart aufgefordert. Also habe ich neu gestartet. Was aber das Security Center jetzt unter Gerätesicherheit anzeigt, ist total paradox. Die Überschrift "Hardwaresicherheit" ganz unten ist weg! Der Text mit der Status-Info ist ebenfalls weg! Es steht nur noch der Link "Weitere Informationen" da. Klicke ich dann auf "Details zur Kernisolierung", steht dort der Schalter für Speicherintegrität auf "An", was ja soweit ok ist. Doch wenn ich jetzt zurück zu Gerätesicherheit gehe, dann steht dort, wo der Punkt "Hardwaresicherheit" immer noch fehlt, jetzt plötzlich "Die Standardhardwaresicherheit wird nicht unterstützt".

Das meinte ich mit paradox. Zuerst heißt es, "Die Standardhardwaresicherheit wird unterstützt", dann aktiviere ich es im BIOS, dann steht die Kernisolierung zur Verfügung und ich kann dort die Speicherintegrität einschalten, aber nach einem Neustart steht dann, dass die Standardhardwaresicherheit doch nicht unterstützt wird, obwohl gleichzeitig die Kernisolierung als verfügbar angezeigt wird, bei eingeschalteter Speicherintegrität. Bin ich hier beim Konfigurieren falsch vorgegangen, oder ist dies ein rießiger Bug im Defender? Und was ist denn nun bei mir geschützt und was nicht? :kopfkratz:

Tante Google

Defender: schwerwiegender Bug?

Beitrag von Tante Google » 31.08.2018, 21:31


TempMember

Re: Defender: schwerwiegender Bug?

Beitrag von TempMember » 31.08.2018, 21:51

Noch ein Nachtrag:

Mit den oben beschrieben Einstellungen, startet und läuft mein Rechner jetzt auch langsamer als zuvor. Und im Geräte-Manager ist jetzt unter Systemgeräte der Treiber "ACPI-Prozessoraggregator" inaktiv mit dem Status "nicht angeschlossen". Der war aber definitiv vor meiner Aktivierung der Kernisolierung aktiv. :kopfkratz:

Benutzeravatar
DK2000
Superhirn
Superhirn
Beiträge: 1479
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: Defender: schwerwiegender Bug?

Beitrag von DK2000 » 31.08.2018, 22:33

Was die Einstellungen im BIOS angeht, Intel TXT deaktivieren. Wenn das aktiviert ist, läuft das alles nicht unbedingt wie erwartet. Intel VT-d kann ebenfalls Probleme machen. Das müsste Du aber austesten, da es sehr von Board und UEFI abhängig ist, ob VT-d zusammen mit Hyper-V CI sauber zusammen arbeitet. Intel VT-x muss aber aktiviert sein. Ohne dieses läuft die Virtualisierung nicht.

Was die Performance angeht, hatte ich ja hier schon einmal nachgefragt:

viewtopic.php?f=334&t=20937

Die Probleme in Zusammenhang mit dem 'ACPI Processor Aggregator Driver' habe ich hier nich oder nicht darauf geachtet. Auch das Ein- und Ausschalten von HVCI klappt hier soweit einwandfrei, dafür aber bei aktiviertem HVCI eine deutlichen Performance Einbruch. Zum Testen hatte ich da halt nur mein Tablet, auf dem Laptop kann bzw. will ich es nicht deaktivieren, weil im Anschluss VMware bzw. VirtualBox nicht mehr läuft. Von daher lasse ich es lieber.

Wenn sich HVCI bei Dir nicht über die GUI mehr deaktivieren lässt (bekannter Bug, der nach wie vor bei einigen augtritt), musst Du das direkt in der Registry ausschalten:

https://www.deskmodder.de/wiki/index.ph ... aktivieren

Ansonsten mal schauen, wie sich das weiter entwickelt. Momentan ist das für mich noch ein unbrauchbares Feature.

TempMember

Re: Defender: schwerwiegender Bug?

Beitrag von TempMember » 31.08.2018, 22:51

Ok, danke Dir.

Werde also TxT und VT-d deaktivieren, aber VT-x nat. aktiviert lassen. Mal sehen, was dann der ACPI Processor Aggregator Treiber macht, ob sich an der Performance was ändert und was mir das Secutity Center dann für sinnige oder unsinnige Einstellungen anzeigt.

Werde dann berichten, ob und was es gebracht hat.

TempMember

Re: Defender: schwerwiegender Bug?

Beitrag von TempMember » 01.09.2018, 20:41

So, habe VT-d und TxT deaktiviert und die Performance ist wieder "normal". Moinmoin hatte das ja sogar erst kürzlich in einem Blog-Beitrag erwähnt, den ich übersehen habe.

Dass aber bei mir ohne aktivierte Kernisolierung "Die Standardhardwaresicherheit wird unterstützt" und nach der Aktivierung "Die Standardhardwaresicherheit wird nicht unterstützt" steht, muss wohl doch ein Bug sein. Ausserdem ist diese Aussage mal wieder total unpräzise von Microsoft. Denn wie ich inzw. recherchiert habe, wird das bereits angezeigt, wenn nur eine der vielen Sicherheitsfunktionen nicht unterstützt wird. Solange das Security Center sich aber so komisch verhält, lasse ich das mit der Kernisolierung mal sein. Mal sehen, wie das dann bei der 1809 sein wird. Wenn man nämlich vor einer cleanen Neuinstallation im BIOS VT-x bereits aktiviert hat, dann soll die Speicher-Integrität automatisch aktiviert werden. Das probiere ich dann mal aus, weil ich standardmäßig bei jeder neuen Windows-Version eine cleane Neuinstallation mache. Da weiß ich, was ich habe. :D

Danke für die Tipps, DK2000. :)

sGaessje
Einsteiger
Einsteiger
Beiträge: 12
Registriert: 19.07.2018, 08:07
Geschlecht:

Re: Defender: schwerwiegender Bug?

Beitrag von sGaessje » 18.09.2018, 16:01

Ich kapere den Thrad mal für einen "Bug"? hier. 17760 komplett neu aufgesetzt, innerhalb der Einstellungen des Defender lassen sich hier keinerlei Ausnahmen für den Defender setzen. Sprich, ich kann weder Files noch Folder oder Prozesse davon ausnehmen, in Echtzeit gescannt zu werden. Der Dialog lässt sich komplett ausführen aber es wird nicht übernommen. Kann das mal jemand bei sich verifizieren?

Tom

Benutzeravatar
DK2000
Superhirn
Superhirn
Beiträge: 1479
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: Defender: schwerwiegender Bug?

Beitrag von DK2000 » 18.09.2018, 16:16

Funktioniert hier mit der 17760.1 einwandfrei. Ausnahmen lassen sich normal einrichten und löschen.

sGaessje
Einsteiger
Einsteiger
Beiträge: 12
Registriert: 19.07.2018, 08:07
Geschlecht:

Re: Defender: schwerwiegender Bug?

Beitrag von sGaessje » 18.09.2018, 17:17

Erstaunlich. Nix zu machen hier. Danke für Infos

Benutzeravatar
moinmoin
★ Team Admin ★
Beiträge: 44887
Registriert: 14.11.2003, 11:12
Geschlecht:

Re: Defender: schwerwiegender Bug?

Beitrag von moinmoin » 18.09.2018, 17:23

Hab es jetzt auch mal probiert. Geht ohne Probleme.
Die nächste Insider wirds vllt wieder richten.
Bild
Deskmodder findet ihr bei: Mewe | Twitter | Facebook Windows 10 Tipps und Tricks: Tutorials Windows 10.

sGaessje
Einsteiger
Einsteiger
Beiträge: 12
Registriert: 19.07.2018, 08:07
Geschlecht:

Re: Defender: schwerwiegender Bug?

Beitrag von sGaessje » 18.09.2018, 19:55

Das Ganze ist ja schon ein bisschen strange, da es auf einem Laptop, mit dem selben Stick und der 17760 neu aufgesetzt, direkt funktionierte.
Und als wär das noch nicht genug, hat ein "sfc /scannow" NICHTS gefunden oder repariert aber direkt im Anschluss ging es dann
Hab den PC jetzt mal in "Paranormal Activity" umbenannt und lasse später mal die originalen Ghostbuster drüber laufen :rofl:

Antworten