Neuere Zertifikatskette wird nicht in Edge und andren Chromium-Browsern angezeigt

Du brauchst Hilfe zu OneDrive, der Sicherheit oder dem Internet Explorer?
Antworten
GwenDragon
★ Team Forum ★
Beiträge: 8297
Registriert: 20.07.2014, 12:25
Geschlecht:

Neuere Zertifikatskette wird nicht in Edge und andren Chromium-Browsern angezeigt

Beitrag von GwenDragon » 27.09.2021, 15:07

Wenn ich mit Chromium 94, Edge 94, Opera oder Vivaldi 4.3 auf deskmodder.de gehe, mir über das Schloss die Zertifikatskette anzeigen lasse, wird von Windows das für die Ablaufzeit angezeigt:
DST Root CA X3: 30.9.2021
R3: 29.9.2021
Siehe GIF-Animation:
zertifikatskette-win10-21h2.gif
Auf Linux Debian & Manjaro mit Chromium-Kindern sowie bei bei Firefox (WIn, Linux) wird für die Zertifikatskette angezeigt mit folgender Ablaufzeit:
ISRG Root X1: 04.06.35, 13:04:38 MESZ
R3: 15.09.25, 18:00:00 MESZ

Wieso verwendet Windows 10 nicht die neue Zertifikatskette?
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

Tante Google

Neuere Zertifikatskette wird nicht in Edge und andren Chromium-Browsern angezeigt

Beitrag von Tante Google » 27.09.2021, 15:07


GwenDragon
★ Team Forum ★
Beiträge: 8297
Registriert: 20.07.2014, 12:25
Geschlecht:

Re: Neuere Zertifikatskette wird nicht in Edge und andren Chromium-Browsern angezeigt

Beitrag von GwenDragon » 27.09.2021, 17:41

Interessant, dass auch openssl die neueren Zertifikate X1 + R3 verwendet.
win-11-10-zert-kette.png
Gerade Windows 11 gestartet, da wird die neue Zertifikatkette angezeigt.
In Win 10 21H2 die alte. Wie kann das sein?
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

GwenDragon
★ Team Forum ★
Beiträge: 8297
Registriert: 20.07.2014, 12:25
Geschlecht:

Re: Neuere Zertifikatskette wird nicht in Edge und andren Chromium-Browsern angezeigt

Beitrag von GwenDragon » 27.09.2021, 19:45

Seltsam, bei anderen Windows-Konten wird die Kette richtig wie auch in Win 11 angezeigt.

Was kann denn an einem Windows-Konto defekt sein, dass die Zertifikatskette so falsch angezeigt wird?

GwenDragon
★ Team Forum ★
Beiträge: 8297
Registriert: 20.07.2014, 12:25
Geschlecht:

Re: Neuere Zertifikatskette wird nicht in Edge und andren Chromium-Browsern angezeigt

Beitrag von GwenDragon » 28.09.2021, 12:48

Ich habe nun als Notbehelf das Konto gelöscht, neur erstellt und dann die wichtigen Daten rüber kopiert.

Nun passt es wieder mit den Zertifikaten.

Wenn jemand trotzdem weiß wie ich beim nächsten Mal die Einstellungen für den Benutzer die Windows SSL-Zertifikate wieder auf Standard zurück setzen kann, das wäre ganz praktisch.

Benutzeravatar
moinmoin
★ Team Admin ★
Beiträge: 53627
Registriert: 14.11.2003, 11:12
Geschlecht:

Re: Neuere Zertifikatskette wird nicht in Edge und andren Chromium-Browsern angezeigt

Beitrag von moinmoin » 28.09.2021, 13:05

Muss ehrlich gestehen, darum hab ich mich noch nie gekümmert.
Aber bspw im Edge / Einstellungen Zertifikate eingeben und aufrufen da stehen doch alle. :kopfkratz:
3.jpg
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

GwenDragon
★ Team Forum ★
Beiträge: 8297
Registriert: 20.07.2014, 12:25
Geschlecht:

Re: Neuere Zertifikatskette wird nicht in Edge und andren Chromium-Browsern angezeigt

Beitrag von GwenDragon » 28.09.2021, 13:16

moinmoin hat geschrieben: 28.09.2021, 13:05 Aber bspw im Edge / Einstellungen Zertifikate eingeben und aufrufen da stehen doch alle. :kopfkratz:
Was nutzt es, wenn die Kette aber falsch angezeigt wird? Klar, wer schau tschon sowas an – Na, Leute wie ich, die Systeme administrieren müssen.

Wenn Zertifikatsketten falsch angezeigt werden wie soll da noch einer SSL-Verbindung vertraut werden? Klar, die meisten Nutzer schauen da eh nicht drauf, Hauptsache irgendein Schloss für 2sicher" wird angezeigt.

Benutzeravatar
moinmoin
★ Team Admin ★
Beiträge: 53627
Registriert: 14.11.2003, 11:12
Geschlecht:

Re: Neuere Zertifikatskette wird nicht in Edge und andren Chromium-Browsern angezeigt

Beitrag von moinmoin » 30.09.2021, 15:26

Scheint sich von selbst aufgelöst zu haben.
Hier im Vivaldi unter Windows 10 wird es nun korrekt angezeigt.

Benutzeravatar
DK2000
Legende
Legende
Beiträge: 5833
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: Neuere Zertifikatskette wird nicht in Edge und andren Chromium-Browsern angezeigt

Beitrag von DK2000 » 30.09.2021, 15:38

Ob das so richtig ist? Mal schauen, wie es morgen aussieht, wenn "DST Root CA X3" abgelaufen ist.

GwenDragon
★ Team Forum ★
Beiträge: 8297
Registriert: 20.07.2014, 12:25
Geschlecht:

Re: Neuere Zertifikatskette wird nicht in Edge und andren Chromium-Browsern angezeigt

Beitrag von GwenDragon » 30.09.2021, 17:31

Ist bei mir unter Windows 10 jetzt so:

Code: Alles auswählen

ISRG Root X1
└ R3
  └ deskmodder.de

Benutzeravatar
DK2000
Legende
Legende
Beiträge: 5833
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: Neuere Zertifikatskette wird nicht in Edge und andren Chromium-Browsern angezeigt

Beitrag von DK2000 » 30.09.2021, 17:34

Stimmt. Bei mir jetzt auch. Vorhin stand da noch "DST Root CA X3" ganz oben. Das ist jetzt aber raus. Gut, dann passt es jetzt so.

GwenDragon
★ Team Forum ★
Beiträge: 8297
Registriert: 20.07.2014, 12:25
Geschlecht:

Re: Neuere Zertifikatskette wird nicht in Edge und andren Chromium-Browsern angezeigt

Beitrag von GwenDragon » 30.09.2021, 17:35

Mal abwarten bis morgen, ob es von manchen Besuchern dann ein Geschrei wegen Zertifikaten gibt 😉.

Antworten