Erneut Treiber-Update-Chaos unter 1903

Probleme mit der Installation von Windows 10?
Antworten
Carsten

Erneut Treiber-Update-Chaos unter 1903

Beitrag von Carsten » 04.09.2019, 17:37

Oh je, auch unter 1903 herrscht weiterhin das bekannte Chaos mit den Treiber-Updates von Windows Update und jenen im Geräte-Manager. Dass man oft falsche, nicht funktionierende Treiber installiert bekommt, kennt man ja. Aber 2 verschiedene Versionen quasi gleichzeitig, ist mir jetzt neu.

Konkret geht es bei um den Realtek-Bluetooth-Treiber. Seither hatte ich immer den originalen Lenovo-Treiber Realtek 8723BE, 8192EE Combo Card ver. 1.3.868.3 (11.11.15) installiert. Der war passend zur entspr. Realtek WLAN-Combo Card und machte eigentlich keinerlei Probleme.

Doch heute kam nach Jahren erstmalig plötzlich ein "neuer" Treiber via Win Update: Version 1.5.1012.3 vom 09.01.18. Doch warum kommt der erst jetzt? Wir haben August 2019. Ich habe etwas recherchiert, darin sind Sicherheits-Updates enthalten. Schön und gut, dann lasse ich den jetzt mal drauf, dachte ich.

Nach dem Rechner-Neustart habe ich abschließend dann noch im Geräte-Manager den zuvor via Win Update installierten neuen Treiber nochmal automatich online auf Aktualisierungen geprüft. Zu meiner Überraschung wurde erneut ein "aktuellerer" Treiber gefunden, nämlich Version 1.5.1009.3. Und nein, der war zuvor noch nie installiert gewesen, kam also nicht vom Driver Store, sondern er wurde neu heruntergeladen.

Win Update installiert somit Version 1.5.1012.3 vom 09.01.18, der Geräte-Manager jedoch Version 1.5.1009.3 vom 30.01.18. Welcher ist nun aktuell? Die höhere Version, oder das neuere Datum? Und warum installiert Windows überhaupt 2 unterschiedliche Treiber? Weiß jemand Rat?

Tante Google

Erneut Treiber-Update-Chaos unter 1903

Beitrag von Tante Google » 04.09.2019, 17:37


Workshop
Profi
Profi
Beiträge: 194
Registriert: 12.08.2019, 20:49

Re: Erneut Treiber-Update-Chaos unter 1903

Beitrag von Workshop » 04.09.2019, 18:26

Wer ein Tool wie Driver Store einsetzt, braucht sich über Nichts zu wundern.

Carsten

Re: Erneut Treiber-Update-Chaos unter 1903

Beitrag von Carsten » 04.09.2019, 18:34

Mit Driver Store meinte ich nicht diesen Update-Dienst, sonder den Windows-Ordner namens Driver Store! :lol:

Würde niemals einen Treiber-Updater eines Drittanbieters benutzen. Insofern ist Dein Einwand sehr berechtigt. :)

Benutzeravatar
moinmoin
★ Team Admin ★
Beiträge: 49819
Registriert: 14.11.2003, 11:12
Geschlecht:

Re: Erneut Treiber-Update-Chaos unter 1903

Beitrag von moinmoin » 04.09.2019, 18:50

Also bei den Treibern über Windows Update wundert mich nichts mehr.
Das "Warum" kann ich dir auch nicht erklären.
Kann durchaus sein, dass die jetzt erst hinzugefügt worden sind.
Das System die Geräte jetzt erst erkannt und dementsprechend nach Treibern gesucht hat.

Solange alles funktioniert, sei froh.

Ist alles ein Grund, warum ich bei mir die Suche nach Treibern deaktiviert habe und auch nie und nimmer im Geräte-Manager online nach neuen Treibern ausschau halte. Weil dann ist das Gerät einmal gescannt und Treiber werden dann über WU abgerufen.
Bild
Deskmodder findet ihr bei: Mewe | Twitter | Facebook Windows 10 Tipps und Tricks: Tutorials Windows 10.

Carsten

Re: Erneut Treiber-Update-Chaos unter 1903

Beitrag von Carsten » 04.09.2019, 19:44

Aus Deiner Antwort entnehme ich, dass Du also eher Win Update vertraust, als dem Geräte-Manager?

Ich würde ja gerne bei meinem alten Hersteller-Treiber bleiben, ist immer meiner erste Wahl. Allerdings fehlen dann halt die Sicherheits-Updates, das ist das Problem. Und bei diesem ist der Sicherheits-Patch als critical deklariert. Andererseits habe ich einen Combo-Treiber, in Verbindung mit dem WLAN-Treiber. Der vo Windows Update ist jedoch der eigenständige Bluetooth-Treiber. Ich glaube, ich setze wieder -wuuhext.dll, dann ist Ruhe. :D

Benutzeravatar
moinmoin
★ Team Admin ★
Beiträge: 49819
Registriert: 14.11.2003, 11:12
Geschlecht:

Re: Erneut Treiber-Update-Chaos unter 1903

Beitrag von moinmoin » 05.09.2019, 08:05

Weder noch. Ich setze auf die Herstellerseiten und deren Treiber.

Wenn der neue Treiber funktioniert ist doch alles gut. Dann brauchst du dir doch keine Gedanken machen.
Schlimmer wäre wenn jetzt etwas nicht mehr geht. ;)
Bild
Deskmodder findet ihr bei: Mewe | Twitter | Facebook Windows 10 Tipps und Tricks: Tutorials Windows 10.

Carsten

Re: Erneut Treiber-Update-Chaos unter 1903

Beitrag von Carsten » 05.09.2019, 19:02

Hi moinmoin, der erste Satz in meinem vorherigen Post war quatsch. Konnte ihn aber nachträglich nicht löschen. :hihi:

Ja klar nehmen wir beide in der Regel die originalen Hersteller-Treiber. Beim Realtek Bluetooth-Treiber ist mein letzter bei Lenovo jedoch von 2015 und bei Realtek von 2017. Also bliebe nur noch Station Drivers. Diese Treiber von dort stammen aber lediglich von irgendwelchen bestimmten Rechner-Modellen und sind speziell für diese konfiguriert. Und einen für z. B. Asus optimierten Treiber auf einen Lenovo zu knallen bringt meist nur Konflikte.

Meine alten Treiber von Lenovo laufen alle einwandfrei, kein Thema. Doch haben die halt teilweise krasse Sicherheitslücken. Nur deswegen schaue ich hin und wieder bei Windows Update, wenn es beim Hersteller direkt nichts halbwegs Aktuelles gibt. Aber man muss wohl mit unsichren älteren Treibern norgedrungen leben. Oder sich halt einen neuen Rechner kaufen. :betruebt:

hdmue_
Neuling
Neuling
Beiträge: 9
Registriert: 01.06.2019, 13:46

Re: Erneut Treiber-Update-Chaos unter 1903

Beitrag von hdmue_ » 06.09.2019, 00:26

also ich habs geschafft... mit viel schweiss und Zeit....

- der ersten Installation stürzte Win erst mal an
- danach fhrs wieder hoch

danach cmd als admin aus geführt:
Eingabe 1: sfc /scannow
sfc blieb bei ca. 80 % stehn ==> crtl C - Abruch

Eingabe 2: dism.exe /online /cleanup-image /restorehealth
100 % OK
Eingabe 3: sfc /scannow
sfc reparierte die defekte Version

Eingabe 4: sfc /scannow
alles OK 100 % durchgelaufen

Eingabe 5: dism /online /get-currentedition

kann leider keine (noch nicht) Bilder hochladen.... deshalb das ganze im Text

Erg:
- Version 10.0.18362.1
- Abbildversion: 10.0.18362.329

bisher keine weiteren Probleme festgestellt.... läuft gut... laden Win 10 mit ssd ca. 20 sec ... tools funktionieren auch alle .. Programme auch Word 2003 (laden 2-3 sec) / Word Datei (5 Seiten incl. 3 Bilder) 1-2 sec ... kann man nicht meckern
gemessen auf einem intel NUC ... Intel Laptop I3

Antworten