Kein Upgrade auf 1809 bei aktiviertem Hyper-V

Probleme mit der Installation von Windows 10?
HStoni
Neuling
Neuling
Beiträge: 5
Registriert: 15.10.2018, 11:07

Kein Upgrade auf 1809 bei aktiviertem Hyper-V

Beitrag von HStoni » 15.10.2018, 11:19

Bei aktiviertem Hyper-V ist auf meinem PC kein Upgrade auf die Version 1809 (17763.55) möglich.
Der PC wird nach mehreren kurzen Boot-Versuchen in der 3.Phase (über 75%) wieder auf die Vorherige Version zurückgesetzt.
Ein Upgrade mit deaktiviertem Hyper-V führt zu Erfolg.
In der Windowsversion 1809 führt aber dann ein Aktivieren von Hyper-V beim 2. Booten zu einer Boot-Schleife, die sich auch nicht durch Systemwiederherstellung beheben lässt.
Erst ein manuelles Löschen des Wertes "hypervisorlaunchtype" mittels bcdedit führt wieder zu einem ordentlichen Bootvorgang.
Gleiches Verhalten der Version 1809 gibt es auch bei einer Clean-Installation.
In der Insiderversion 18252 funktioniert Hyper-V wieder normal.
Ich bin jetzt wieder auf 1803 und werde auf einer Wechselplatte die 1809 weiter beobachten.

Mich wundert nur, dass ich im Internet zu diesem Problem noch nichts gefunden habe.
Entweder haben Nutzer mit Hyper-V das Upgrade noch nicht gewagt, oder der Abbruch des Upgrade wurde nicht mit Hyper-V in Verbindung gebracht, oder ich stehe mit meinem Problem alleine da.

Holger

Tante Google

Kein Upgrade auf 1809 bei aktiviertem Hyper-V

Beitrag von Tante Google » 15.10.2018, 11:19


Benutzeravatar
moinmoin
★ Team Admin ★
Beiträge: 42893
Registriert: 14.11.2003, 11:12
Geschlecht:

Re: Kein Upgrade auf 1809 bei aktiviertem Hyper-V

Beitrag von moinmoin » 15.10.2018, 11:34

:willkommen: Holger,

Das es Probleme mit aktivierten Hyper-V geben kann, ist schon in einigen Foren als Frage aufgetaucht.
Aber deine Konstellation ist mir auch neu.

Wobei ich aber sagen muss, dass Hyper-V nicht gerade zu meinen Stärken gehört.

Hab gerade mal das gefunden: https://social.technet.microsoft.com/Fo ... 0itprovirt

Letzter Kommentar unten.
Bild
Deskmodder findet ihr bei: Tickers |Google+ | Twitter Windows 10 Tipps und Tricks: Tutorials Windows 10.

DK2000
Veteran
Veteran
Beiträge: 785
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: Kein Upgrade auf 1809 bei aktiviertem Hyper-V

Beitrag von DK2000 » 15.10.2018, 13:17

Bei dem Verhalten habe ich da immer irgendwie Intel VT-d und Intel TXT im Verdacht.

Ansonsten sollte Hyper-V das Upgrade an sich nicht stören, außer die neue Version hat irgendwelche Probleme mit dem BIOS.

HStoni
Neuling
Neuling
Beiträge: 5
Registriert: 15.10.2018, 11:07

Re: Kein Upgrade auf 1809 bei aktiviertem Hyper-V

Beitrag von HStoni » 15.10.2018, 19:16

Den Eintrag in der BCD-Datenbank habe ich schon editiert.
Bei Versuchen habe ich festgestellt, dass wenn der Eintrag "hypervisorlaunchtype" auf Auto steht, egal ob Hyper-V als Feature aktiviert ist oder nicht, Windows nicht startet und sich auch nicht automatisch reparieren kann.
Wenn der Eintrag nicht existiert oder auf Off steht startet Windows, egal ob Hyper-V als Feature aktiviert ist oder nicht.
Für weitere Tests warte ich auf die nächsten Updates von Microsoft.
Das Problem habe ich heute morgen im Feedback-Hub mit Schweregrad 5 gemeldet.

HStoni
Neuling
Neuling
Beiträge: 5
Registriert: 15.10.2018, 11:07

Re: Kein Upgrade auf 1809 bei aktiviertem Hyper-V

Beitrag von HStoni » 17.10.2018, 10:34

Auch in der Insider-Version 17763.104 tritt der Fehler weiterhin auf.
Nach einem Aktivieren des Windows-Features "Hyper-V" führt der letzte Bootvorgang zu einer Bootschleife.
Die automatische Reparatur von Windows schlägt fehl.
Erst ein manuelles Editieren der BCD mittels "bcdedit" hilft. Dabei muss der Eintrag "hypervisorlaunchtype" von "Auto" auf "Off" gestellt werden oder komplett gelöscht werden.

DK2000
Veteran
Veteran
Beiträge: 785
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: Kein Upgrade auf 1809 bei aktiviertem Hyper-V

Beitrag von DK2000 » 17.10.2018, 11:13

Das liegt am Hypervisor (Hyper-V). Der kann bei Dir ais irgendwelchen Gründen nicht vor Windows starten und das führt zu dem erwähnten Bootloop.

Mit hypervisorlaunchtype=off (bzw. Eintrag fehlt entspricht =off) weist Du den Bootmanager an, den Hypervisor nicht zu starten, egal ob installiert oder nicht, weswegen Windows dann startet (ohne laufendem Hyper-V dann).

Die automatische Reparatur bringt hier gar nichts, da kein Problem vorliegt, welches davon repariert werden kann.

Das Problem ist höchstwahrscheinlich eine Inkompatibilität mit dem Hypervisor, welche auftritt, sobald er gestartet werden soll. Eventuell BIOS/UEFI oder Treiber. Oder vielleicht doch ein Bug? Irgendetwas verhindert da einen sauberen Start des Hypervisors.

HStoni
Neuling
Neuling
Beiträge: 5
Registriert: 15.10.2018, 11:07

Re: Kein Upgrade auf 1809 bei aktiviertem Hyper-V

Beitrag von HStoni » 17.10.2018, 12:03

Ich wundere mich, dass der Fehler erst oder nur in der Version 1809 auftritt.
Ich nutze schon ewig Hyper-V auf meinem Rechner mit ständig wechselnden Windowsversionen (immer mit Upgrade bei aktiviertem Hyper-V).
In der Insider-Version aus dem Fast-Ring (18252) lässt sich Hyper-V anstandslos aktivieren.
Mein Motherboard ist ein M4A785TD-V EVO von ASUS, Prozessor AMD Phenom II X6 1050T beides zugegeben nicht das Neueste, aber hat bisher immer gereicht.

DK2000
Veteran
Veteran
Beiträge: 785
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: Kein Upgrade auf 1809 bei aktiviertem Hyper-V

Beitrag von DK2000 » 17.10.2018, 12:53

Kann ein Bug sein. Ich weiß es nicht. Wie gesagt, normaler Weise stört Hyper-V das Upgrade nicht.

Wenn es mit der 1903/19H1 geht, kann es sich durchaus um einen Bug handeln. Selber testen kann ich es im Moment mangels ungenutzter Hardware leider nicht.

Holgi
Frischling
Frischling
Beiträge: 23
Registriert: 12.05.2018, 12:33

Re: Kein Upgrade auf 1809 bei aktiviertem Hyper-V

Beitrag von Holgi » 17.10.2018, 13:53

muss ein spezieller Fehler sein; kein allgemeiner:
hier läuft ein Notebook mit Update von 1803 auf 1809 und aktiviertem Hyper-V.
Die Vms laufen natürlich auch.

HStoni
Neuling
Neuling
Beiträge: 5
Registriert: 15.10.2018, 11:07

Re: Kein Upgrade auf 1809 bei aktiviertem Hyper-V

Beitrag von HStoni » 20.10.2018, 20:54

Ich habe mich mal von der 1803 über die Insider-Builds hochgearbeitet und festgestellt, dass auf meinem Rechner Hyper-V bis zur Version 17735 funktioniert. Ab der Version 17738 führt der Wert "hypervisorlaunchtype" auf "Auto" zu einer Bootschleife, egal ob das Windows-Feature "Hyper-V" aktiviert ist oder nicht.
Ich werde den Text noch etwas aufarbeiten und so im Feedback-Hub melden.

blubbr
Beobachter
Beobachter
Beiträge: 2
Registriert: 18.11.2018, 11:58

Re: Kein Upgrade auf 1809 bei aktiviertem Hyper-V

Beitrag von blubbr » 18.11.2018, 12:16

Hi,
Ich habe genau dasselbe Problem mit dem kleinen Bruder Asus M4A785TD-M EVO und AMD Phenom II X6 1045T.
Eure Einträge sind jetzt einen Monat alt. Habt Ihr neue Erkentnisse dazu? :kopfkratz:

Ich habe bei Feedback Hub auch einen Eintrag dazu gemacht.
Bertrand

motorrad
Beobachter
Beobachter
Beiträge: 3
Registriert: 17.11.2018, 09:53
Geschlecht:

Re: Kein Upgrade auf 1809 bei aktiviertem Hyper-V

Beitrag von motorrad » 19.11.2018, 19:35

Ich kann das nur bestätigen.
Das ASUS Laptop meiner Schwester hat das gleiche Problem hervorgerufen.

Benutzeravatar
IT-Nerd
Nachwuchs
Nachwuchs
Beiträge: 70
Registriert: 17.04.2018, 21:44
Geschlecht:

Re: Kein Upgrade auf 1809 bei aktiviertem Hyper-V

Beitrag von IT-Nerd » 21.11.2018, 18:19

Mainboard oder CPU, vielleicht ja beides?

Beim Stöbern gerade entdeckt: https://aka.ms/AA39bas

vANgLOUs
Beobachter
Beobachter
Beiträge: 2
Registriert: 06.12.2018, 16:32

Re: Kein Upgrade auf 1809 bei aktiviertem Hyper-V

Beitrag von vANgLOUs » 06.12.2018, 16:46

Hallo,

ich habe diesen Thread hier zufällig gefunden. Du/Ihr seid nicht allein. Ich habe das selbe Problem und hatte vorhin in einem anderen Forum gepostet.

Auch ich verwende seit der ersten Stunde Hyper-V auf Windows 10 und bis zuletzt unter 1803.
Das In-Place-Upgrade von 1803 auf 1809 war nicht sehr easy. Nach zahlreichen Fehlschlägen brachte die Deinstallation von Hyper-V vor dem Upgrade endlich die Lösung. Soweit so gut, aber …

Da ich Hyper-V ja nicht nur so zum Spaß installiert hatte, habe ich das Feature dann unter 1809 wieder aktiviert.
Die Installation braucht natürlich einen Reboot und gleich wie bei euch lässt sich Windows dann nicht mehr starten.

Ein Editieren mittels "bcdedit" habe ich nicht durchgeführt.
Ich bin dahintergekommen, dass Windows wieder startet, wenn im BIOS die "VT-d" Technologie deaktiviert wird.
Problem an der Sache ist, dass Hyper-V ohne VT-d natürlich nicht funktioniert. :heulen:

Das interessante ist der Zusammenhang: Ich habe genau wie ihr auch einen AMD Phenom II X6.
Dieser Thread ist ja schon ein paar Wochen alt. Seid ihr inzwischen weitergekommen?

Danke!

Benutzeravatar
moinmoin
★ Team Admin ★
Beiträge: 42893
Registriert: 14.11.2003, 11:12
Geschlecht:

Re: Kein Upgrade auf 1809 bei aktiviertem Hyper-V

Beitrag von moinmoin » 06.12.2018, 17:27

Erst einmal :willkommen:
Das heutige Update (auch wenn es nicht in der Changelog stand) hat auch nichts gebracht?
Bild
Deskmodder findet ihr bei: Tickers |Google+ | Twitter Windows 10 Tipps und Tricks: Tutorials Windows 10.

Antworten