Gelöst: Installation auf 1903 läuft durch, aber beim "..Windows wird konfiguriert .. " startet dann das alte Windows 10

Probleme mit der Installation von Windows 10?
Guenther
Nachwuchs
Nachwuchs
Beiträge: 54
Registriert: 02.11.2018, 11:50
Geschlecht:

Gelöst: Installation auf 1903 läuft durch, aber beim "..Windows wird konfiguriert .. " startet dann das alte Windows 10

Beitrag von Guenther » 19.06.2019, 15:08

Servus,

ich habe jetzt lange gewartet und alle mir bekannten Tricks zur Vorbereitung des Updates auf 1903 immer wieder abgearbeitet.
Nur jetzt hänge ich fest, weil ich glaube, dass mein BCD - Bootsektor nicht beschrieben werden kann und daher Windows ein Restore durchführt.
Meine - erfolglosen - Vorbereitungen:

McAfee deinstalliert
Arconis 2019 deinstalliert
chkdsk on C
sfc /scannow
alle Befehle im Zusammenhang "DISM" abgearbeitet.
Das Tool "ResetWUEng" abgearbeitet und die "Update-Fragmente damit gelöscht
In der Systemsteuerung den Computerschutz deaktiviert und alte Daten für Restore gelöscht
Temps gelöscht
Speicherplatz auf der C sichergestellt, genügend Platz
bcdboot c:\windows /v mehrmals laufen lassen, dabei festgestellt dass zwei statt eine "elendslange - Registerschlüssel" vorlagen, die das Tool nicht verändern konnte.
mit RegistryFinder eine der Daten gelöscht.

Nun installiert Windows das Update 1903 ohne Probleme (mit und ohne DVD -als Datenträger) damit beides probiert Inplace als auch die Updatefunktion von w 10 genutzt. Dann startet Windows neu mit dem Text "... Windows wird konfiguriert ….nicht ausschalten". Das klappt dann auch bis 52%. Danach erfolgt regelmäßig der Sturz zurück zu 1809!

Den aus meiner Sicht entscheidenden Fehler finde ich nun in der setupact.log:

2019-06-19 14:19:35, Error [0x064199] IBSLIB SetCheckpoint(WinPEBootFilesRestoreCheckpoint): threw exception.: class RollbackException: RollbackException: Error(5), CSystemVolumeSelectionCheckpoint: Failed to backup BCD database. void __cdecl OSRollbackService::CBootFilesRestoreCheckpoint::Finalize(const unsigned short *,struct OSRollbackService::ICheckpointParameters *)[gle=0x00000005]
2019-06-19 14:19:35, Error [0x06418a] IBSLIB RollbackSetCheckpoint(WinPEBootFilesRestoreCheckpoint): threw exception.: class RollbackException: RollbackException: Error(5), CSystemVolumeSelectionCheckpoint: Failed to backup BCD database. void __cdecl OSRollbackService::CCheckpointImpressario::SetCheckpoint(const unsigned short *,struct OSRollbackService::ICheckpointParameters *)
void __cdecl OSRollbackService::CBootFilesRestoreCheckpoint::Finalize(const unsigned short *,struct OSRollbackService::ICheckpointParameters *)[gle=0x00000005]
2019-06-19 14:19:35, Error [0x06414e] IBSLIB RollbackSetCheckpoint(WinPEBootFilesRestoreCheckpoint) failed. Disabling Rollback.[gle=0x00000005]
2019-06-19 14:19:35, Error SP Error setting OS Switch Rollback checkpoint[gle=0x00000005]
2019-06-19 14:19:35, Info SP CUpdateBootCode::DoExecute: Try to repair BCD file due to potential corruption error
2019-06-19 14:19:35, Info SP CUpdateBootCode::DoExecute: Retry set OS Switch Rollback checkpoint
2019-06-19 14:19:35, Info [0x06412c] IBSLIB SetCheckpoint: Checkpoint("WinPEBootFilesRestoreCheckpoint") in progress...
2019-06-19 14:19:35, Info IBSLIB OSRollbackService::CBootFilesRestoreCheckpoint::Finalize: System volume drive path is [N:\]
2019-06-19 14:19:36, Info IBSLIB TrackVolume: Successfully marked that [$Setup_SystemVolume$] is on drive [N:].
2019-06-19 14:19:36, Info IBSLIB OSRollbackService::CBootFilesRestoreCheckpoint::Finalize: N:\boot.ini does not exist, skip.
2019-06-19 14:19:36, Info IBSLIB OSRollbackService::CBootFilesRestoreCheckpoint::Finalize: N:\ntldr does not exist, skip.
2019-06-19 14:19:36, Info IBSLIB OSRollbackService::CBootFilesRestoreCheckpoint::Finalize: N:\NTDETECT.COM does not exist, skip.
2019-06-19 14:19:36, Info IBSLIB OSRollbackService::CBootFilesRestoreCheckpoint::Finalize: N:\bootmgr does not exist, skip.
2019-06-19 14:19:36, Error IBSLIB BCD: BcdCopyObjectEx: Failed to enumerate source elements. Target: {a6e1865f-34f0-11e9-9ed6-bceb755eb889} Flags: 0x4 Status: c0000022[gle=0x00000002]
2019-06-19 14:19:36, Error IBSLIB BCD: Failed to clone store. Status: c0000022[gle=0x00000002]
2019-06-19 14:19:36, Error IBSLIB BCD: BcdExportStore: Failed clone BCD to \??\C:\$WINDOWS.~BT\Sources\Rollback\EFI\Microsoft\Boot\BCD. Status: c0000022[gle=0x00000002]
2019-06-19 14:19:36, Error IBSLIB OSRollbackService::CBootFilesRestoreCheckpoint::Finalize: Failed to backup BCD database from "N:\EFI\Microsoft\Boot\BCD" to "C:\$WINDOWS.~BT\Sources\Rollback\EFI\Microsoft\Boot\BCD".[gle=0x00000005]
2019-06-19 14:19:36, Error [0x064199] IBSLIB SetCheckpoint(WinPEBootFilesRestoreCheckpoint): threw exception.: class RollbackException: RollbackException: Error(5), CSystemVolumeSelectionCheckpoint: Failed to backup BCD database. void __cdecl OSRollbackService::CBootFilesRestoreCheckpoint::Finalize(const unsigned short *,struct OSRollbackService::ICheckpointParameters *)[gle=0x00000005]
2019-06-19 14:19:36, Error [0x06418a] IBSLIB RollbackSetCheckpoint(WinPEBootFilesRestoreCheckpoint): threw exception.: class RollbackException: RollbackException: Error(5), CSystemVolumeSelectionCheckpoint: Failed to backup BCD database. void __cdecl OSRollbackService::CCheckpointImpressario::SetCheckpoint(const unsigned short *,struct OSRollbackService::ICheckpointParameters *)
void __cdecl OSRollbackService::CBootFilesRestoreCheckpoint::Finalize(const unsigned short *,struct OSRollbackService::ICheckpointParameters *)[gle=0x00000005]
2019-06-19 14:19:36, Error [0x06414e] IBSLIB RollbackSetCheckpoint(WinPEBootFilesRestoreCheckpoint) failed. Disabling Rollback.[gle=0x00000005]
2019-06-19 14:19:36, Error SP Error setting OS Switch Rollback checkpoint[gle=0x00000005]
2019-06-19 14:19:36, Error SP Operation failed: Update Boot Code. Error: 0x80004005[gle=0x000000b7]
2019-06-19 14:19:36, Info MOUPG Finalize: Registering Setup Platform error: [0x80004005]
2019-06-19 14:19:36, Error SP ExecuteOperations: Failed execution phase Finalize. Error: 0x80004005
2019-06-19 14:19:36, Info MOUPG MoSetupPlatform: SetupPlatform::INewSystem::Finalize returned: [0x4]
2019-06-19 14:19:36, Error MOUPG MoSetupPlatform: Finalize reported failure!
2019-06-19 14:19:36, Error MOUPG MoSetupPlatform: Using action error code: [0x80004005]
2019-06-19 14:19:36, Error MOUPG CDlpActionFinalize::ExecuteSetupPlatformFinalize(1076): Result = 0x80004005
2019-06-19 14:19:36, Error MOUPG CDlpActionFinalize::ExecuteRoutine(456): Result = 0x80004005

Damit ist im Zentrum meiner Probleme der BCD - Boot - Sektor, oder?

Hat jemand eine Idee?

Vielen Dank im Voraus

Servus

Günther
Zuletzt geändert von Guenther am 20.06.2019, 17:56, insgesamt 1-mal geändert.

Tante Google

Gelöst: Installation auf 1903 läuft durch, aber beim "..Windows wird konfiguriert .. " startet dann das alte Windows 10

Beitrag von Tante Google » 19.06.2019, 15:08


Benutzeravatar
DK2000
Superhirn
Superhirn
Beiträge: 1479
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: Installation auf 1903 läuft durch, aber beim "..Windows wird konfiguriert .. " startet dann das alte Windows 10

Beitrag von DK2000 » 19.06.2019, 15:35

Da das System im UEFI Modus installiert ist, hast Du keinen Boot-Sektor mehr. Es geht hier speziell und die ESP (EFI-Systempartition).

Ist das Selbe Problem, wie in dem Thread hier auch:

viewtopic.php?f=327&t=22212

Irgendetwas passt da mit dem BCD nicht bzw. mit dem Zugriff (STATUS_ACCESS_DENIED). Das Setup hat Probleme mit dem Eintrag {a6e1865f-34f0-11e9-9ed6-bceb755eb889}:

Code: Alles auswählen

2019-06-19 14:19:36, Error IBSLIB BCD: BcdCopyObjectEx: Failed to enumerate source elements. Target: {a6e1865f-34f0-11e9-9ed6-bceb755eb889} Flags: 0x4 Status: c0000022[gle=0x00000002]
2019-06-19 14:19:36, Error IBSLIB BCD: Failed to clone store. Status: c0000022[gle=0x00000002]
Würde mich jetzt nicht wundern, wenn das auch das Resumeobject ist (Wiederaufnahme aus dem Ruhezustand).

Hatte ja schon eine Mögliche Lösung dazu im anderen Thread geschrieben, aber bislang keine Antwort erhalten, ob es geklappt hat oder nicht.

Guenther
Nachwuchs
Nachwuchs
Beiträge: 54
Registriert: 02.11.2018, 11:50
Geschlecht:

Re: Installation auf 1903 läuft durch, aber beim "..Windows wird konfiguriert .. " startet dann das alte Windows 10

Beitrag von Guenther » 19.06.2019, 19:48

Danke für die Info:
Mir war nicht bewusst, dass im UEFI Bios installiert kein Bootsektor mehr existiert. Dass der alte MBR nur als Notlösung und zum Schutz des UFI da ist, war mir bekannt.
Damit würde ich ja mit jedem Aufruf des bcdboot - Tools ja das System zerstören? Ist das bei mir schon der Fall:
ich gab ein bcdedit /enum, das is die Ausgabe:

PS C:\windows\system32> bcdedit /enum

Windows-Start-Manager
---------------------
Bezeichner {bootmgr}
device partition=\Device\HarddiskVolume3
path \EFI\Microsoft\Boot\bootmgfw.efi
description Windows Boot Manager
locale en-us
inherit {globalsettings}
default {default}
resumeobject {a6e1868f-34f0-11e9-9ed6-bceb755eb889}
displayorder {default}
toolsdisplayorder {memdiag}
timeout 30

Windows-Startladeprogramm
-------------------------
Bezeichner {default}
device partition=C:
path \windows\system32\winload.efi
description Windows 10
locale en-us
inherit {bootloadersettings}
isolatedcontext Yes
allowedinmemorysettings 0x15000075
osdevice partition=C:
systemroot \windows
resumeobject {a6e1868f-34f0-11e9-9ed6-bceb755eb889}
nx OptIn
bootmenupolicy Standard
PS C:\windows\system32>

Ich mache gerade ein Backup der C und werde dann mal versuchen, den Eintrag zu löschen. Ich weiß das aus früheren Updateversuchen, dass sich der Schlüssel sperrt! Mal schaun!
Bin eigentlich etwas zu ruhig, da nirgends im Register der Schlüssel auftaucht. Seltsam!

Benutzeravatar
DK2000
Superhirn
Superhirn
Beiträge: 1479
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: Installation auf 1903 läuft durch, aber beim "..Windows wird konfiguriert .. " startet dann das alte Windows 10

Beitrag von DK2000 » 19.06.2019, 19:57

bcdboot zertört da nichts, da das Tool von sich aus erkennt, ob UEFI- oder BIOS-Mode. In Zweifelsfall kann man das aber eingeben:

bcdboot C:\Windows /f UEFI oder bcdboot C:\Windows /f BIOS

Und der BCD sollte sich beim Upgrade eigentlich nicht sperren, da ansonsten ein Upgrade unmöglich wird. Lese dass jetzt zum dritten Mal, dass es ein solches Problem gibt, aber die Ursache dafür ist mir unbekannt.

Guenther
Nachwuchs
Nachwuchs
Beiträge: 54
Registriert: 02.11.2018, 11:50
Geschlecht:

Re: Installation auf 1903 läuft durch, aber beim "..Windows wird konfiguriert .. " startet dann das alte Windows 10

Beitrag von Guenther » 19.06.2019, 20:21

Hi,
habe versucht den Eintrag zu löschen. Der von Dir angegebene Befehl wird nicht akzeptiert /unbekannter Befehl.
Im gesamten Register ist der Schlüssel nicht vorhanden.
Wie kann ich denn die Ruhestandsaktivierung sonst noch abschalten? Habe ein Tool von Mainboardhersteller ASrock aktiviert (Energiesparmodus), jetzt um gestellt auf "Standard" und alles deaktiviert. Mach jetzt Neustart

Dann stelle ich fest, dass nur wenig Befehle mit bcdedit zugelassen sind. Ich las im Netz, dass man im Abgesicherten Modus arbeiten muss. Ich konnte den BCD zum Beispiel für en Backup nicht exportieren, weil der Zugriff bisher verweigert wurde!
Mache morgen weiter! :-)
Zuletzt geändert von Guenther am 19.06.2019, 20:33, insgesamt 1-mal geändert.

Benutzeravatar
DK2000
Superhirn
Superhirn
Beiträge: 1479
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: Installation auf 1903 läuft durch, aber beim "..Windows wird konfiguriert .. " startet dann das alte Windows 10

Beitrag von DK2000 » 19.06.2019, 20:31

Was passiert denn, wenn Du das eingibts:

Code: Alles auswählen

bcdedit /enum {a6e1865f-34f0-11e9-9ed6-bceb755eb889}
Wenn es denn Abschitt noch gibt, sollte man den auch löschen können:

Code: Alles auswählen

bcdedit /delete {a6e1865f-34f0-11e9-9ed6-bceb755eb889} /cleanup 
Habe ich gerade mal in der VM getestet un es wird ausgeführt.

Den Ruhezustand deaktivieren: powercfg -h off

Guenther
Nachwuchs
Nachwuchs
Beiträge: 54
Registriert: 02.11.2018, 11:50
Geschlecht:

Re: Installation auf 1903 läuft durch, aber beim "..Windows wird konfiguriert .. " startet dann das alte Windows 10

Beitrag von Guenther » 19.06.2019, 20:34

PS C:\windows\system32> bcdedit /enum {a6e1865f-34f0-11e9-9ed6-bceb755eb889}
Ungültiger Befehlszeilenschalter: /encodedCommand
Führen Sie "bcdedit /?" aus, um die Befehlszeilenunterstützung aufzurufen.
Falscher Parameter.
PS C:\windows\system32>

:(

Guenther
Nachwuchs
Nachwuchs
Beiträge: 54
Registriert: 02.11.2018, 11:50
Geschlecht:

Re: Installation auf 1903 läuft durch, aber beim "..Windows wird konfiguriert .. " startet dann das alte Windows 10

Beitrag von Guenther » 19.06.2019, 20:35

PS C:\windows\system32> bcdedit /delete {a6e1865f-34f0-11e9-9ed6-bceb755eb889} /cleanup
Der angegebene Löschbefehl ist nicht gültig.
Führen Sie "bcdedit /?" aus, um die Befehlszeilenunterstützung aufzurufen.
Falscher Parameter.
PS C:\windows\system32>

--->>> abgesicherter Modus?

Benutzeravatar
DK2000
Superhirn
Superhirn
Beiträge: 1479
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: Installation auf 1903 läuft durch, aber beim "..Windows wird konfiguriert .. " startet dann das alte Windows 10

Beitrag von DK2000 » 19.06.2019, 20:41

Ach, Moment, Du bist in der Powershell. Ja, da bekomme ich das auch.

Gebe in der Powershell vorher cmd ein, um in die alte Eingabeaufforderung zu wechseln. Nicht alle alten Befehle lassen sich in der Umgebung der Powershell ausführen. Das vergesse ich da immer zu erwähnen, weil ich schon ganz automatisch ohne Nachzudenken da cmd eingebe. Sorry.

Und, in der Registry sollte der Eintrag hier zu finden sein:

Code: Alles auswählen

HKEY_LOCAL_MACHINE\BCD00000000\Objects

Guenther
Nachwuchs
Nachwuchs
Beiträge: 54
Registriert: 02.11.2018, 11:50
Geschlecht:

Re: Installation auf 1903 läuft durch, aber beim "..Windows wird konfiguriert .. " startet dann das alte Windows 10

Beitrag von Guenther » 19.06.2019, 20:46

Register: Das darf nicht wahr sein: so um die 20 Einträge, nach dem a64 ändern sich die Nummern, der ´Rest ist un verändert.

Guenther
Nachwuchs
Nachwuchs
Beiträge: 54
Registriert: 02.11.2018, 11:50
Geschlecht:

Re: Installation auf 1903 läuft durch, aber beim "..Windows wird konfiguriert .. " startet dann das alte Windows 10

Beitrag von Guenther » 19.06.2019, 20:59

jetzt konnte ich löschen, bcdedit findet den Eintrag n cht mehr, bcdboot aber schon. Aber in der BCDboot ist jetzt der Fehlereintrag - kann nicht zugriefen weg. Seltsamer weise lauten die Einträge:

a6e dann die Ziffernfolge 1869c,, dann b, dann f usw. der Rest ab dem ersten - ist dann identisch.

Das kann mir jetzt ggf. geholfen haben. bcdboot c:\windwos /v scheint jetzt klar zu sein und legt wieder einen neun (nach a6e) an

Ich starte jetzt nochmal das Update, das dauert bei mir aber bis zu vier Stunden!!
Bis dahinherzlichen Dank
Servus
Günther

Benutzeravatar
DK2000
Superhirn
Superhirn
Beiträge: 1479
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: Installation auf 1903 läuft durch, aber beim "..Windows wird konfiguriert .. " startet dann das alte Windows 10

Beitrag von DK2000 » 19.06.2019, 21:02

Gut, wollte gerade vorschlagen, die Systempartition zu formatieren und alles mittels bcdboot neu anlegen zu lassen.

Das der Eintrag, in meinem Falle {2fa483c4-6118-11e9-931c-005056c00008} öfters erscheint in der Registry, ist da wohl normal. Allerdings bei mir sind das nur vier Einträge nach dem beschriebenen Schema.

Drücke Dir da die Daumen, dass es jetzt klappt.

Guenther
Nachwuchs
Nachwuchs
Beiträge: 54
Registriert: 02.11.2018, 11:50
Geschlecht:

Re: Installation auf 1903 läuft durch, aber beim "..Windows wird konfiguriert .. " startet dann das alte Windows 10

Beitrag von Guenther » 19.06.2019, 23:48

Mist, hat nicht geklappt, diesmal konnte das Update nicht mal ganz abschließen.
Fehlercode.txt
Und wieder ist er BCD d<bei! Morgen Deinen letzten Gedanken, umsetzen? formatieren der Systempartition und wieder einrichten mit BCDboot? Ist aber keine Neuinstallation oder?
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

Benutzeravatar
DK2000
Superhirn
Superhirn
Beiträge: 1479
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: Installation auf 1903 läuft durch, aber beim "..Windows wird konfiguriert .. " startet dann das alte Windows 10

Beitrag von DK2000 » 20.06.2019, 00:09

Ist aber interessant. Jetzt meckert er über den Einrag {a6e18660-...}. Vorher war es {a6e1865f-...}. Scheinen da also mehrer dieser Einräge ungültig zu sein.

Nein, eine Neuinstallation ist es nicht. Es wird die die EPS (EFI-Systempartition) neu gemacht. bcdboot holt sich alles was es braucht aus dem Ordner C:\Windows\Boot.

Ich weiß jetzt nur gerade nicht, ob Windows Dich da so ohne weiteres ran lässt. Ansonsten musst Du das über die Konsole des Installationsmediums machen bzw. die Windows RE Umgebung starten. Würde das so oder so offline machen, also Windows läuft nicht.

Die ESP muss FAT32 sein.Und dann

Code: Alles auswählen

 bcdboot C:\Windows /l de-de /s S: /f UEFI
C:\Windows -> sollte klar sein; kann sich aber in der WinPE/RE Umgebung verschieben.
S: -> ist der temporäre Buchstabe für die Systempartition; den musst Du vergeben mittels diskpart.

Wenn alles klappt, hast Du dann einen ganz neuen BCD wie nach einer Neuinstallation. Die Registry wird entsprechen automatisch angepasst.

Würde mich aber mal so interessieren, wo diese ganzen Einträge herkommen. Sammeln die sich bei Upgrades und Updates an?

Guenther
Nachwuchs
Nachwuchs
Beiträge: 54
Registriert: 02.11.2018, 11:50
Geschlecht:

Re: Installation auf 1903 läuft durch, aber beim "..Windows wird konfiguriert .. " startet dann das alte Windows 10

Beitrag von Guenther » 20.06.2019, 09:05

Guten Morgen!
Für mich ist Windows PE Neuland, habe es bisher immer vermieden damit zu arbeiten. Daher kann ich dort nur einsteigen wenn ich zeitlich den Rücken frei habe, also erst gegen späten Nachmittag.
Die Datei "a6e..." wird immer dann neu geschrieben, wenn ich bcdboot laufen hab lassen. dann wird fortnummeriert. Soll ich die vielen Einträge im Register löschen und dann einmal bcdboot laufen lassen?
Es könnte auch sein, dass die vielen Versuche eines Updates hier Einträge verursacht haben!

Jetzt mal mit der WindowsPE :-/

Antworten