UEFI: nur Windows Boot Manager im Bootmenü [gelöst]

Alle Fragen und Antworten die Linux betreffen. Egal ob Styling oder zum System.
Antworten
jangbooter
Neuling
Neuling
Beiträge: 6
Registriert: 26.12.2019, 14:46

UEFI: nur Windows Boot Manager im Bootmenü [gelöst]

Beitrag von jangbooter » 29.12.2019, 10:22

Hallo

die Frage hat wahrscheinlich weniger mit Linux oder Windows zu tun...

Auf einem Acer-Laptop mit 2 Festplatten war auf der ersten HD Windows 7 vorinstalliert und wurde auf Windows 10 aktualisiert. Auf einem unpartitionierten Bereich der zweiten Festplatte habe ich Linux Mint installiert (mit der Option Linux und Windows Boot Manager nebeneinander). Der Linux-Installer hat darafhin auf der 2. HD eine zusätzliche EFI-Systempartition angelegt.

In den UEFI-Firmware-Einstellungen (InsydeH2O Rev. 5.0) habe ich für die Boot-Reihenfolge einen möglichen Eintrag für jede Harddisk plus einen Eintrag Windows Boot Manager. Ich habe folgende Boot-Reihenfolge festgelegt:

Code: Alles auswählen

1. HDD1: Samsung SSD 860 EVO 2TB
2. HDD0: LITEON IT L8T-256L96
3. Windows Boot Manager
Auf den Plätzen 4. bis 9. folgen noch CD-Laufwerk, USB-Laufwerke und Netzwerk-Boot

Auf HDD1 ist die EFI-System-Partition mit dem Eintrag für Linux, auf HDD 0 die EFI-System-Partition mit dem Eintrag für Windows 10. Obwohl HDD1 ganz oben steht, wird trotzdem Windows von HDD0 gestartet.

Gehe ich nach dem Einschalten mit F12 ins Boot-Menü wird nur die Option "Windows Boot Manager" angeboten. Ich habe auch schon den Eintrag EFI\ubuntu in die ESP auf HDD0 kopiert und versuchsweise auf Legacy-Boot und wieder zurückgestellt (weil ich dachte, dass dann die EFI-Systempartitionen erneut analysiert werden).

Was ich noch versuchen könnte, ist Linux zu löschen und erneut zu installieren, diesmal mit der Option den Bootloader direkt in die ESP mit dem Windows Bootmanager zu installieren. Aber es muß doch einen weniger "brachialen" Weg geben.

LG
jangbooter

Tante Google

UEFI: nur Windows Boot Manager im Bootmenü [gelöst]

Beitrag von Tante Google » 29.12.2019, 10:22


Benutzeravatar
DK2000
Elite
Elite
Beiträge: 2338
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: UEFI: nur Windows Boot Manager im Bootmenü

Beitrag von DK2000 » 29.12.2019, 10:40

Da fehlt eigentlich im UEFI Boot Menü der Eintrag für Linux. Der wird bei der Installation von Grub eingetragen. Automatisch vom UEFI aus wird der dort nicht eingetragen.

Muss ich gerade mal testen, was Linux Mint da so macht, wenn man das automatisch installieren lässt. Normaler Weise verwende ich da immer die manuelle Option.

---

Hier hat das Setup die den Eintrag soweit richtig geschrieben:

Code: Alles auswählen

tiger@mint-virtual-machine:~$ efibootmgr
BootCurrent: 0004
Timeout: 2 seconds
BootOrder: 0004,0001,0006,0000,0002,0003
Boot0000* EFI Network
Boot0001* Windows Boot Manager
Boot0002* EFI VMware Virtual SATA Hard Drive (0.0)
Boot0003* EFI VMware Virtual SATA Hard Drive (2.0)
Boot0004* ubuntu
Boot0006* EFI VMware Virtual SATA CDROM Drive (1.0)
tiger@mint-virtual-machine:~$ 
BootCurrent steht auf 0004, also den Eintrag für Linux. Nachteil hier ist allerdings, dass Windows und Linux sich die ESP teilen:

Code: Alles auswählen

Boot0001* Windows Boot Manager	HD(2,GPT,5a698f24-71b9-4ce2-b513-0f67f0d5c7db,0x109000,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)
Boot0004* ubuntu	        HD(2,GPT,5a698f24-71b9-4ce2-b513-0f67f0d5c7db,0x109000,0x32000)/File(\EFI\ubuntu\shimx64.efi)
Das funktioniert zwar, kann aber beim nächsten Upgrade von Windows zu Problemen führen.

Eine zweite ESP wurde jetzt hier nicht angelegt.

ecerer

Re: UEFI: nur Windows Boot Manager im Bootmenü

Beitrag von ecerer » 29.12.2019, 11:43

Ich kenn mich damit wenig aus, aber wenn du die Windows-Platte im UEFI deaktivierst, dann Mint installierst, müsstest du doch einen funktionierenden Eintrag in der Boot-Reihenfolge haben.
Was hast du dann wenn du die Windows-Platte wieder aktivierst?

jangbooter
Neuling
Neuling
Beiträge: 6
Registriert: 26.12.2019, 14:46

Re: UEFI: nur Windows Boot Manager im Bootmenü

Beitrag von jangbooter » 29.12.2019, 13:45

DK2000 hat geschrieben:
29.12.2019, 10:40
Da fehlt eigentlich im UEFI Boot Menü der Eintrag für Linux. Der wird bei der Installation von Grub eingetragen. Automatisch vom UEFI aus wird der dort nicht eingetragen.
Dank deiner Anregung (efibootmgr) habe ich jetzt folgendes versucht (aus irgendeinem Grund ist HDD0 = /dev/sdb und HDD1 = /dev/sda):

Code: Alles auswählen

mint@mint:~$ sudo efibootmgr --create --disk /dev/sdb --part 1 --label "GRUB" --loader \\EFI\\ubuntu\\grubx64.efi
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0006,0005,2001,2002,2003
Boot0000* Windows Boot Manager x
Boot0001* USB HDD: KingstonDataTraveler 2.0
Boot0002* Unknown Device: 
Boot0003* Unknown Device: 
Boot0004* Unknown Device: 
Boot0005* Windows Boot Manager
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot2003* EFI Network
Boot0006* GRUB
Die Einträge mit Unknown device stammen von Versuchen mit dem Windows-Tool bootice. Der Eintrag GRUB wird anschließend im Bootmenü NICHT angezeigt. Starte ich dann wieder vom Stick und sehe mir die Einträge an, sieht es so aus:

Code: Alles auswählen

mint@mint:~$ efibootmgr
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0005,2001,2002,2003
Boot0000* Windows Boot Manager x
Boot0001* USB HDD: KingstonDataTraveler 2.0
Boot0002* Unknown Device: 
Boot0003* Unknown Device: 
Boot0004* Unknown Device: 
Boot0005* Windows Boot Manager
Boot0006* GRUB
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot2003* EFI Network
Der Eintrag Boot0006 ist noch da, fehlt aber in der Liste Boot-Order. Dasselbe passiert, wenn ich shimx64.efi verwende, oder wenn ich auf die zweite ESP verweise (die nur Linux-Einträge enthält).

Im Detail sehen die Einträge so aus (0005 = einzig funktionierender Eintrag)

Code: Alles auswählen

Boot0005* Windows Boot Manager	HD(1,GPT,4ff7535d-5a52-4d1e-8cd2-b81b89468dba,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...0................
Boot0006* GRUB	HD(1,GPT,4ff7535d-5a52-4d1e-8cd2-b81b89468dba,0x800,0x32000)/File(\EFI\ubuntu\grubx64.efi)
Boot0007* Mint aus eigener ESP	HD(7,GPT,ebc3efc7-5446-4290-84d1-17ae7fac0bf2,0xc9840800,0x100800)/File(\EFI\ubuntu\grubx64.efi)/dev/sda
Woher die Zeichenkette "WINDOWS.........x...B.C.D.O.B.J.E.C.T.=..9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...0................"
beim Windows Boot-Manger kommt, weiß ich nicht.

Secure-Boot ist disabled. Trotzdem scheint UEFI die Boot-Einträge irgendwie "abzulehnen".

Ratlos
jangbooter

Benutzeravatar
DK2000
Elite
Elite
Beiträge: 2338
Registriert: 03.04.2018, 00:07
Geschlecht:

Re: UEFI: nur Windows Boot Manager im Bootmenü

Beitrag von DK2000 » 29.12.2019, 15:37

Boot0006 und Boot0007, hast Du den selber erstellt?

Bei UEFI, egal ob mit oder ohne Secure Boot, zeigt der eigentlich immer auf die \EFI\ubuntu\shimx64.efi, so wie es bei mir in der Testinstallation ohne Secure Boot auch der Fall ist. Jedenfalls bei einer auf Ubuntu basierenden Distribution.

Bekommst Du Linux überhaupt gebootet?

jangbooter
Neuling
Neuling
Beiträge: 6
Registriert: 26.12.2019, 14:46

Gelöst - Re: UEFI: nur Windows Boot Manager im Bootmenü

Beitrag von jangbooter » 29.12.2019, 18:17

DK2000 hat geschrieben:
29.12.2019, 15:37
Boot0006 und Boot0007, hast Du den selber erstellt?

Bei UEFI, egal ob mit oder ohne Secure Boot, zeigt der eigentlich immer auf die \EFI\ubuntu\shimx64.efi, so wie es bei mir in der Testinstallation ohne Secure Boot auch der Fall ist. Jedenfalls bei einer auf Ubuntu basierenden Distribution.

Bekommst Du Linux überhaupt gebootet?
Ja, die Einträge habe ich selbst erstellt und nein Linux bekomme ich von der Festplatte nicht gebootet...

Zumindest bis eben.

Meine Vermutung, dass es an der Firmware liegt, die die Boot-Einträge trotz abgeschaltetem Secure-Boot nicht akzeptiert hat mich auf die richtige Fährte gebracht und ich habe schließlich diese Anleitung (von Acer selbst?) in einem Ubuntu-Forum gefunden: https://media-cdn.ubuntu-de.org/forum/a ... _Linux.pdf

Die notwendigen Anpassungen im UEFI-BIOS in Kurform sind:
  • Im Security-Tab: Supervisor-Passwort fürs UEFI-BIOS vergeben (damit werden einige Security-Optionen im UEFI-BIOS freigeschaltet)
  • Im Boot-Tab: Secure-Boot einschalten
  • Im Security-Tab: "Select an UEFI file as trusted for executing" auswählen (dieser Punkt ist bei abgeschaltetem Secure-Boot nicht auswählbar)
  • dann navigiert man zum gewünschten Eintrag in der EFI-Systempartition, beispielsweise über HDD0 > EFI > ubuntu zu grubx64.efi, wählt es aus, vergibt einen Namen fürs Bootmenü und aktiviert den Eintrag mit [Yes]
  • Save and exit
Anschließend taucht der Eintrag im Bootmenü auf und funktioniert wie erwartet!

Die von mir erstellten Boot-Einträge funktionieren alle, wenn man sie über diese Methode aktiviert (Sowohl 1. als auch 2. EFI-System-Partition und sowohl grubx64.efi als auch shimx64.efi). Man kann auch beim Runterfahren von Windows mit Shift-Taste die Linux-Einträge für den nächsten Bootvorgang auswählen.

Und man könnte anschließend sogar Secure-Boot im UEFI wieder disablen und die freigeschalteten Einträge funktionieren weiterhin. Werde es aber eingeschaltet lassen.

Ganz logisch erscheint mir das Verhalten der UEFI-Firmware (InsydeH2O Rev. 5 in einem Acer Travelmate 7) allerdings nicht, gelinde gesagt. Zumindest ist der Weg zum lauffähigen Bootvorgang verwirrend.

Nochmals danke für den Hinweis zu efibootmgr, mit den von mir verwendeten Windows-Tools hätte ich die Spur nie gefunden.
:dankeschoen:
jangbooter


Antworten