Sandbox - Ich kann's nicht

Forumsregeln
Bitte die betreffende Version im Topic mit angeben.

Antwort erstellen


Diese Frage dient dazu, das automatisierte Versenden von Formularen durch Spam-Bots zu verhindern.
Smilies
:) ;) :smile: :lol: :hihi: :D :rofl: :muahah: :( :pff: :kopfstreichel: :ohno: :betruebt: :heulen: :kopfkratz: :duckundweg: :o :? :oops: :psst: :sauer: :-P :daumenrunter: :daumen: :dankeschoen: :thx: :dafür: :gähn:
Mehr Smilies anzeigen

BBCode ist eingeschaltet
[img] ist eingeschaltet
[flash] ist ausgeschaltet
[url] ist eingeschaltet
Smilies sind eingeschaltet

Die letzten Beiträge des Themas

Ich habe die Datenschutzerklärung gelesen und bin damit einverstanden.

   

Ansicht erweitern Die letzten Beiträge des Themas: Sandbox - Ich kann's nicht

Re: Sandbox - Ich kann's nicht

von R3pSol » 23.04.2019, 22:25

AScheisse, nein, das ist nicht meine Aufgabe MS sucks

Re: Sandbox - Ich kann's nicht

von jschroettle » 12.03.2019, 12:42

Nach Installation des Updates 18351.7 (KB4492310) kommt es wieder zum 'üblichen' Fehler, die Sandbox startet nicht mehr :betruebt:

Re: Sandbox - Ich kann's nicht

von jschroettle » 09.03.2019, 18:03

Gefunden, DxDiag zeigt den WDDM-Level an. Mein Entwickler-System (NUC6i7) mit 1809 und neuestem Intel (DCH) Treiber ist WDDM 2.1 (wenn DxDiag die Wahrheit sagt). Laut Wikipedia müsste 1809 schon WDDM 2.4 unterstützen. Der NUC5i5 mit 1903 Insider ist sogar nur WDDM 2.0.
Noch ein weiter Weg bis WDDM 2.5...

Re: Sandbox - Ich kann's nicht

von jschroettle » 09.03.2019, 17:52

Vielen Dank für den Hinweis mit WDDM 2.5. Das erklärt das zähe Verhalten meiner Sandbox.
Ich habe die 1903 auf einem NUC5i5. Für den Core i5 gibt es von Intel (leider) keine neueren DCH Treiber mehr. Ich vermute mal mein Intel Treiber vom September '18 ist bezüglich WDDM nicht auf dem neuesten Stand.
Ich habe versucht über Google ein Tool zu finden das den unterstützen WDDM-Level anzeigt. Leider habe ich nichts gefunden und GPU-Z und "GPU Caps Viewer" zeigen dies auch nicht an. Kennst du ein Tool mit dem ich prüfen kann welchen WDDM Level mein System wirklich hat?

Re: Sandbox - Ich kann's nicht

von DK2000 » 09.03.2019, 15:28

jschroettle hat geschrieben:
09.03.2019, 14:25
(Anscheinend wird die Bildschirm-Ausgabe über Remote-Desktop erledigt)
So sieht das aus. Ist eine für Hyper-V typische RDP Verbindung mit den 'üblichen' Einschränkungen, Besonders was das Skalieren der Schrift angeht.

Und ja, wenn man die Sandbox einfach so schließt, kommt da der eine oder andere Fehler. Kann man zwar wohl ignorieren, aber ist dennoch unschön.
jschroettle hat geschrieben:
09.03.2019, 14:25
Bevor die Sandbox wirklich nutzbar wird und mit VirtualBox/VMWare konkurrieren kann muss MS noch viel Arbeit investieren...
Das wird es wohl nie. Mich persönlich stört es ja schon, dass Hyper-V (Typ 1 Hypervisor) verwendet wird und dadurch bei Installation der Sandbox das Host-Windows selber in einer VM landet. Und das andere, was mich an der Sandbox stört ist, dass sie keinen Reboot überlebt. Man kann dort keine Installationen testen, welche einen Neustart erfordern. Und das dritte ist die Anforderungen an die Grafikkarte. Erst wenn diese bzw. dessen Treiber mind. WDDM 2.5 unterstützen, läuft das WIndows in der Sandbox geschmeidig. Da ich nur WDDM 2.1 habe, läuft alles über eine Softwareanwender, was in der Sandbox deutlich spürbar ist.

Was Desktop-Virtualisierung angeht, so favorisiere ich da auch VirtualBox/VMWare Workstation bzw. Player (Typ 2 Hypervisor).

Ich werde die Sandbox da mal weiter beobachten, aber im Moment hat sie da für mich nur einen eingeschränkten bis gar keinen Nutzen.

Re: Sandbox - Ich kann's nicht

von jschroettle » 09.03.2019, 14:25

Ja, du hast natürlich Recht. Windows ist NICHT aktiviert.
Man auch nicht die Screen-Skalierung auf 150% einstellen, weniger wegen der Aktivierung sondern wegen der Remote-Desktop-Sitzung.
(Anscheinend wird die Bildschirm-Ausgabe über Remote-Desktop erledigt)
Auf meinem 4K-Bildschirm hat die Sandbox ein riesiges Fenster mit fast unlesbar kleiner Schrift. Und permanent einstellen geht ja nicht.
Wenn man das Windows in der Sandbox runterfährt, dann kommt eine Fehlermeldung dass die Remote-Desktop Sitzung unerwartet geschlossen wurde.
Bevor die Sandbox wirklich nutzbar wird und mit VirtualBox/VMWare konkurrieren kann muss MS noch viel Arbeit investieren...

Re: Sandbox - Ich kann's nicht

von moinmoin » 08.03.2019, 17:26

Super. :daumen: Aber Windows ist wirklich aktiviert in der Sandbox?
Bei mir nicht.

Re: Sandbox - Ich kann's nicht

von jschroettle » 08.03.2019, 16:57

Update: Mit der Version 18351.1 funktioniert die Sandbox jetzt bei mir.
Vorgehensweise: Sandbox und Hyper-V in der 18348.8 deaktiviert, die Containers und den Registry-Eintrag gelöscht und anschließend Neustart.
Inplace-Upgrade auf die 18351.1, wie gewohnt mehrere Neustarts und mein Dual-Boot mit Ubuntu bleibt erhalten.
Anschließend im 18351.1 erstmal nur die Sandbox aktiviert. Der erste Start dauert etwas, aber dann kommt die virtuelle Maschine. Juhu!
(Interessanterweise ist dann in Programme&Features keinerlei Haken beim Hyper-V, ich hatte da schon etwas erwartet)
Zum Ausprobieren noch Hyper-V und die Windows Hypervisor Plattform (für VirtualBox) aktiviert mit Neustart
Auch jetzt funktioniert die Sandbox noch. Ist praktisch da das Windows in der Sandbox aktiviert ist.

Re: Sandbox - Ich kann's nicht

von jschroettle » 01.03.2019, 17:40

Danke nochmal, ich geb's jetzt auf. Und gehe wieder zurück zum LTSC in Virtualbox, geht auch gut und braucht kaum Platz.
Der Vollständigkeit halber, was habe ich probiert:
Nochmal Sandbox entfernt, Container gelöscht, Registry-Entrag gelöscht, Neustart, Sandbox installiert, Neustart und Sandbox gestartet => 0x80070002
Der FileAccessErrorView bekommt nur die 0x104 und 0xc00000a2, andere kommen da nicht vor. Erklärt also nicht die 0x80070002
Aber wahrscheinlich kann der FileAccessErrorView nicht in die virtuelle Maschine 'reinschauen'.
Ich werde es mit der finalen 19H1 dann wieder probieren.
Beste Grüsse
Josef

Re: Sandbox - Ich kann's nicht

von DK2000 » 01.03.2019, 14:22

Die Dateien gibt es bei mir auch nicht, aber das stört die Sandbox nicht weiter. Startet normal.

Ist Deutsches Windows 10 Pro 64bit (18346.1).

Irgendwie fehlt der Sandbox noch so etwas wie eine Reparaturoption für sich selber. Kann sie da nicht dazu überreden, sich selbst zu fixen.

Vermutlich musst Du Sandbox und WDAG deinstallieren, und dann Ordner leeren und Registryeinträge entfernen. Dann sollte alles neu erstellt werden.

Ansonsten wüsste ich da im Moment auch nicht weiter.

Die fehlenden Dateien bei mir, die zum Fehler 0x80070002 führen, waren immer die Dateien, welche ich da aus dem Container-Ordner gelöscht habe. Aber kann die Sandbox auch nichts dazu bewegen, sie einfach so neu zu erstellen.

---

Und bei dem Tool FileAccessErrorView sortiere mal nach 0xc0000034. Das ist der Staus-Code für 'Der Objektname wurde nicht gefunden.'. Der führt dann zu 0x80070002, sofern das Object eine Datei ist.

Re: Sandbox - Ich kann's nicht

von jschroettle » 28.02.2019, 19:05

Gute Idee, hilft bei mir aber nicht.
Das Löschen war erst gar nicht so einfach, da ich auch den WindowsApplicationDefenderGuard (WDAG) eingeschaltet hatte.
Beide (WDAG und Sandbox) nutzen das gleiche BaseImage! Wenn nur einer abgeschaltet wird dann ist das Image immer noch 'aktiv' (und kann in der Datenträgerverwaltung gesehen werden). Ein Löschen ist dann nicht möglich da 'in use'. Außerdem wird das Image bei jedem Neustart wieder erstellt. Das FileAccessErrorView liefert beim Fehler viele Errors 0x00000104 (symbolic link), das scheint ok zu sein.
Ich habe zwei 0xc00000a2 (write protection) bei 'Delete File' bei
\Device\HarddiskVolume8\Files\Windows\System32\DriverStore\en-US\wnetvsc.inf_loc
\Device\HarddiskVolume8\Files\Windows\System32\drivers\en-US\netvsc.sys.mui
Das Volume8 scheint das Image zu sein. In meinem Windows existieren diese beiden Files nicht!
Könnte das wegen 'en-US' mit der Sprache zu tun haben? Habt ihr ein deutsches Windows mit funktionierender Sandbox?

Re: Sandbox - Ich kann's nicht

von DK2000 » 28.02.2019, 16:43

Das kann ich Dir auch nicht so genau sagen. hatte da gerade den Fehler 0x80070002 hinbekommen, aber den zu beseitigen ist da wieder etwas schwieriger.

- Sandbox deinstallieren

- Alles aus C:\ProgramData\Microsoft\Windows\Containers löschen

- Unter HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Containers\CmService\Images den Ordner Portable-10.0.18342.8
löschen. Die Build 18342.8 musst Du eventuell Deiner Build anpassen.

- Sandbox wieder installieren.

Jetzt sollte das Base Image wieder komplett neu erstellt werden. Jedenfalls war dadurch der 0x80070002 weg bei mir.

Re: Sandbox - Ich kann's nicht

von jschroettle » 28.02.2019, 15:20

Danke für den Tipp mit dem FileAccessView. Probier' ich mal aus.
Es gibt gute und schlechte Neuigkeiten.
Die Gute zuerst: Der Inplace-Upgrade hat funktioniert und mein Dual-Boot funktioniert immer noch :daumen:
Noch eine Gute: Ein Container ist jetzt da, sieht auch nach vhd/vhdx aus. Ich war schon zuversichtlich...
Jetzt die Schlechte: Sandbox startet immer noch nicht mit dem gleichen Fehler (0x80070002).
Jetzt wird es wirklich mysteriös. Was fehlt ihm denn jetzt noch? Aber vielleicht hilft jetzt ja FileAccessView.
Ist schon fast wie in einer alten Serie, "die Auflösung gibt es in der nächsten Folge"
@DK2000: Ich habe versucht was in den Ereignissen zu 'Sandbox' zu finden. Aussichtslos. Hast du einen Pfad?

Re: Sandbox - Ich kann's nicht

von DK2000 » 28.02.2019, 14:10

Die Sandbox erzeugt das Base Image über die WCSetupAgent.exe. Der wird intern das erste mal so aufgerufen (:

WCSetupAgent.exe PrepareForSnapshot 60000 1

Habe aber jetzt keine Ahnung, ob man das einfach so manuell ausführen kann, zumal die Sandbox das Tool mit Systemrechten ausführt.

Hast Du mal überprüft, ob es noch den Ordner Windows.old gibt?

Eventuell auch mal das oben erwähnte Tool starten und im Anschluss versuchen, die Sandbox zu starten:

https://www.nirsoft.net/utils/file_acce ... _view.html

Eventuell geht daraus hervor, welche Datei da fehlen soll. In der Ereignisanzeige könnte auch etwas stehen, aber das ist teilweise schwer zu interpretieren, da Fehler nicht unbedingt als Fehler angegeben werden und Alles nur als Info ausgegeben wird.

Re: Sandbox - Ich kann's nicht

von jschroettle » 28.02.2019, 13:34

Ich probier's mal. sfc /scannow und dism /restorehealth haben erstmal nicht geholfen.
Wahrscheinlich zerschießt mir die Inplace-Installation wieder mein Dual-Boot mit Ubuntu :heulen:
Aber 'boot-repair' hilft da (https://help.ubuntu.com/community/Recov ... ingWindows)
Ich werde berichten...
Josef

Nach oben